Subject: [CDNi] I-D Action: draft-ietf-cdni-media-type-01.txt

From: [email-masked]
Date: Tue, 29 Sep 2015 07:54:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.

        Title           : CDNI Media Type Registration
        Author          : Kevin J. Ma
	Filename        : draft-ietf-cdni-media-type-01.txt
	Pages           : 6
	Date            : 2015-09-29

Abstract:
   This document defines the standard media type used by the Content
   Delivery Network Interconnection (CDNI) protocol suite, including the
   registration procedure and recommended usage of the required payload-
   type parameter .

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cdni-media-type/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-cdni-media-type-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-media-type-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Kevin Ma J <[email-masked]>
Date: Tue, 29 Sep 2015 14:55:33 +0000

updated to address Francois's nits.

> -----Original Message-----
> From: CDNi [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, September 29, 2015 10:54 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [CDNi] I-D Action: draft-ietf-cdni-media-type-01.txt
> 
> 
>  This draft is a work item of the Content Delivery Networks
> Interconnection Working Group of the IETF.
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Daryl Malas <[email-masked]>
Date: Wed, 30 Sep 2015 17:34:28 +0000

Kevin,

I have a question regarding the media-type draft.  I recognize that you
use JSON as an example in the introduction, which is fine.  The current
preferred implementations of the interfaces will likely use JSON.  As I
think through this, however, we should expect JSON to become obsolete in
the next 5 years (or so); yet, the media types will still be relevant to
some new language.  In the ³encoding considerations² and the ³Security
considerations,² should we remove specific references to using JSON?  I¹m
concerned we may somehow imply a dependency on JSON for CDNI in the
future, which I think we would want to avoid.

What are your thoughts?

Thanks,

Daryl

On 9/29/15, 8:55 AM, "CDNi on behalf of Kevin Ma J" <[email-masked]

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 30 Sep 2015 18:01:29 +0000

Hi Daryl,

  We can change it.  I think the encoding considerations text reads as informational: 

    "The CDNI protocol suite includes interfaces with JSON encoded messages"

  Doesn't say it has to be JSON, just says that some are.  I think the "8bit or binary" still works; pretty much covers everything.  But we can remove "JSON encoded"; I don't think it hurts.

  In the security considerations case, the text could be overly restrictive in scope:

    "CDNI interfaces that return JSON encoded data may be (mis)interpreted"

  Really, any message may be misinterpreted, so I don't see any harm in removing "JSON encoded", though I don't read the text as placing any dependency on JSON.  

  I'm open to any other opinions from the WG, but if no one dissents, I will remove "JSON encoded" from those two sections.

thanx!

--  Kevin J. Ma

> From: Daryl Malas [mailto:[email-masked]]
> Sent: Wednesday, September 30, 2015 1:34 PM
> To: Kevin Ma J; [email-masked]
> Subject: Re: [CDNi] I-D Action: draft-ietf-cdni-media-type-01.txt
> 
> Kevin,
>

---

From: "Ali C. Begen" <[email-masked]>
Date: Wed, 30 Sep 2015 21:04:20 +0300

I think you might say "encoded data/message" instead of "JSON encoded
data/message"

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 30 Sep 2015 18:05:54 +0000

fair enough.  thanx Ali!

> From: Ali C. Begen [mailto:[email-masked]]
> Sent: Wednesday, September 30, 2015 2:04 PM
> To: Kevin Ma J
> Cc: Daryl Malas; [email-masked]
> >   Doesn't say it has to be JSON, just says that some are.  I think the
> "8bit or binary" still works; pretty much covers everything.  But we can
> remove "JSON encoded"; I don't think it hurts.
> >
> >   Really, any message may be misinterpreted, so I don't see any harm in
> removing "JSON encoded", though I don't read the text as placing any
> dependency on JSON.
> >
> >   I'm open to any other opinions from the WG, but if no one dissents, I
> will remove "JSON encoded" from those two sections.
> >
> > thanx!
> >
> > --  Kevin J. Ma
> >

---

From: Daryl Malas <[email-masked]>
Date: Wed, 30 Sep 2015 18:09:32 +0000

Kevin,

I think this approach works, and I agree with Ali’s perspective. I just
want to avoid any implications of a dependency that may become obsolete,
hopefully before CDNI implementations do. :-)

Thanks,

Daryl