Subject: [CDNi] Nits regarding draft-ietf-cdni-media-type-00.txt

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 28 Sep 2015 12:44:51 +0000

Hi Kevin,

Thanks for progressing this document. 
Could you consider the following nits whenever you get to rev it up?
Thanks

Francois

*** RFC6770 does not discuss “CDN federation”, hence:
OLD:
"
The CDNI working group is developing a set of protocols to enable the
   interconnection of multiple CDNs to a CDN federation, as discussed in
   [RFC6770].
“
NEW:
"
The CDNI working group is developing a set of protocols to enable the
   interconnection of multiple CDNs to a CDN federation, as discussed in
   [RFC6770].
"

*** I think “json" is most commonly referred to as “JSON” in IETF documents. Should it be capitalised here also?

*** please add an authoritative reference for JSON (RFC7159 perhaps?)

*** The introduction mentions "CDNI payload-type parameter values” and "payload-type parameter names”.  I think there is a single notion here. If I am correct, then please pick either “name” or “value” and use the same term throughout the document.

*** OLD:
“
where rhe purpose
"
NEW:
“
where the purpose
“

> On 17 Aug 2015, at 23:25, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Content Delivery Networks Interconnection Working Group of the IETF.
> 
>        Title           : CDNI Media Type Registration
>        Author          : Kevin J. Ma
> 	Filename        : draft-ietf-cdni-media-type-00.txt
> 	Pages           : 6
> 	Date            : 2015-08-17
> 
> Abstract:
>   This document defines the standard media type used by the Content
>   Delivery Network Interconnection (CDNI) protocol suite, including the
>   registration procedure and recommended usage of the required payload-
>   type parameter .
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-cdni-media-type/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-cdni-media-type-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Mon, 28 Sep 2015 12:51:29 +0000

Folks,

As agreed in Prague, we want to expedite the registration of a single Media Type for all CDNI interfaces.

This starts a 1-week Working Group Last Call on draft-ietf-cdni-media-type-00.txt. It is a very short document.
Please send any comment to the list by 5 October end of the day.

Cheers

Francois & Daryl

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: [CDNi] I-D Action: draft-ietf-cdni-media-type-00.txt
Date: 17 August 2015 23:25:00 CEST
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Abstract:

---

From: Kevin Ma J <[email-masked]>
Date: Mon, 28 Sep 2015 18:04:38 +0000

Hi Francois,

  Thanks for the review.  comments inline:

> -----Original Message-----
> From: Francois Le Faucheur (flefauch) [mailto:[email-masked]]
> Sent: Monday, September 28, 2015 8:45 AM
> To: Kevin Ma J
> Cc: Francois Le Faucheur (flefauch); [email-masked]
> Subject: Nits regarding draft-ietf-cdni-media-type-00.txt
> 
> Hi Kevin,
> 

These look the same, but I assume you want me to remove "to a CDN federation".  done.
 
> *** I think “json" is most commonly referred to as “JSON” in IETF
> documents. Should it be capitalised here also?

capitalized.

> *** please add an authoritative reference for JSON (RFC7159 perhaps?)

added.
 
> *** The introduction mentions "CDNI payload-type parameter values” and
> "payload-type parameter names”.  I think there is a single notion here. If
> I am correct, then please pick either “name” or “value” and use the same
> term throughout the document.

correct.  removed "name" and "value"; just using "payload-type parameter".

> where the purpose

fixed.

thanx!

--  Kevin J. Ma
 
> > This draft is a work item of the Content Delivery Networks
> Interconnection Working Group of the IETF.
> >