Subject: [CDNi] Yokohama minutes & URI signing

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 8 Dec 2015 22:06:28 +0000

I see in the minutes from yokohama a suggestion to use a similar anonymising technique for the ip address in a signed uri as that used for c-groupid in the logging draft. 

That would mean encrypting the ip address with a shared secret and then hashing it with the same (or a different) shared secret. 

If we're going to have to have encryption for the ip address, we might as well just encrypt the whole URI Signing Package (or whatever it's called) and not bother with hashing. 

It also made me wonder whether following logging would mean (according to the spec) the csp & ucdn doing the pick random alternate bytes dance which makes me wonder whether we should have that level of detail of how to generate a key/etc in the logging draft (& presumably repeated in the uri signing draft) or whether we should just say something along the lines of "pick a good key" with a reference to general best practice for picking a good key?

(I wasn't in the discussions but all this dancing to protect privacy feels a bit like giving ourselves a ready brek glow[1] that we're doing something but i suspect it'll largely be ignored in reality given signed uris are prevalent in the wild without all this privacy protection and i can't see what the incentive to csps is to change to something more complicated)

Ben

[1] http://youtu.be/r06VyTzLLmE

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 9 Dec 2015 15:00:09 +0000

Hi Ben,

  (as an individual)

> That would mean encrypting the ip address with a shared secret and then hashing it with the same (or a different) shared secret.

  Correct.  We discussed using the same shared secret (or private key).

> we might as well just encrypt the whole URI Signing Package (or whatever it's called) and not bother with hashing.

  The thinking here was that, for those who do not care to use the CIP IE, they wouldn't have to bother with encryption or key management.

> whether we should just say something along the lines of "pick a good key" with a reference to general best practice for picking a good key

  We probably should.  Something about randomness and how often to rotate keys?

> but i suspect it'll largely be ignored in reality given signed uris are prevalent in the wild without all this privacy protection and i can't see what the incentive to csps is to change to something more complicated

  I don't disagree with this statement, but I think the general push for privacy within IETF protocols will probably require us to put something in the spec.

--  Kevin J. Ma

From: CDNi [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
Sent: Tuesday, December 08, 2015 5:06 PM
To: [email-masked]
Subject: [CDNi] Yokohama minutes & URI signing

Ben

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 9 Dec 2015 17:27:12 +0000

Hi Kevin,

> On 9 Dec 2015, at 15:00, Kevin Ma J <[email-masked]> wrote:
> 
> Hi Ben,
>  
>   (as an individual)
>  

I hadn’t considered that scenario when I wrote my mail. They'd save having to do the encryption. They wouldn’t have to do (secure) key management but they’d still have to do (secure) secret management if they were using a shared secret instead of asymmetric signatures.

Honestly I don’t know whether saving the encryption is a meaningful saving or not. My gut says sticking to one solution for everything is better just because it leaves fewer special cases for people to get wrong. The number of implementers for this is potentially much larger than the other CDNI specs because the CSP also has to implement the signed uri spec to generate the tokens in the first place.
 
>   We probably should.  Something about randomness and how often to rotate keys?

I’m not a security expert so I’m not sure. Whoever suggest the current text is probably the expert to ask. My concern is we end up with lots of documents each specifying the same thing (possibly in slightly different ways unless someone keeps a good eye to make sure they’re perfectly aligned) rather than a reference able source that all the documents can refer to.

[It’s probably off-topic for this group, but while I’m sensitive to privacy concerns it feels like we’re being hit with a hammer to address “privacy” while operating in an environment without good general guidance being documented (or at least referenced if they do exist) so everyone (not just in CDNI) is reinventing the wheel for themselves.]
 
>   I don't disagree with this statement, but I think the general push for privacy within IETF protocols will probably require us to put something in the spec.

I’m sure it will. C’est la vie.
 
Ben
 
> [1] http://youtu.be/r06VyTzLLmE <http://youtu.be/r06VyTzLLmE>

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 9 Dec 2015 18:06:52 +0000

Hi Ben,

> Honestly I don’t know whether saving the encryption is a meaningful saving or not. My gut says sticking to one solution for everything is better just because it leaves fewer special cases for people to get wrong.

  This is a fair point.  Most folks implementing this will probably have access to a good crypto library?

> The number of implementers for this is potentially much larger than the other CDNI specs because the CSP also has to implement the signed uri spec to generate the tokens in the first place.

  Agreed.  MPEG liaison - case in point.

> My concern is we end up with lots of documents each specifying the same thing (possibly in slightly different ways unless someone keeps a good eye to make sure they’re perfectly aligned) rather than a reference able source that all the documents can refer to.

  It's a valid concern.  I don't know if the secdir review will help with this; unfortunately these crypto/privacy issues are all moving targets.  The threat models for logging IPs and logging URIs with tokens that contain IPs are arguably different, but I suppose the same encryption scheme could be used to protect both.  Is this an AD-level question (because protecting IP addresses, from a privacy perspective, does go beyond CDNI)?

thanx.

--  Kevin J. Ma

From: Ben Niven-Jenkins [mailto:[email-masked]]
Sent: Wednesday, December 09, 2015 12:27 PM
To: Kevin Ma J
Cc: [email-masked]
Subject: Re: [CDNi] Yokohama minutes & URI signing

Hi Kevin,

On 9 Dec 2015, at 15:00, Kevin Ma J <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ben,

  (as an individual)

Ben

--  Kevin J. Ma

From: CDNi [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
Sent: Tuesday, December 08, 2015 5:06 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [CDNi] Yokohama minutes & URI signing

Ben