Subject: [CDNi] Éric Vyncke's No Objection on draft-ietf-cdni-request-routing-extensions-07: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 14 Oct 2019 00:47:13 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-cdni-request-routing-extensions-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cdni-request-routing-extensions/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document. I have a couple of comments and
nits.

Regards,

-éric

== COMMENTS ==

One generic suggestion (no need to act on a COMMENT): add the definition of
"router" in this document as it is not the typical IP-layer router as in most
IETF documents.

-- Section 2.3 --
It is unclear to me whether the 3xx redirection (cfr last example) can switch
from HTTP to HTTPS or vice-versa? Should the 'httptarget' include the
scheme/protocol to be used ? In any case, the text should be clear whether the
scheme is kept between original request and the scheme in the redirected
location. Or is it specify in the OpenCache spec ?

== NITS ==

-- Abstract --
Please expand FCI at first use.

-- Requirements language --
Unusual place in the document. It will be fixed by the RFC Editor probably
later in the process.

-- Section 2 --
s/defintion/definition/, I will stop looking for typos, easier to use a spell
checker ;)

---

From: [email-masked]
Date: Mon, 14 Oct 2019 16:20:47 +0000

Hi Eric - Thank you for your review and comments. Will update the documents with nits identified with spell checker and add clarity in sec 2.3.

Thanks
Sanjay

-----Original Message-----
From: Éric Vyncke via Datatracker [mailto:[email-masked]] 
Sent: Monday, October 14, 2019 3:47 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; Kevin Ma <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [E] Éric Vyncke's No Objection on draft-ietf-cdni-request-routing-extensions-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwIDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=XRZqXyo6jLZHo0QE5Md2JDYc6SoX0yUbh4FmYkwBKkE&s=-Cx0uCkVc2A8NUrtmSSh6D_ZmCB6EIFYrXn5aeA8Cwk&e=
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dcdni-2Drequest-2Drouting-2Dextensions_&d=DwIDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=XniVbishGiO2Ao9hKqSc-hTVIWCi3T-x6GdHR4ZTgoM&m=XRZqXyo6jLZHo0QE5Md2JDYc6SoX0yUbh4FmYkwBKkE&s=Y9gOiSRJ9nzsmJK4a1sA_4fFVPPRGxAUYtXFFZ4WkJs&e= 

Regards,

-éric

== COMMENTS ==

-- Section 2.3 --

== NITS ==

-- Abstract --

-- Section 2 --