Subject: [Cellar] human readable EBML Element definitions

From: Dave Rice <[email-masked]>
Date: Sun, 13 Mar 2016 13:28:31 -0400

Hi all,
I’m looking for advice on how to present EBML Elements in a human readable form. 

The current structure in the EBML Specification is a bit messy and hard to read: https://github.com/Matroska-Org/ebml-specification/blob/master/specification.markdown#ebml-header-elements

I just tried to update this to tables with one table per Element definition: https://github.com/MediaArea/ebml-specification/blob/update-EBML-elements-to-new-definition-style/specification.markdown#ebml-header-elements

But there’s also the current form of the matroska.org presentation of the Elements at https://matroska.org/technical/specs/index.html#LevelEBML.

Any advice or comments or suggestions on what works?

Best Regards,
Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 20 Mar 2016 10:32:21 +0100

> I just tried to update this to tables with one table per Element definition: https://github.com/MediaArea/ebml-specification/blob/update-EBML-elements-to-new-definition-style/specification.markdown…

It would look better if each table had the same (full) width.

> Any advice or comments or suggestions on what works?

It depends on the target document. For a document with precise
description of each element, the more room there is for text, the
better. So your table per element is probably better.

For a document to look quickly for element values and semantic
attributes (ID, type, mandatory, multiple, default) one line per
element is better.

> Best Regards,
> Dave Rice
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman