Subject: Re: [Cellar] Encryption in Matroska

From: Steve Lhomme <[email-masked]>
Date: Sun, 4 Sep 2016 15:35:33 +0200

I agree with everything that's been said. We should remove the
elements that are not used and especially the ones better handled in
other layers.

I created an issue so we don't forget to do it
https://github.com/Matroska-Org/ebml-specification/issues/85

Not being an expert enough I will trust that the WebM encryption
elements are sufficient and good enough and we should adopt these.

2016-08-30 19:48 GMT+02:00 Sebastian G. <bastik>
<[email-masked]>:
> 21.07.2016, 15:12 Jerome Martinez:
>> Le 20/07/2016 à 20:44, Michael Bradshaw a écrit :
>>> [...]
>>>
>>> Personally, I'm in favor of just adopting WebM's encryption
>>> specification <https://www.webmproject.org/docs/webm-encryption/> and
>>> removing the other encryption features of Matroska (assuming no one is
>>> using them).
>>
>> With the same assumption (do we have real file with Matroska
>> encryption?), I am also in favour of removing old encryption features of
>> Matroska from the draft for IETF and for only integration of WebM
>> encryption elements.
>>
>>
>
> +1
>
> For interoperability and maybe because encryption can still be useful,
> even though it often has negative effects if DRM is so anti-consumer
> that its restrictions make legitimate use harder, I an in favor of
> adopting WebM encryption elements.
>
> Best Regards,
> Sebastian
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Dave Rice <[email-masked]>
Date: Sun, 4 Sep 2016 16:12:54 -0400

I agree as well:
1. deprecate abandoned Matroska encryption elements with a maxver value
2. add webM encryption elements: ContentEncAESSettings and AESSettingsCipherMode
3. add webM encryption documentation at https://www.webmproject.org/docs/webm-encryption/ as a new markdown file in https://github.com/Matroska-Org/matroska-specification

I could possibly draft PR for #1 and #2, but am not well enough familiar with the documentation of #3.

Also note that the element definitions and the related documentation is Copyright The WebM Project and I’m a little unclear of the precise license of the current specification work.
Dave Rice

> On Sep 4, 2016, at 9:35 AM, Steve Lhomme <[email-masked]> wrote:
>