Subject: [Cellar] Matroska element descriptions and defaults

From: Kieran O Leary <[email-masked]>
Date: Tue, 24 Jul 2018 10:30:31 +0100

Is it within the scope of the IETF specification that the meaning of
the integer values should be explained? I find that if I want to
understand Matroska, I also have to refer to
https://matroska.org/technical/specs/index.html.

In this instance, I wanted to know what was the default value of
FlagInterlaced, as this is the presumed value when the element is not
present in a Matroska file.

I was able to see from :
https://tools.ietf.org/html/draft-ietf-cellar-matroska-00#section-8.2.92
tha the default is 0, and the range is 0-2, but I have to go to
matroska.org in order to know what these mean.

If this is something that needs to be manually added, I could have a
go, but perhaps it's outside of the scope of the IETF spec work.

Best,

Kieran O'Leary
IFI Irish Film Archive.

---

From: Kieran O Leary <[email-masked]>
Date: Tue, 24 Jul 2018 10:35:26 +0100

P.S

I see that this information is actually present in the XML file in the
form of  <restriction>, but it isn't making its way into the IETF
drafts? https://github.com/Matroska-Org/matroska-specification/blob/master/ebml_matroska.xml#L311

-K

---

From: "Timothy B. Terriberry" <[email-masked]>
Date: Tue, 24 Jul 2018 08:47:50 -0700

> go, but perhaps it's outside of the scope of the IETF spec work.

This is completely in scope. It's okay to point to other specifications 
to define what something means, when there is a good specification 
available, but even then the IETF draft should at least have the pointer.

---

From: Dave Rice <[email-masked]>
Date: Wed, 25 Jul 2018 16:46:43 -0400

> On Jul 24, 2018, at 11:47 AM, Timothy B. Terriberry <[email-masked]> wrote:
> 
> Kieran O Leary wrote:
> This is completely in scope. It's okay to point to other specifications to define what something means, when there is a good specification available, but even then the IETF draft should at least have the pointer.

I added changes that put the enumeration vocabularies into the RFC in https://github.com/Matroska-Org/matroska-specification/pull/251 <https://github.com/Matroska-Org/matroska-specification/pull/251>.
Dave Rice

---

From: Dave Rice <[email-masked]>
Date: Thu, 26 Jul 2018 10:33:58 -0400

> On Jul 25, 2018, at 4:46 PM, Dave Rice <[email-masked]> wrote:
> 
> 
>> On Jul 24, 2018, at 11:47 AM, Timothy B. Terriberry <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Kieran O Leary wrote:

These changes are changed and a new 01 version of matroska is at https://datatracker.ietf.org/doc/draft-ietf-cellar-matroska/ <https://datatracker.ietf.org/doc/draft-ietf-cellar-matroska/>. The main changes since 00 are:
- mkv elements are now organized into subsections based on elemental depth (up to a depth of 6)
- enumeration vocabularies are now in tables in the rfc draft
- updated colour primary and transfer characteristic vocabularies
- other typo fixes.

Best Regards,
Dave Rice