Subject: [Cellar] 2022-01-25: agenda for today's meeting

From: Michael Richardson <[email-masked]>
Date: Tue, 25 Jan 2022 12:23:24 -0500

Today's meeting is at 21:00 Amsterdam, 2000 UTC.
That's in ~2.5 hours for me, I think.
Spencer will be late, and I have an appointment that ends 30 minutes before,
but I should be on time.

# CELLAR -- DRAFT AGENDA for Virtual Interim Meeting

| Date |Time | Local Times |
|:------:|:-----------:|:------|
|2022-01-25 |21:00 Amsterdam |[Time Converter](https://savvytime.com/converter/netherlands-amsterdam-to-utc-ny-new-york-city-ca-san-francisco/jun-22-2021/9pm)|
| **Note** | Meeting time is anchored to Amsterdam |

## Administrivia

### INFO:
   https://github.com/ietf-wg-cellar/chair-notes/tree/master/interim-2022-01
   **Note that we're now pointing to the Github repo for chair notes here**

### WEB CONFERENCE:

   https://meetings.conf.meetecho.com/interim/?short=7c38e939-3eaf-451e-8fde-8d05e4bd88c8

#### Shared COMIMD for notetaking: https://codimd.ietf.org/notes-cellar-virtual

* Note that if you log in to the IETF datatracker, you'll be able to edit these notes, add your name to attendee lists, etc.
* Please ask Spencer if you have questions.
:::warning
   The ComiMD URL is still redirecting, but the newly official location is https://notes.ietf.org/notes-cellar-virtual?edit - and that's active now. Please bookmark the new one when you're redirected to it.
:::

### Logistics for Meeting

#### 2022 virtual interim meeting dates

 * Please note our 2022 dates listed at https://datatracker.ietf.org/wg/cellar/meetings/

## Agenda Items

### Note Well:  https://www.ietf.org/about/note-well/

#### Roll call

  Attendees
   *
   * Michael Richardson

  Regrets
   * Spencer Dawkins (will be 30 min late)

#### Accept draft minutes from previous meeting (attached below)

   * Any objections? Please let us know on the mailing list.
   * No objections on the mailing list or on the call.

###  WG status update

   * draft-ietf-cellar-chapter-codecs-00 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-codec-07 was posted 2021-10-19, in ID Exists
   * draft-ietf-cellar-control-00 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-ffv1-v4-18 was posted 2021-11-27, in ID Exists
   * draft-ietf-cellar-flac-02 was posted 2021-11-01, in ID Exists
   * draft-ietf-cellar-matroska-08 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-tags-07 was posted 2021-10-09, in ID Exists

###  Milestone review:

   * Previous status: Jerome is now able to focus on FFV1-v4, since we've published FFV1.
       **ACTION** Spencer to send e-mail to DISPATCH when we submit a (small) update. We should wait until we have a bit more text, or bigger issues, to publish as a draft.

   * Are we ready to submit a working group draft for EBML updates (errata plus additions) yet? (https://github.com/ietf-wg-cellar/ebml-specification/tree/corrections-doc) - we can still wait for more feedback/bigger changes before submitting anything - ETA is "after we get Matroska out, so we know everything Matroska needs will be covered"

##### Discussion on the call

   *

### Matroska issues - Discussion on the call
   *

### FLAC issues - Discussion on the call
   *

### FFV1 v4 issues - Discussion on the call
   * No discussion on the call

## AOB?
   *

:::success
NEXT MEETING 2022-01-25 :tada:
:::

# CELLAR -- DRAFT AGENDA for Virtual Interim Meeting

| Date |Time | Local Times |
|:------:|:-----------:|:------|
|2021-11-23 |21:00 Amsterdam |[Time Converter](https://savvytime.com/converter/netherlands-amsterdam-to-utc-ny-new-york-city-ca-san-francisco/jun-22-2021/9pm)|
| **Note** | Meeting time is anchored to Amsterdam |

## Administrivia

### INFO:
   https://github.com/ietf-wg-cellar/chair-notes/tree/master/interim-2021-10
**Note that we're now pointing to the Github repo for chair notes here**

### WEB CONFERENCE:

   https://whereby.com/cellar-interim

   THERE IS NO TELEPHONE DIALIN (You can try connecting to the whereby.com link at any time.)

Try out the meetecho link:
   https://meetings.conf.meetecho.com/interim/?short=ec140dba-9bf7-4173-80cf-bf1d86100095

#### Shared COMIMD for notetaking: https://codimd.ietf.org/notes-cellar-virtual
* Note that if you log in to the IETF datatracker, you'll be able to edit these notes, add your name to attendee lists, etc.
* Please ask Spencer if you have questions.
:::warning
   The ComiMD URL is still redirecting, but the newly official location is https://notes.ietf.org/notes-cellar-virtual?edit - and that's active now. Please bookmark the new one when you're redirected to it.
:::

### Logistics for Meeting

#### 2021 virtual interim meeting dates

 * Please note our 2022 dates listed at https://datatracker.ietf.org/wg/cellar/meetings/

## Agenda Items

### Note Well:  https://www.ietf.org/about/note-well/

#### Roll call

  Attendees
   * Spencer Dawkins
   * Michael Richardson
   * Martijn van Beurden
   * Steve Lhomme
   * Jérôme Martinez
   * Michael Niedermayer
   * Dave Rice

  Regrets
   *

### News You Can Use
   * **NOTE** that https://mediaarea.net/NoTimeToWait5 is December 8-10, with in-person and virtual registration - a lot of us are attending
    ** workshop on improving Matroska, and how to improve FFV1.
    ** the workshops are on December 8, meeting 9/10.

#### Final dates for 2022 Cellar meetings have been approved by our AD and added to the datatracker

   * 2022-01-25
   * 2022-02-22
   * 2022-03-29
   * 2022-04-26
   * 2022-05-24
   * 2022-06-28
   * 2022-08-23
   * 2022-09-27
   * 2022-10-25
   * 2022-12-06

###  WG status update

   * draft-ietf-cellar-chapter-codecs-00 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-codec-07 was posted 2021-10-19, in ID Exists
   * draft-ietf-cellar-control-00 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-ffv1-v4-17 was posted 2021-05-25, in ID Exists **Expires Soon** -18 will be a keep-alive submission
   * draft-ietf-cellar-flac-02 was posted 2021-11-01, in ID Exists
   * draft-ietf-cellar-matroska-08 was posted 2021-10-09, in ID Exists
   * draft-ietf-cellar-tags-07 was posted 2021-10-09, in ID Exists

###  Milestone review:

   * Previous status: Jerome is now able to focus on FFV1-v4, since we've published FFV1. **ACTION** Spencer to send e-mail to DISPATCH when we submit a (small) update. We should wait until we have a bit more text, or bigger issues, to publish as a draft.
   * Are we ready to submit a working group draft for EBML updates (errata plus additions) yet? (https://github.com/ietf-wg-cellar/ebml-specification/tree/corrections-doc) - we can still wait for more feedback/bigger changes before submitting anything - ETA is "after we get Matroska out, so we know everything Matroska needs will be covered"

##### Discussion on the call
   * **ACTION:** For Matroska, **Spencer and Michael** will review the IANA considerations, especially for deprecated assignments/non-assignments, and ask for ART area review
   * move the security considerations before IANA section

#### Accept draft minutes from previous meeting (attached below)

   * Any objections? Please let us know on the mailing list.
   * No objections on the mailing list or on the call.

### Making sure we have copyright issues straightened out for the FLAC specification
   * Update from Michael on discussions with Josh Coalson and IETF Trust
   * Continue with the current document, or start a new one?

##### Discussion on the call
   * Martijn has a PR for new text, but we can use text from the previous document now that Josh has agreed that we have permission
   * **ACTION: Spencer and Michael**: get list of authors correct.
   * Martijn to add himself as an author and delete Michael Richardson
   * We will continue to engage with Josh on whether he would like to be listed as an author or added as a contributor
   * We should add the Xiph documentation as a informative reference

### Matroska issues - Discussion on the call
   * (above IANA Considerations review)
   * We do have PRs we can merge now
   * **ACTION: please review pull requests: 115, 555**

### FLAC issues - Discussion on the call
   * Discussed under copyright topic above

### FFV1 v4 issues - Discussion on the call
   * No discussion on the call
   * **ACTION: -18 keepalive version will get reposted by Dave Rice**

## AOB?
   * NoTimeToWait5 is sending updates to attendees that includes current information about potential CoViD-19 lockdowns and restrictions for vaccinated-only attendees, etc.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Jan 2022 10:28:51 -0500

I have posted the minutes for yesteday's meeting:
     https://github.com/ietf-wg-cellar/chair-notes/tree/master/interim-2022-01

Please send Pull Requests.
Spencer note that there is an open ACTION for you, which we didn't know if
you had managed to complete that.

And the minutes are included below:

| Date |Time | Local Times |
|:------:|:-----------:|:------|
|2022-01-25 |21:00 Amsterdam |[Time Converter](https://savvytime.com/converter/netherlands-amsterdam-to-utc-ny-new-york-city-ca-san-francisco/jun-22-2021/9pm)|
| **Note** | Meeting time is intentionally anchored to Amsterdam |

## Administrivia

### INFO:

### WEB CONFERENCE:

## Agenda Items

#### Roll call

  Attendees
   * Martijn van Beurden
   * Michael Richardson
   * Steve Lhomme
   * Michael Niedermayer
   * Jérôme Martinez

  Regrets

###  WG status update

###  Milestone review:

   * Are we ready to submit a working group draft for EBML updates (errata plus additions) yet? (https://github.com/ietf-wg-cellar/ebml-specification/tree/corrections-doc)
       * we can still wait for more feedback/bigger changes before submitting anything - ETA is "after we get Matroska out, so we know everything Matroska needs will be covered"
       * also have some implementation/experience reports.
   * Discussion about what is an Internet Standard.
       * it is actually quite an old format, a lot of implementations.
           * but for many implementations, there will be no updates, but the current files play just fine.

### Matroska issues - Discussion on the call
   * merged a few pull requests
   * merged/rewrote the time work, defined different ticks for each time base
       * was trying to sample/presized timestamps.  Could work, but would never be backwards compatible.  So, removed that part, and simplified the result.
           * got some comments, but it is ready.
           * some bugs, but already fixed.
   * https://github.com/ietf-wg-cellar/matroska-specification/pull/577 more review needed.
   * https://github.com/ietf-wg-cellar/matroska-specification/pull/578 generated IANA Considerations.
       * does not generate unassigned for gaps
       * "Any values not mentioned in this table are unassigned"
   * https://github.com/ietf-wg-cellar/matroska-specification/pull/521 needs to be merged (timebase)
   * https://github.com/ietf-wg-cellar/matroska-specification/issues?q=is%3Aopen+is%3Aissue+project%3Aietf-wg-cellar%2Fmatroska-specification%2F1+-label%3Amatroska-v5+-label%3A%22control+track%22   this is the list of things that need to be fixed before the document can be finished.
       * also: PRs: https://github.com/ietf-wg-cellar/matroska-specification/pulls?q=is%3Apr+is%3Aopen+project%3Aietf-wg-cellar%2Fmatroska-specification%2F1+-label%3Amatroska-v5+-label%3A%22control+track%22+sort%3Acreated-desc

### FLAC issues - Discussion on the call
   * Discussion about Examples, and Numerical Considerations Appendix.
   * Martijn will merge some items and close some dead issues and post a new version soon.

### FFV1 v4 issues - Discussion on the call
   * No progress to discuss.

## AOB?
   * EBML query from Martijn!

:::success
NEXT MEETING 2022-02-22 :tada:
:::