Subject: [Cfrg] Mechanism of using block cipher

From: "A SUGANYA" <[email-masked]>
Date: 30 Jun 2011 12:32:22 -0000

I would like to know about a
mechanism of using AES-128 block cipher (in any secure mode of operation) for frame (Ethernet frame at data link layer) encryption. Please note that the size of frame will not be multiples of block size and frame size will not be constant for all frames. Also, for synchronisation purpose we prefer not to carry-forward the current frame bits to next frame.

Suganya

---

From: "Rose, Greg" <[email-masked]>
Date: Thu, 30 Jun 2011 16:42:28 +0000

You could use CCM mode (for compatibility with WiFi) or EAX mode.

Greg.

On 2011 Jun 30, at 5:32 , A SUGANYA wrote:

> I would like to know about a mechanism of using AES-128 block cipher (in any secure mode of operation) for frame (Ethernet frame at data link layer) encryption. Please note that the size of frame will not be multiples of block size and frame size will not be constant for all frames. Also, for synchronisation purpose we prefer not to carry-forward the current frame bits to next frame.
> 
> 
> Suganya
> 
> Treat yourself at a restaurant, spa, resort and much more with Rediff Deal ho jaye!_______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: David McGrew <[email-masked]>
Date: Thu, 30 Jun 2011 09:53:56 -0700

Hi Suganya,

AES-GCM is what 802.1AE MAC Security uses for frame encryption, see http://www.ieee802.org/1/pages/802.1ae.html 
    If you are looking to protect ethernet frames, it seems like you  
would be interested in that standard.  It is supported in commercially  
available ethernet ASICs and some higher end NIC cards.

David

On Jun 30, 2011, at 9:42 AM, Rose, Greg wrote:

>> I would like to know about a mechanism of using AES-128 block  
>> cipher (in any secure mode of operation) for frame (Ethernet frame  
>> at data link layer) encryption. Please note that the size of frame  
>> will not be multiples of block size and frame size will not be  
>> constant for all frames. Also, for synchronisation purpose we  
>> prefer not to carry-forward the current frame bits to next frame.
>>
>>
>> Suganya
>>
>> Treat yourself at a restaurant, spa, resort and much more with  
>> Rediff Deal ho jaye!_______________________________________________
>> Cfrg mailing list
>> [email-masked]
> _______________________________________________
> Cfrg mailing list
> [email-masked]