Subject: [Cfrg] Identity-based 923-bit encryption broken

From: Russ Housley <[email-masked]>
Date: Thu, 21 Jun 2012 09:54:32 -0400

http://news.cnet.com/8301-1009_3-57457470-83/code-crackers-break-923-bit-encryption-record/?tag=mncol;cnetRiver

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 21 Jun 2012 07:59:53 -0700

From the discussion of this topic on one of the cryptography lists, I think a better subject line would be "Some identity-based ...".

Having said that, there is still a dearth of analysis from EC folks on this paper and the one that preceded it.

--Paul Hoffman

---

From: David McGrew <[email-masked]>
Date: Thu, 21 Jun 2012 12:50:02 -0400

Thanks Russ.

For comparison, the IBC recommended parameters are here <http://tools.ietf.org/html/rfc5091#section-9>

I don't see the full report on the official announcement site at <http://www.fujitsu.com/global/news/pr/archives/month/2012/20120618-01.html>   Has anyone seen the full technical report?

David

On Jun 21, 2012, at 9:54 AM, Russ Housley wrote:

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 22 Jun 2012 09:05:17 +0000

Rather misleading headline, as the real key size would be in a component of the domain of the pairing, not the codomain, and there's a factor of 6 (the embedding degree) difference. That makes this equivalent to a 154 bit key.  If you apply the NIST guidelines (assuming they apply in the ternary, rather than binary, case that was cracked)  that suggest a key size that is double the security level, then that's a security level of 77 bits, which is in line with 80 bit security becoming deprecated.

(Apart from the quoting of number of bits that has certainly thrown many commentators, I think that's exactly the message the originators intended, as they comment on establishing strength, not making PBC obsolete - and a good thing too, as people are using it. Many commentators on technology news sites have missed that however. It wasn't a great press release in that regard.)

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: 21 June 2012 14:55
To: IRTF CFRG
Subject: [Cfrg] Identity-based 923-bit encryption broken

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf> on how to deal with suspicious emails.
http://news.cnet.com/8301-1009_3-57457470-83/code-crackers-break-923-bit-encryption-record/?tag=mncol;cnetRiver

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************