Subject: [Cfrg] License for CLEFIA in RFC 6114 and draft-katagi-tls-clefia-02

From: Joachim Strömbergson <[email-masked]>
Date: Thu, 30 Jan 2014 11:04:11 +0100

Aloha!

I took a brief look at RFC 6114 which provides informational description
of the CLEFIA cipher. In the RFC I don't see any reference to licensing
of IP claims on the cipher.

draft-katagi-tls-clefia-02 which presents a way of adding CLEFIA to TLS
does not contain any information about licensing nor claimed rights.

There is however a license for CLEFIA, a license that seems to combine
an open BSD license with a quite strict license which makes it
impossible for anyone but Sony to develop support for CLEFIA:

http://www.sony.net/Products/cryptography/clefia/download/

(Nota bene: IANAL)

The RFC is a done deal, but wouldn't it be appropriate to add a section
in the draft about licensing and IP rights. And to point to the License
agreement?

Also, the link to the technical related information for CLEFIA in
section 7 of the draft seems to be broken.

(This link:
http://www.sony.net/Products/cryptography/clefia/technical/related_material.html)

- -- 
Med vänlig hälsning, Yours

Joachim Strömbergson - Alltid i harmonisk svängning.
========================================================================

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 30 Jan 2014 11:04:47 +0000

Hiya,

On 01/30/2014 10:04 AM, Joachim Strömbergson wrote:
> Aloha!
> 
> I took a brief look at RFC 6114 which provides informational
> description of the CLEFIA cipher. In the RFC I don't see any
> reference to licensing of IP claims on the cipher.

Yes it can be hard to know where to find that, but it
exists. RFCs generally do not contain IPR stuff in the
body of the RFC these days, as RFCs do not change but
licensing does. There's also the not-well-understood
factoid that 6114 is an independent submission RFC and
is not an IETF or IRTF stream RFC. Its common for
algorithm descriptions to be independent stream RFCs
as they are often just copies of something else and
so not really under IETF or IRTF change control.

But anyway, if you look at the IETF tools page [1] for
6114 there is a link to the IPR declarations [2] that
were made for that. To fully grok that you might also
need to understand the IETF's general IPR rules [3]
which are also generally used in the IRTF in case
work moves from one to the other.

Even if this isn't an IETF document, people tend to
want to follow those rules if they hope their
encumbered algorithms might get broader adoption.
(In my personal opinion, having any patent on your
crypto stuff is a fine way of ensuring that it is
not likely to get broad adoption, but people filing
patent applications don't seem to get that;-)

   [1] https://tools.ietf.org/html/rfc6114
   [2]
https://datatracker.ietf.org/ipr/search/?option=rfc_search&rfc_search=6114
   [3] https://tools.ietf.org/html/bcp79

> draft-katagi-tls-clefia-02 which presents a way of adding CLEFIA to
> TLS does not contain any information about licensing nor claimed
> rights.

Same as above, you can find that via [4] at [5].

   [4] https://tools.ietf.org/html/draft-katagi-tls-clefia-02
   [5]
https://datatracker.ietf.org/ipr/search/?option=document_search&document_search=draft-katagi-tls-clefia

> There is however a license for CLEFIA, a license that seems to
> combine an open BSD license with a quite strict license which makes
> it impossible for anyone but Sony to develop support for CLEFIA:
> 
> The RFC is a done deal, but wouldn't it be appropriate to add a
> section in the draft about licensing and IP rights. And to point to
> the License agreement?
> 
> 

That'd
be one for the authors. If that draft were to
become an RFC (and I don't recall if the TLS wg have
looked at it or not), then the RFC editor would likely
want it fixed before publication as well to reference
something more stable.

Cheers,
S.

> 
> _______________________________________________ Cfrg mailing list 
> [email-masked] http://www.irtf.org/mailman/listinfo/cfrg
>