Subject: Re: [Cfrg] QKD is pointless (was: Re: considering new topics for CFRG) (Igoe, Kevin M.)

From: "Dang, Quynh" <[email-masked]>
Date: Wed, 8 Jan 2014 18:39:20 +0000

NIST is interested in post-quantum cryptography research and standardization efforts. NIST would consider to help the IETF in these areas depending on specific topics.

Quynh.

---

From: David McGrew <[email-masked]>
Date: Thu, 09 Jan 2014 19:27:54 -0500

Hi Quynh,

> NIST is interested in post-quantum cryptography research and standardization efforts. NIST would consider to help the IETF in these areas depending on specific topics.

That would be great.  Many IETF participants closely track NIST 
standards and guidelines, and input or coordination from NIST would be 
very positive in establishing the viability and role for post-quantum 
standards.    My guess is that there is substantial interest in the 
post-quantum work, but it will also take a good bit of effort, so let's 
let other people chime in on what work they would prioritize.

As far as post-quantum work goes, I think hash-based signatures will be 
easiest to realize, because they are fairly well understood, and it 
should not be too hard to get a signature system about which people have 
good confidence.   So it would make sense to do signatures first.   My 
$0.02 anyway.

David

> Quynh.
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Paul Lambert <[email-masked]>
Date: Thu, 9 Jan 2014 18:26:31 -0800

Hi Quynh,

On a related topic of getting assistance and review 
by NIST: 

  Would NIST help this group evaluate and document
  proposals for additional ECC curves beyond those 
  recommended by NIST in 1999?

It seems that some progress may have been made in the
practice of ECC in 15 years that should be reviewed
and considered.

Is there a specific process for adding new 
cryptographic algorithms in FIPs recommendations
that should be followed?

Thanks in advance,

Paul

> -----Original Message-----
> From: Cfrg [mailto:[email-masked]] On Behalf Of David McGrew
> Sent: Thursday, January 09, 2014 4:28 PM
> To: Dang, Quynh
> Cc: [email-masked]
> Subject: [Cfrg] post-quantum cryptography
> 
> Hi Quynh,
> 
> > NIST is interested in post-quantum cryptography research and
> standardization efforts. NIST would consider to help the IETF in these
> areas depending on specific topics.
>