Subject: Re: [Cfrg] Key establishment advice (say, for TLS): How about MQV?

From: Peter Gutmann <[email-masked]>
Date: Thu, 27 Mar 2014 22:07:19 +0000

Dan Brown <[email-masked]> writes:

>For MQV's IPR status, I wonder if a letter similar to:
>
>http://www.ietf.org/ietf-ftp/IPR/certicom-ipr-rfc-3278.pdf
>
>would address your type of concern.

Only if someone is prepared to decrypt:

  Patent Holder shall only be required to license any prospective licensee if
  such prospective licensee will commit to license its necessary patents for
  implementation of the same above Standard free of charge or under reasonable
  and nondiscriminatory terms.

for me.  Apart from the impenetrability of the text, the reference to RAND as
part of the definition of RAND is circular.  If I showed that to a lawyer he
might lock up and require a reboot.

It looks like a reciprocity clause of some kind, but just saying "RAND"
doesn't mean you won't end up having to negotiate a licence fee.

Peter.

---

From: Watson Ladd <[email-masked]>
Date: Thu, 27 Mar 2014 18:13:47 -0400

> doesn't mean you won't end up having to negotiate a licence fee.

If you are going to allege your patent claims against implementors of
the standard, while relying on this license, you need to licence your
patent under RAND terms to everyone. I agree it is unfortunately weak,
but on the plus side this isn't a problem with Certicom's patents, but
potential other patents. It also isn't saying that you license under
these terms, but under terms that are "RAND" whatever that is. It's
also missing an indirect object in the sentence saying to whom the
patents must be licensed.

IANAL, so don't rely on what I say too much.

Sincerely,
Watson Ladd
>
> Peter.
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

-- 
"Those who would give up Essential Liberty to purchase a little
Temporary Safety deserve neither  Liberty nor Safety."
-- Benjamin Franklin