Subject: [Cfrg] IBE checking...

From: Stephen Farrell <[email-masked]>
Date: Mon, 17 Nov 2014 15:56:44 +0000

Hiya,

This IBE draft [1] is on next week's IESG telechat. Since
IBE ain't my thang really, I figured I'd check see if
someone here wanted to give it a read from a crypto POV.

There's not too much to this over and above RFC6507 [2] (I
think:-) but this seems to be the first case of a standards
track document making use of 6507 so there's a bit of process
novelty here, even if not much cryptographic novelty.

If you can review, sending comments here, or to the secdir
list, or the IETF list or just to Kathleen and I are all fine
things to do. If you might get to it but aren't sure please
drop me a note.

Oh, and it's not that long: just 16 pages incl. examples:-)

Thanks in advance,
S.

[1] https://datatracker.ietf.org/doc/draft-ietf-manet-ibs/
[2] https://tools.ietf.org/html/rfc6507

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 17 Nov 2014 13:45:37 -0800

My first reaction is to wonder if the group discussed the IPR issues and why
the IPR disclosures were not propagated forward to this document.

Jim

> -----Original Message-----
> From: Cfrg [mailto:[email-masked]] On Behalf Of Stephen Farrell
> Sent: Monday, November 17, 2014 7:57 AM
> To: [email-masked]
> Subject: [Cfrg] IBE checking...
> 
> 
> Hiya,
> 
> This IBE draft [1] is on next week's IESG telechat. Since IBE ain't my
thang
> really, I figured I'd check see if someone here wanted to give it a read
from a
> crypto POV.
> think:-) but this seems to be the first case of a standards track document
> making use of 6507 so there's a bit of process novelty here, even if not
much
> cryptographic novelty.
> 
> If you can review, sending comments here, or to the secdir list, or the
IETF list
> or just to Kathleen and I are all fine things to do. If you might get to
it but aren't
> sure please drop me a note.
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: Watson Ladd <[email-masked]>
Date: Mon, 17 Nov 2014 21:32:04 -0800

Someone more familiar with the byte-level formats of RFC 5444 needs to
check that the various ID spaces are nonoverlapping over the space
they need to be. It's the only problem I could see, assuming RFC 6507
is a secure scheme.

Sadly, RFC 6507 has no references to a security analysis or
publication describing the scheme. The security argument isn't
actually a security argument. My attempts at finding such an analysis
have come up dry.

I also found a patent application WO2001043341A2 which seems to cover
this method in claim 4. I can't figure out if it was granted or not:
my guess is no, because I haven't found patents, just applications.

Anyway, this doesn't directly answer the question presented.

Sincerely,
Watson Ladd