Subject: [Cfrg] malicious DH base points [was Re: should the CFRG really strive for consensus?]

From: Dan Brown <[email-masked]>
Date: Wed, 31 Dec 2014 15:07:21 +0000

‎The paper talks about the possibility of malicious base points for DH:

Boaz Tsaban: Fast generators for the Diffie-Hellman key agreement protocol and malicious standards. IACR Cryptology ePrint Archive 2005: 231 (2005)

It may be far-fetched, but the paper seems to show that the independence of DH from the base point is ‎not quite a mathematical certainty, unless the paper has been refuted in further research. 

Best regards, 

-- Dan
From: Adam Langley
Sent: Wednesday, December 31, 2014 9:45 AM
To: Christoph Anton Mitterer
Cc: [email-masked]
Subject: Re: [Cfrg] should the CFRG really strive for consensus?

On Dec 31, 2014 1:50 PM, "Christoph Anton Mitterer" <[email-masked]> wrote:
> I think it's really a bad idea for the CFRG to strive so much for
> consensus.

If you believe in the security of curve25519 then you also believe in the security of Microsoft's current position at ~128 bits. They have the same structure and thus strictly the same strength.

There's /no/ possibility of weakening anything, mathematically, with a different base point (in the correct subgroup) or by using an isogeny.

IRTF groups do not, technically, have to reach consensus. However, everyone does have to function on the same Internet at the end of the day.
Cheers

AGL

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Wed, 31 Dec 2014 15:30:35 +0000

Actually, that paper doesn’t actually say “it’s possible to pick a malicious generator from a prime-sized group”.  Instead, it (actually, claim 9) says “if we knew of a generator/KDF pair which made deriving the shared secret easy, someone setting up the group could use that to select a random-looking generator that, with that KDF, contains a trap door that he could exploit”.

If anything, that paper can be construed to be an argument for a nonrandom-looking generator (because that doesn’t give anyone a chance to build in the above trap door).

From: Cfrg [mailto:[email-masked]] On Behalf Of Dan Brown
Sent: Wednesday, December 31, 2014 10:07 AM
To: Adam Langley; Christoph Anton Mitterer
Cc: [email-masked]
Subject: [Cfrg] malicious DH base points [was Re: should the CFRG really strive for consensus?]

Boaz Tsaban: Fast generators for the Diffie-Hellman key agreement protocol and malicious standards. IACR Cryptology ePrint Archive 2005<http://www.informatik.uni-trier.de/~ley/db/journals/iacr/iacr2005.html#Tsaban05>: 231 (2005)

Best regards,

-- Dan
From: Adam Langley
Sent: Wednesday, December 31, 2014 9:45 AM
To: Christoph Anton Mitterer
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Cfrg] should the CFRG really strive for consensus?

Cheers

AGL