Subject: [Cfrg] Fwd: CFP - NIST Workshop on Elliptic Curve Cryptography Standards

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 16 Jan 2015 09:11:11 +0100

I wonder what you think about this upcoming workshop since it more or
less aims to do what this group is working on.

Ciao
Hannes

-------- Forwarded Message --------
Subject: 	[saag] Fwd: CFP - NIST Workshop on Elliptic Curve Cryptography
Standards
Date: 	Thu, 15 Jan 2015 17:57:45 -0500
From: 	Russ Housley <[email-masked]>
To: 	IETF SAAG <[email-masked]>

> *Workshop on Elliptic Curve Cryptography Standards
> *June 11-12, 2015*
> **
> **/Call for Papers/**
> *
> The National Institute of Standards and Technology (NIST) will host
> a */Workshop on Elliptic Curve Cryptography Standards/* at NIST
> headquarters in Gaithersburg, MD on June 11-12, 2015.  The workshop
> will provide a venue to engage the cryptographic community, including
> academia, industry, and government users to discuss possible
> approaches to promote the adoption of secure, interoperable and
> efficient elliptic curve mechanisms.
>
> NIST solicits papers, presentations, case studies, panel proposals,
> and participation from any interested parties, including researchers,
> systems architects, vendors, and users.
>
> The full Call for Papers and workshop details are available at the
> workshop website:  http://www.nist.gov/itl/csd/ct/ecc-workshop.cfm**
>
>  
>

---

From: "Paterson, Kenny" <[email-masked]>
Date: Fri, 16 Jan 2015 08:34:00 +0000

Hi Hannes,

The timescales are different, but, yes, there is significant overlap. 

Regards

Kenny

Sent from my iPhone

> On 16 Jan 2015, at 08:11, Hannes Tschofenig <[email-masked]> wrote:
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 16 Jan 2015 08:50:27 -0800

> less aims to do what this group is working on.

Nothing in the workshop announcement says that it "aims to do what this group is working on". It is on the same topic, but the aims are completely different and, as Kenny points out, the timescales are vastly different.

The descriptive work that the RG has done in the last six months about comparison of EC proposals would be great input to the workshop. Beyond that, the CFRG's aim right now is still to give the TLS WG something to work with, a few months ago.

--Paul Hoffman

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 16 Jan 2015 15:03:14 -0500

I don't think that is quite right Paul.

NIST has traditionally been the standard setter in this area. It is clear
that this is no longer tenable for a variety of reasons beyond Snowden. But
being NIST they can't just say 'whatever'.

The question in my view is what continuing role NIST should play in public
crypto standards. One that I think would be very valuable and not raise
control point issues would be to provide challenge values for a small set
of preferred algorithms. If generated in an appropriate way these would
provide irrefutable proof of a break.

And this is a model that other national standards institutes could copy
without coordination being required.

On Fri, Jan 16, 2015 at 11:50 AM, Paul Hoffman <[email-masked]>
wrote:

> Nothing in the workshop announcement says that it "aims to do what this
> group is working on". It is on the same topic, but the aims are completely
> different and, as Kenny points out, the timescales are vastly different.
>
> The descriptive work that the RG has done in the last six months about
> comparison of EC proposals would be great input to the workshop. Beyond
> that, the CFRG's aim right now is still to give the TLS WG something to
> work with, a few months ago.
>
> --Paul Hoffman
>
>
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 19 Jan 2015 09:46:09 +0100

Given that there is this overlapping activity I would suggest that the
chairs make sure that the work in the group is moving forward according
to the schedule.

I appreciated that Alexey posted a status update and a plan:
http://www.ietf.org/mail-archive/web/cfrg/current/msg05813.html

According to that message outcome of the discussion should be declared
today.

Ciao
Hannes

On 01/16/2015 09:03 PM, Phillip Hallam-Baker wrote:
> NIST has traditionally been the standard setter in this area. It is
> clear that this is no longer tenable for a variety of reasons beyond
> Snowden. But being NIST they can't just say 'whatever'.
> 
> The question in my view is what continuing role NIST should play in
> public crypto standards. One that I think would be very valuable and not
> raise control point issues would be to provide challenge values for a
> small set of preferred algorithms. If generated in an appropriate way
> these would provide irrefutable proof of a break.
> 
> On Fri, Jan 16, 2015 at 11:50 AM, Paul Hoffman <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     On Jan 16, 2015, at 12:11 AM, Hannes Tschofenig
>     <[email-masked] <mailto:[email-masked]>> wrote:
>     Nothing in the workshop announcement says that it "aims to do what
>     this group is working on". It is on the same topic, but the aims are
>     completely different and, as Kenny points out, the timescales are
>     vastly different.
> 
>     The descriptive work that the RG has done in the last six months
>     about comparison of EC proposals would be great input to the
>     workshop. Beyond that, the CFRG's aim right now is still to give the
>     TLS WG something to work with, a few months ago.
> 
>     --Paul Hoffman
> 
> 
> 
>     [email-masked] <mailto:[email-masked]>