Subject: [Cfrg] Fwd: Re: [openpgp] [PATCH] RFC4880bis: Argon2i

From: Stephen Farrell <[email-masked]>
Date: Fri, 6 Nov 2015 02:18:13 +0000

The password hashing competition has a winner and some folks
in the openpgp wg are interested in using that winner. I guess
this might be better processed via cfrg if folks are amenable
to that.

Thanks,
S.

-------- Forwarded Message --------
Subject: Re: [openpgp] [PATCH] RFC4880bis: Argon2i
Date: Thu, 5 Nov 2015 08:50:36 +0000
From: Stephen Farrell <[email-masked]>
To: Dmitry Khovratovich <[email-masked]>, Simon Josefsson
<[email-masked]>
CC: Nils Durner <[email-masked]>, Alex Biryukov
<[email-masked]>, [email-masked] <[email-masked]>, Daniel Dinu
<[email-masked]>, Kathleen Moriarty
<[email-masked]>, Joseph Lorenzo Hall <[email-masked]>

Process-wise, I think the thing to do with this is
to handle it as a cfrg draft. (I'll forward this
there and as if they wanna adopt it.)

Cheers,
S

On 05/11/15 08:32, Dmitry Khovratovich wrote:
> Thank you, Simon!
> 
> I will review your draft and give comments ASAP
> 
> Dmitry
> 
> Sent from my iPad
> 
>> On Nov 5, 2015, at 09:25, Simon Josefsson <[email-masked]> wrote:
>>
>> We have now pushed out a -00 strawman on Argon2 in ID form:
>>
>> https://tools.ietf.org/html/draft-josefsson-argon2-00
>>
>> I'm not happy with the explanation of the H' and G functions, and the
>> permutation P (from BLAKE2b) and the indexing section are missing.
>> Reference code in a higher-level language like python would be useful.
>> If those things, and an ASN.1 schema is added, I believe the document
>> would be good to go.
>>
>> We need to have an IETF discussion whether we are interested in the
>> Argon2d non-side-channel safe variant.  The Argon2 paper implies that
>> the Argon2i side-channel safe variant is for "dangerous settings" where
>> you need side-channel safety.  For Internet use I believe we have
>> already passed the point where we can ignore side-channel concerns,
>> since they have been used in several successful attacks already.  This
>> could be resolved in the security considerations, but I'm concerned
>> about giving people too much rope here.
>>
>> /Simon
>>
>> Stephen Farrell <[email-masked]> writes:
>>
>>> Hiya,
>>>
>>> One way to handle this might be to add the winners as
>>> co-authors on the Internet-draft. In that case, the
>>> draft boilerplate text says that you're following the IETF
>>> IPR rules and hence would have filed an IPR declaration
>>> if one was needed. And if none is needed, we'd be done.
>>>
>>> I'm sure we can figure other options but the above would
>>> be easiest from the IETF point of view.
>>>
>>> Cheers,
>>> S.
>>>
>>>> On 03/11/15 11:56, Joseph Lorenzo Hall wrote:
>>>> Congratulations btw on winning the competition!
>>>>
>>>> Kathleen and Stephen can confirm, but I believe you don't have to do
>>>> anything in terms of adding any language in this case (no patent
>>>> issued/sought, patent pending, etc.). When/if the document is adopted by
>>>> the working group, the chair will request any disclosures.
>>>>
>>>>
>>>>
>>>>> On Tuesday, November 3, 2015, Alex Biryukov <[email-masked]> wrote:
>>>>>
>>>>> Hi all,
>>>>>
>>>>> We were not intending to patent it, so we can add a sentence about it.
>>>>> Suggestions of lawyer-happy phrases are welcome.
>>>>>
>>>>> Alex
>>>>>
>>>>> On Tue, Nov 3, 2015 at 10:47 AM, Joseph Lorenzo Hall <[email-masked]
>>>>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>>>
>>>>>> At IETF94 one question that came up in trying to move quickly to
>>>>>> support Argon2 is the potential IPR that might be in Argon2. The code
>>>>>> available now [1] is CC0 which, AFAICT, doesn't have any patent grant
>>>>>> or implication for patents, etc., meaning the authors could still
>>>>>> claim something, precluding it from use without a waiver (or whatever,
>>>>>> IANAL)
>>>>>>
>>>>>> I'll CC the Argon2 authors (on the Argon2 spec [2]) here and see if we
>>>>>> can clarify any potential IPR and whether that might affect using it
>>>>>> in the future in OpenPGP.
>>>>>>
>>>>>> best, Joe
>>>>>>
>>>>>> [1]: https://github.com/p-h-c/phc-winner-argon2
>>>>>> [2]: https://password-hashing.net/argon2-specs.pdf
>>>>>>
>>>>>> On Tue, Nov 3, 2015 at 5:20 PM, Simon Josefsson <[email-masked]
>>>>>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>>>>>> Den Tue, 3 Nov 2015 07:45:44 +0100
>>>>>>> skrev Re: [openpgp] [PATCH] RFC4880bis: Argon2i:
>>>>>>>
>>>>>>>> Hi Daniel,
>>>>>>>>
>>>>>>>>> If we introduce this as a normative dependency for OpenPGP, though,
>>>>>>>>> we might also want to have an IETF RFC for Argon2.  Do you know of
>>>>>>>>> anyone working on such a draft?
>>>>>>>>
>>>>>>>> Simon Josefsson has expressed interest in helping with that.
>>>>>>>> @Simon: are you working on this?
>>>>>>>
>>>>>>> I started on an Argon2 draft but after talking to the Argon2 team we
>>>>>>> decided to wait until Argon2 was finalized.  I suppose now is a good
>>>>>>> time to resume that work.  I'll put something up on gitlab.com so
>>>>>>> people can review and help.  If anyone wants to help, please let me
>>>>>>> know and we'll coordinate something.
>>>>>>>
>>>>>>> /Simon
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> openpgp mailing list
>>>>>>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>>>>>>> https://www.ietf.org/mailman/listinfo/openpgp
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Joseph Lorenzo Hall
>>>>>> Chief Technologist
>>>>>> Center for Democracy & Technology
>>>>>> 1634 I ST NW STE 1100
>>>>>> Washington DC 20006-4011
>>>>>> (p) 202-407-8825
>>>>>> (f) 202-637-0968
>>>>>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>>>>>> PGP: https://josephhall.org/gpg-key
>>>>>> fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> ---------------------------------
>>>>> Prof. Dr. Alex Biryukov,
>>>>> FSTC/CSC, University of Luxembourg,
>>>>> 6, rue Richard Coudenhove-Kalergi,
>>>>> L-1359 Luxembourg-Kirchberg
>>>>> LUXEMBOURG
>>>>> Tel:  +352 46 66 44 6793
>>>>> Fax: +352 46 66 44 5500
>>>>>
>>>>
>>>>
> 

_______________________________________________
openpgp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/openpgp

---

From: "Paterson, Kenny" <[email-masked]>
Date: Fri, 6 Nov 2015 11:47:05 +0000

Hi Stephen,

Yes, the chairs are amenable to this. We've been keeping an eye on the
password hashing competition and were planning a work item in this area.

Any comments from the group, either supporting or objecting to us adopting
this draft in the RG?

Cheers,

Kenny 

(for the chairs)

On 06/11/2015 02:18, "Cfrg on behalf of Stephen Farrell"
<[email-masked] on behalf of [email-masked]> wrote:

>>>>>>>><javascript:_e(%7B%7D,'cvml',[email-masked]');>
>Cfrg mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/cfrg

---

From: Deirdre Connolly <[email-masked]>
Date: Fri, 6 Nov 2015 15:25:49 -0500

> Any comments from the group, either supporting or objecting to us adopting

+1 in support.