Subject: [Cfrg] DER/PEM storage format for CFRG private keys

From: Hugo Landau <[email-masked]>
Date: Tue, 22 Dec 2015 13:19:15 +0000

Is there a DER format specified by the CFRG, or already used elsewhere
for the storage of Ed25519 or Ed448 private keys?

If not, this seems like it should receive a specification.

I found the following formats:
  PKCS1: Suitable for RSA only.

  EC:    RFC5915. Consists of a version int, private key octet string,
         named curve OID and public key bitstring. Could probably be
         mashed into supporting Ed keys, but is that a good idea?

  PKCS8: Essentially a tagged union allowing the storage of the
         PKCS1 or EC formats above.

  OpenSSH Ed25519 Private Keys: Uses an OpenSSH-specific PEM format.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 22 Dec 2015 15:19:36 +0000

> for the storage of Ed25519 or Ed448 private keys?

That's work TBD in the just-formed IETF curdle WG. [1]

You can see a list of relevant drafts in it's charter [2]
but since the WG was just formed yesterday, none of those
are official yet.

If you see any gaps in there, saying so on the curdle
list would be the way to get those filled. (Or to get
someone to ask you to fill them:-)

Please join in there,
Cheers,
S.

[1] https://tools.ietf.org/wg/curdle/
[2] https://tools.ietf.org/wg/curdle/charters

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Damien Miller <[email-masked]>
Date: Wed, 23 Dec 2015 11:49:36 +1100 (AEDT)

>   OpenSSH Ed25519 Private Keys: Uses an OpenSSH-specific PEM format.

OpenSSH's isn't PEM, it's a simpler format that looks a little like it
(--- HEADER --- + base64 blob).

-d

---

From: Peter Gutmann <[email-masked]>
Date: Wed, 23 Dec 2015 01:38:03 +0000

Hugo Landau <[email-masked]> writes:

>Is there a DER format specified by the CFRG, or already used elsewhere for
>the storage of Ed25519 or Ed448 private keys?
>

PKCS #15: Works just fine.

Peter.