Subject: Re: [Cfrg] BLS Signature for X.509

From: Antonio Sanso <[email-masked]>
Date: Tue, 4 Oct 2016 06:12:08 +0000

anyome :S ?

On Sep 30, 2016, at 8:57 AM, Antonio Sanso <[email-masked]> wrote:

> hi *, 
> 
> sorry for the noise. 
> I was wondering if it was already discussed the idea to use BSL Signature for X.509.
> AFAIK this will avoid certificate chains thanks to the signature aggregation property…
> If this was already discussed I apologize. 
> If not WDYT about this? 
> 
> regards
> 
> antonio
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Paul Grubbs <[email-masked]>
Date: Tue, 4 Oct 2016 12:01:23 -0400

BLS signatures would be nice for many reasons. The lack of standardized
pairing groups makes it a little difficult from a deployability
perspective, I think.

---

From: Antonio Sanso <[email-masked]>
Date: Wed, 5 Oct 2016 09:09:47 +0000

hi Paul,

thanks. Isn’t where this group can help though (namely standardization) ?

regards

antonio

On Oct 4, 2016, at 6:01 PM, Paul Grubbs <[email-masked]<mailto:[email-masked]>> wrote:

BLS signatures would be nice for many reasons. The lack of standardized pairing groups makes it a little difficult from a deployability perspective, I think.

On Tue, Oct 4, 2016 at 2:12 AM, Antonio Sanso <[email-masked]<mailto:[email-masked]>> wrote:
anyome :S ?

On Sep 30, 2016, at 8:57 AM, Antonio Sanso <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>

_______________________________________________
Cfrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/cfrg

---

From: Paul Grubbs <[email-masked]>
Date: Wed, 5 Oct 2016 13:52:45 -0400

The IETF does play an important role in the process, but most people (at
least in the US) won't consider anything in crypto 'standardized' unless it
involves NIST.

On Wed, Oct 5, 2016 at 5:09 AM, Antonio Sanso <[email-masked]> wrote:

> On Oct 4, 2016, at 6:01 PM, Paul Grubbs <[email-masked]> wrote:
>

---

From: Benjamin Black <[email-masked]>
Date: Wed, 5 Oct 2016 11:06:00 -0700

CFRG just recommended 2 non-NIST curves at the request of the TLS working
group. At least one of those curves is widely deployed for kex and
signatures in multiple protocols. Lack of NIST blessing is no longer an
impediment to adoption.

---

From: Dan Brown <[email-masked]>
Date: Wed, 5 Oct 2016 18:18:55 +0000

Hi Antonio,

Can you briefly expand on the advantages of BLS, especially the aggregation of chains [citing also a reference]?  How well are these advantages aligned with IETF needs?  At the moment, I’m a little skeptical that the benefits (smaller chains?) outweigh the risks (relying on pairing-groups), but I could be wrong.

Just to be clear, although BLS uses pairing-groups, it does not have any escrow worries (unlike IBE etc.), or am I badly mistaken?

Is BLS standardized elsewhere (ISO, IEEE 1363*, etc.)?

In any event, you could prepare an individual I-D to propose BLS to IETF, although I do not how much it would be accepted.

Pairing-groups have been proposed for in use IETF before:
https://datatracker.ietf.org/doc/draft-budronimccusker-milagrotls/
https://datatracker.ietf.org/doc/rfc6508/
https://datatracker.ietf.org/doc/rfc6509/

Best regards,

Dan

From: Cfrg [mailto:[email-masked]] On Behalf Of Paul Grubbs
Sent: Wednesday, October 05, 2016 1:53 PM
To: Antonio Sanso <[email-masked]>
Cc: [email-masked]
Subject: Re: [Cfrg] BLS Signature for X.509

The IETF does play an important role in the process, but most people (at least in the US) won't consider anything in crypto 'standardized' unless it involves NIST.

On Wed, Oct 5, 2016 at 5:09 AM, Antonio Sanso <[email-masked]<mailto:[email-masked]>> wrote:
hi Paul,

regards

antonio

---

From: Antonio Sanso <[email-masked]>
Date: Thu, 6 Oct 2016 12:20:28 +0000

hi Dan

On Oct 5, 2016, at 8:18 PM, Dan Brown <[email-masked]<mailto:[email-masked]>> wrote:

Hi Antonio,

Can you briefly expand on the advantages of BLS, especially the aggregation of chains [citing also a reference]?

here a couple of references

http://theory.stanford.edu/~dfreeman/cs259c-f11/finalpapers/aggregatesigs.pdf
https://crypto.stanford.edu/~dabo/papers/aggsurvey.pdf

AFAIU if the signature used is BLS  there is not need to calculate the certificate chain since any “node” involved can "fully proof" the “chain” .

  How well are these advantages aligned with IETF needs?  At the moment, I’m a little skeptical that the benefits (smaller chains?) outweigh the risks (relying on pairing-groups), but I could be wrong.

are  you aware of any risk of using BLS. I am not so far….

if there is any interest I would be happy to take a stub and write a draft. Is there anyone interested to join the effort?

regards

antonio

Best regards,

Dan

From: Cfrg [mailto:[email-masked]] On Behalf Of Paul Grubbs
Sent: Wednesday, October 05, 2016 1:53 PM
To: Antonio Sanso <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Cfrg] BLS Signature for X.509

regards

antonio

---

From: Dan Brown <[email-masked]>
Date: Thu, 6 Oct 2016 15:04:30 +0000

The risks (as in potential or theoretical risk) of pairing-groups are (1) newer (usual for any new crypto), (2) recent progress in finite field DLP over certain extension fields, e.g Barbulescu et al. quasi-polynomial time [see also http://eprint.iacr.org/2016/914].  Does BLS somehow bypass these risks?  Or is there is a choice of pairing-group that is not deemed risky?

________________________________
From: Antonio Sanso [[email-masked]]
Sent: Thursday, October 06, 2016 8:20 AM
To: Dan Brown
Cc: Paul Grubbs; [email-masked]
Subject: Re: [Cfrg] BLS Signature for X.509

hi Dan

Hi Antonio,

regards

antonio

Best regards,

Dan

regards

antonio

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 08 Oct 2016 23:27:08 +0000

Hi all, I'm trying to summarize a number of other recent conversations on
pairing crypto in various corners of the Internet.

My take: CFRG should not be standardizing pairing crypto groups b/c
available implementations offer less than < 128 bits of security  and
systems that rely on these implementations are searching for new curves.
Ideally, these users will coordinate on what groups to use and potentially
then it will make sense to standardize.

There has been a lot discussion of these issues initiated from Trevor
Perrin's post to Modern Crypto.[0]

Paulo Barreto shared a script for estimating the impact of new number sieve
attack on BN curves.[1] I typed it up.

The Zcash devs discussed the impact of these attacks on their curves
here.[2]

Beyond SNARKS, lots of privacy improving technologies in the cryptocurrency
world are interested in pairing based crypto like Lightning Network(Passive
key rotation), MimbleWimble( scalable confidential transactions etc).

I'd suggest that the OP watch developments in this space for candidate
groups and implementations to use in an X.509 setting.

[0] http://moderncrypto.org/mail-archive/curves/2016/000740.html
[1] https://gist.github.com/zmanian/67625108708dea404aa4b86cedde22ec
[2] https://github.com/zcash/zcash/issues/714

On Thu, Oct 6, 2016 at 8:05 AM Dan Brown <[email-masked]> wrote:

>
>
>
>
>
>
>
> The risks (as in potential or theoretical risk) of pairing-groups are (1)
> newer (usual for any new crypto), (2) recent progress in finite field DLP
> over certain extension fields, e.g Barbulescu et al. quasi-polynomial time
> [see also http://eprint.iacr.org/2016/914].  Does
> BLS somehow bypass these risks?  Or is there is a choice of pairing-group
> that is not deemed risky?
>
> ------------------------------
>
> *From:* Antonio Sanso [[email-masked]]
>
> *Sent:* Thursday, October 06, 2016 8:20 AM
>
> *To:* Dan Brown
>
> *Cc:* Paul Grubbs; [email-masked]
>
>
> *Subject:* Re: [Cfrg] BLS Signature for X.509
>
>
>
> hi Dan
>
>
>
> On Oct 5, 2016, at 8:18 PM, Dan Brown <[email-masked]> wrote:
>
>
>
>
>
>
>
> Hi Antonio,
>
>
>
>
>
> Can you briefly expand on the advantages of BLS, especially the
> aggregation of chains [citing also a reference]?
>
>
>
>
>
>
>
> AFAIU if the signature used is BLS  there is not need to calculate the
> certificate chain since any “node” involved can "fully proof" the “chain” .
>
>
>
>
>
>
>
>   How well are these advantages aligned with IETF needs?  At the moment,
> I’m a little skeptical that the benefits (smaller chains?) outweigh the
> risks (relying on pairing-groups),
> but I could be wrong.
>
>
>
>
>
>
>
> Just to be clear, although BLS uses pairing-groups, it does not have any
> escrow worries (unlike IBE etc.), or am I badly mistaken?
>
>
>
>
>
> In any event, you could prepare an individual I-D to propose BLS to IETF,
> although I do not how much it would be accepted.
>
>
>
>
>
>
>
> if there is any interest I would be happy to take a stub and write a
> draft. Is there anyone interested to join the effort?
>
>
>
>
> regards
>
>
>
>
> antonio
>
>
>
>
>
>
>
>
>
>
>
>
> *From:* Cfrg [mailto:[email-masked] <[email-masked]>]
> *On Behalf Of *Paul Grubbs
>
> *Sent:* Wednesday, October 05, 2016 1:53 PM
>
> *To:* Antonio Sanso <[email-masked]>
>
> *Cc:* [email-masked]
>
> *Subject:* Re: [Cfrg] BLS Signature for X.509
>
>
>
>
>
>
>
>