Subject: [Cfrg] I like PKEX

From: "Salz, Rich" <[email-masked]>
Date: Thu, 16 Nov 2017 07:11:09 +0000

I think the PKEX stuff is very interesting.  It inverts the trust model used on the Web.   Suppose I want to do some online banking with mybank.com. My browser checks the server cert, and decided to trust it if the CA verifies the identity. I then type my name and password into the website. There is a risk if I end up at the wrong website.

With PKEX, I can use my name and password and the bank can use something like my account number or other similar info, and we exchange and get a shared secret. We then use that secret to get an authenticated ECDSA key and then I switch to TLS and get its benefits.  No third-party trust is needed.

I think this solves an interesting use-case and it would be nice to have it in our toolbox.

---

From: Richard Barnes <[email-masked]>
Date: Thu, 16 Nov 2017 15:21:02 +0800

Sorry, what is PKEX?

On Thu, Nov 16, 2017 at 3:11 PM, Salz, Rich <[email-masked]> wrote:

> I think the PKEX stuff is very interesting.  It inverts the trust model
> used on the Web.   Suppose I want to do some online banking with
> mybank.com. My browser checks the server cert, and decided to trust it if
> the CA verifies the identity. I then type my name and password into the
> website. There is a risk if I end up at the wrong website.
>
>
>
> With PKEX, I can use my name and password and the bank can use something
> like my account number or other similar info, and we exchange and get a
> shared secret. We then use that secret to get an authenticated ECDSA key
> and then I switch to TLS and get its benefits.  No third-party trust is
> needed.
>
>
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 16 Nov 2017 07:22:29 +0000

https://datatracker.ietf.org/meeting/100/materials/slides-100-cfrg-public-key-exchange/

Sorry, what is PKEX?

On Thu, Nov 16, 2017 at 3:11 PM, Salz, Rich <[email-masked]<mailto:[email-masked]>> wrote:
I think the PKEX stuff is very interesting.  It inverts the trust model used on the Web.   Suppose I want to do some online banking with mybank.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__mybank.com&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=3nrJp_EjXY0gocLaBMzudoJZuVwi3c9JcbPTl7mDBEg&s=4XLBpZhzsnlZQkUITgKM9BCxc9CSujlbL3eM5mxyHm8&e=>. My browser checks the server cert, and decided to trust it if the CA verifies the identity. I then type my name and password into the website. There is a risk if I end up at the wrong website.

_______________________________________________
Cfrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/cfrg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_cfrg&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=3nrJp_EjXY0gocLaBMzudoJZuVwi3c9JcbPTl7mDBEg&s=yK-DSwfnhPkfWPH4QM5bD43yMpRZCdPZQGA8VUa6ADU&e=>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 16 Nov 2017 15:23:53 +0800

In fact, PKEX (password-authenticated key exchange protocol by Dan Harkins,
https://tools.ietf.org/html/draft-harkins-pkex-04 - for Richard), as all
secure PAKE protocols can help to upgrade most cases of authentication,
when some shared secret (password or, as in Rich's example, an account
number), to solutions which do not require having a primary trust to
someone you're authenticating to.

I'd also like to see PAKEs in the messengers, as I commented during the
CFRG meeting yesterday.

2017-11-16 15:21 GMT+08:00 Richard Barnes <[email-masked]>:

>> mybank.com. My browser checks the server cert, and decided to trust it
>> if the CA verifies the identity. I then type my name and password into the

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 16 Nov 2017 15:31:00 +0800

Though, unfortunately, I am not aware of any online banking systems or
messengers that use PAKEs for user authentication, I'd like to mention
(hope you consider it interesting) that there are some existing cloud
signature solutions (digital signature servers) in Russia that use one of
PAKEs to authenticate users to their private keys stored in a cloud - in a
way that is pretty similar to the one that has been mentioned by Rich.

Best regards,
Stanislav

2017-11-16 15:23 GMT+08:00 Stanislav V. Smyshlyaev <[email-masked]>:

> In fact, PKEX (password-authenticated key exchange protocol by Dan
> Harkins, https://tools.ietf.org/html/draft-harkins-pkex-04 - for
> Richard), as all secure PAKE protocols can help to upgrade most cases of
> authentication, when some shared secret (password or, as in Rich's example,
> an account number), to solutions which do not require having a primary
> trust to someone you're authenticating to.
>