Subject: [Cfrg] NIST to include 25519 and 448 in their approved curves

From: "Salz, Rich" <[email-masked]>
Date: Thu, 2 Nov 2017 18:17:12 +0000

Congrats to all involved.

https://csrc.nist.gov/News/2017/Transition-Plans-for-Key-Establishment-Schemes

In addition, NIST guidelines on Elliptic Curve Cryptography are also being revised to propose the adoption of new elliptic curves specified in the Internet Engineering Task Force (IETF) RFC 7748. The upcoming draft of SP 800-186, which will specify approved elliptic curves, will include the curves currently specified in FIPS 186-4 and two additional curves: Curve25519 and Curve448.  Their associated key agreement schemes, X25519 and X448, will be considered for inclusion in a subsequent revision to SP 800-56A.  The CMVP does not intend to enforce compliance with SP 800-56A until these revisions are complete.

---

From: Tony Arcieri <[email-masked]>
Date: Thu, 2 Nov 2017 12:13:13 -0700

Great news!

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 3 Nov 2017 10:04:51 +0000

NIST appreciates the great work by the CFRG.

Regards,

Quynh.

________________________________
From: Cfrg <[email-masked]> on behalf of Tony Arcieri <[email-masked]>
Sent: Thursday, November 2, 2017 3:13:13 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Cfrg] NIST to include 25519 and 448 in their approved curves

Great news!

---

From: Dan Brown <[email-masked]>
Date: Fri, 3 Nov 2017 10:34:31 +0000

Credit is most due to djb.

From: Dang, Quynh (Fed)
Sent: Friday, November 3, 2017 6:05 AM
To: Tony Arcieri; [email-masked]
Cc: [email-masked]
Subject: Re: [Cfrg] NIST to include 25519 and 448 in their approved curves

Regards,

Quynh.

Great news!

---

From: William Whyte <[email-masked]>
Date: Fri, 3 Nov 2017 07:02:59 -0400

Is there any chance that NIST will permit eddsa?

Cheers,

William

On Fri, Nov 3, 2017 at 6:34 AM, Dan Brown <[email-masked]> wrote:

> *From: *Dang, Quynh (Fed)
> *Sent: *Friday, November 3, 2017 6:05 AM
> *To: *Tony Arcieri; [email-masked]
> *Cc: [email-masked]
> *Subject: *Re: [Cfrg] NIST to include 25519 and 448 in their approved
> curves
>
> ------------------------------
> *From:* Cfrg <[email-masked]> on behalf of Tony Arcieri <
> [email-masked]>
> *Sent:* Thursday, November 2, 2017 3:13:13 PM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [Cfrg] NIST to include 25519 and 448 in their approved
> curves
>
> Great news!
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

-- 

PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS:
[email-masked]

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 3 Nov 2017 11:08:35 +0000

Yes.

Quynh.

________________________________
From: William Whyte <[email-masked]>
Sent: Friday, November 3, 2017 7:02 AM
To: Dan Brown
Cc: Dang, Quynh (Fed); Tony Arcieri; [email-masked]; [email-masked]
Subject: Re: [Cfrg] NIST to include 25519 and 448 in their approved curves

Cheers,

William

On Fri, Nov 3, 2017 at 6:34 AM, Dan Brown <[email-masked]<mailto:[email-masked]>> wrote:
Credit is most due to djb.

From: Dang, Quynh (Fed)
Sent: Friday, November 3, 2017 6:05 AM
To: Tony Arcieri; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Cfrg] NIST to include 25519 and 448 in their approved curves

Regards,

Quynh.

________________________________
From: Cfrg <[email-masked]<mailto:[email-masked]>> on behalf of Tony Arcieri <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, November 2, 2017 3:13:13 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Cfrg] NIST to include 25519 and 448 in their approved curves

Great news!

_______________________________________________
Cfrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/cfrg<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fcfrg&data=02%7C01%7Cquynh.dang%40nist.gov%7Ca6df0c748e274cf625cc08d522aa7f37%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636453038029953605&sdata=Czy942q9JJil4EY%2Bkh%2FYCCLGE%2FeSBW7AjhFxVQRNpFM%3D&reserved=0>

--

PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS: [email-masked]<mailto:[email-masked]>