Subject: Re: [Cfrg] Dynamic Key Changes on Encrypted Sessions. - Draft I-D Attached

From: Peter Alexander <[email-masked]>
Date: Sat, 4 Nov 2017 10:36:12 -0400

Good morning everyone,

I am attaching my first go at a proper I-D for submission. This is the same
invention that I had mentioned previously, and is quite similar in scope to
what Stanislav is working on (draft-irtf-cfrg-re-keying-08).

Right now I am still working through the Doxygen documentation to translate
the control messages into a cleaner I-D format.

Kindly review this when you are able to do so, and share your comments.

Peter Alexander

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Sat, 4 Nov 2017 18:29:08 +0300

Dear colleagues,

The overall scope is close, but draft-irtf-cfrg-re-keying is about "why and
how to re-key", and the proposed draft is about "when to re-key and how to
control the process".

As a possible way, we could discuss in CFRG, which general principles of
Peter's document (overall principles of how to control the re-keying
process) would be reasonble to add to draft-irtf-cfrg-re-keying.

And questions related to the particular protocols (e.g., IPsec, as in the
provided Peter Alexander's draft) seem to be more convenient to be
discussed within corresponding working groups - such as ipsecme WG.

Best regards,

Stanislav

2017-11-04 17:36 GMT+03:00 Peter Alexander <[email-masked]>:

> Good morning everyone,
>
> I am attaching my first go at a proper I-D for submission. This is the
> same invention that I had mentioned previously, and is quite similar in
> scope to what Stanislav is working on (draft-irtf-cfrg-re-keying-08).
>
> Right now I am still working through the Doxygen documentation to
> translate the control messages into a cleaner I-D format.
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: "Paterson, Kenny" <[email-masked]>
Date: Mon, 6 Nov 2017 10:53:29 +0000

Dear Stanislav,

This sounds like a reasonable way of proceeding.

Please would you initiate a discussion here on the list of the relevant
principles from Peter's document?

Regards,

Kenny 

On 04/11/2017 15:29, "Cfrg on behalf of Stanislav V. Smyshlyaev"
<[email-masked] on behalf of [email-masked]> wrote:

> how to re-key", and the proposed draft is about "when to re-key and how
>to control the process".
>
>

---

From: Станислав Смышляев <[email-masked]>
Date: Mon, 06 Nov 2017 14:17:34 +0300

Dear Kenny, dear colleagues,

Definitely, I'll do this. But, if you don't mind, I'd prefer to wait a few days for the Crypto Review Panel reviews to ‎be posted, because the issues related to the scope of the Peter's document ("when to re-key and how to control the process")‎ could be also mentioned in the reviews - so it would be better to take those considerations into account before further discussions. 

Best regards,
Stanislav
‎
  Исходное сообщение  
От: Paterson, Kenny
Отправлено: понедельник, 6 ноября 2017 г., 13:53
Кому: Stanislav V. Smyshlyaev; Peter Alexander
Копия: [email-masked]
Тема: Re: [Cfrg] Dynamic Key Changes on Encrypted Sessions. - Draft I-D Attached

Dear Stanislav,

Regards,

Kenny

---

From: Peter Alexander <[email-masked]>
Date: Mon, 6 Nov 2017 08:24:17 -0500

Dear Colleagues,

Thank you for taking my work into consideration. I was worried that nothing
would ever come of it, however the warm reception is most welcome.
Furthermore, I am very happy to see progress on this, and would be more
than willing to review, and adopt changes as necessary.

Peter Alexander
Email: [email-masked]

On Mon, Nov 6, 2017 at 6:17 AM, Станислав Смышляев <[email-masked]>
wrote:

> Definitely, I'll do this. But, if you don't mind, I'd prefer to wait a few
> days for the Crypto Review Panel reviews to ‎be posted, because the issues
> related to the scope of the Peter's document ("when to re-key and how to
> control the process")‎ could be also mentioned in the reviews - so it would
> be better to take those considerations into account before further
> discussions.
>
> Best regards,
> Stanislav
> ‎
>   Исходное сообщение
> От: Paterson, Kenny