Subject: Re: [Cfrg] SHE Key Update Protocol

From: =JeffH <[email-masked]>
Date: Wed, 11 Apr 2018 13:49:26 -0700

> Anyone know of any published formal analysis/modeling of it?

hm, I get only one hit when searching goog scholar for [ "SHE Key 
Update" Protocol ]:

Approaches for secure and efficient in-vehicle key management
T Sugashima, DK Oka, C Vuillaume - SAE International Journal of …, 2016 
- papers.sae.org
https://www.denso.com/jp/ja/innovation/technology/dtr/v21/paper-16.pdf

..which contains some modest threat analysis.

In it, they say in part:

HIS,  a  car  consortium  consisting  of  several  major
German  auto  manufacturers,  has  developed  an
implementation  specification  for  secure  hardware
called  SHE  (secure  hardware  extension).  SHE
provides  various  security  functionalities  such  as  MAC
generation  and  verification  based  on  a  hardware  AES
engine  and  loading  of  symmetric  keys  into  secure
key  storage.  To  be  able  to  support  security  use  cases
where  SHE  functionality  is  not  sufficient,  Bosch  has
developed  a  Bosch  HSM  (hardware  security  module)
specification.  HSM  provides  further  support  for
security  functionalities  as  it  has  in  addition  to  a
hardware  AES  engine,  a  dedicated  secure  CPU  and
secure  memory  allowing  it  to  be  programmable  to
support  a  vast  range  of  use  cases.  The  AUTOSAR
specification  4.2.1  includes  CSM  (crypto  services
manager)  and  describes  how  cryptographic  keys
can  be  used  to  support  use  cases  such  as  to  protect
the  in-vehicle  communication.

tho search goog scholar for [ SHE  "Secure hardware extension" analysis 
] yields some further hits, including:

Design, implementation, and evaluation of a vehicular hardware security 
module
M Wolf, T Gendrullis - … Conference on Information Security and 
Cryptology, 2011 - Springer
http://www.marko-wolf.de/files/WoGe12_Automotive_HSM.pdf

..also containing some modest security analysis.

HTH,

=JeffH

---

From: Henry B Hotz <[email-masked]>
Date: Fri, 13 Apr 2018 06:57:17 -0700

Thanks. 

Personal email. [email-masked]

> On Apr 11, 2018, at 1:49 PM, =JeffH <[email-masked]> wrote:
> 
> hm, I get only one hit when searching goog scholar for [ "SHE Key Update" Protocol ]:
> 
> T Sugashima, DK Oka, C Vuillaume - SAE International Journal of …, 2016 - papers.sae.org
> tho search goog scholar for [ SHE  "Secure hardware extension" analysis ] yields some further hits, including:
> 
> Design, implementation, and evaluation of a vehicular hardware security module
> M Wolf, T Gendrullis - … Conference on Information Security and Cryptology, 2011 - Springer
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg