Subject: [Cfrg] Adoption call for draft-arciszewski-xchacha

From: "Paterson, Kenny" <[email-masked]>
Date: Tue, 20 Nov 2018 11:23:03 +0000

Dear CFRG,

This email starts a 2-week adoption call for:

https://datatracker.ietf.org/doc/draft-arciszewski-xchacha/

XChaCha: eXtended-nonce ChaCha and AEAD_XChaCha20_Poly1305

Please give your views on whether this document should be adopted as a CFRG draft, and if so, whether you'd be willing to help work on it/review it.

Thanks,

Kenny (for the chairs)

---

From: Russ Housley <[email-masked]>
Date: Tue, 20 Nov 2018 07:02:24 -0500

I skimmed the document, and this looks like a good think for the CFRG to adopt.  I am willing to review.

Russ

> On Nov 20, 2018, at 6:23 AM, Paterson, Kenny <[email-masked]> wrote:
> 
> Dear CFRG,
>

---

From: Neil Madden <[email-masked]>
Date: Tue, 20 Nov 2018 13:26:11 +0000

I would like to see this draft adopted by CFRG and would be willing to review from an implementor’s perspective.

Kind regards,

Neil

> On 20 Nov 2018, at 11:23, Paterson, Kenny <[email-masked]> wrote:
> 
> Dear CFRG,
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Tony Arcieri <[email-masked]>
Date: Tue, 20 Nov 2018 07:45:18 -0800

I think this document describes an important building block for protocols
and have reviewed past drafts, but would also be happy to look over this
one again in detail.

On Tue, Nov 20, 2018 at 3:23 AM Paterson, Kenny <[email-masked]>
wrote:

> Please give your views on whether this document should be adopted as a
> CFRG draft, and if so, whether you'd be willing to help work on it/review
> it.
>
> Thanks,
>
> Kenny (for the chairs)
>

-- 
Tony Arcieri

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 20 Nov 2018 20:30:30 +0000

I'm okay with adopting this, but I'd prefer the names be like XN.... for extended nonce.  Or something similar.  Just an X makes it sounds like this is a general extension, and I think it's best to be as explicit as possible especially with crypto.

---

From: Adam Langley <[email-masked]>
Date: Tue, 20 Nov 2018 15:36:34 -0800

> Please give your views on whether this document should be adopted as a CFRG draft, and if so, whether you'd be willing to help work on it/review it.

I support the adoption of this draft as a WG item.

-- 
Adam Langley [email-masked] https://www.imperialviolet.org

---

From: Christopher Wood <[email-masked]>
Date: Tue, 20 Nov 2018 15:51:02 -0800

> Please give your views on whether this document should be adopted as a CFRG draft, and if so, whether you'd be willing to help work on it/review it.

I support adoption, have reviewed it, and am willing to do so again in
the future.

Best,
Chris

---

From: Loganaden Velvindron <[email-masked]>
Date: Wed, 21 Nov 2018 10:43:32 +0400

On Wed, Nov 21, 2018 at 3:37 AM Adam Langley <[email-masked]> wrote:

> I also support the adoption of this I-D.

---

From: "Vassilev, Apostol (Fed)" <[email-masked]>
Date: Wed, 21 Nov 2018 14:36:18 +0000

Hi Kenny,

I support adoption but find this draft a bit too brief. It lacks security considerations and IANA sections. I am willing to review it provided these two sections are added. 

Thanks, 
Apostol

> On Nov 20, 2018, at 5:23 AM, Paterson, Kenny <[email-masked]> wrote:
> 
> Dear CFRG,
> 
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-arciszewski-xchacha%2F&amp;data=02%7C01%7Capostol.vassilev%40nist.gov%7Cb0af77eb98804bdb98df08d64eda9c3f%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636783098178419268&amp;sdata=tc6bkRgvMZfXV42a%2BDxtxPYnduJUrkK1gUI86II9Ggg%3D&amp;reserved=0
> 
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fcfrg&amp;data=02%7C01%7Capostol.vassilev%40nist.gov%7Cb0af77eb98804bdb98df08d64eda9c3f%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636783098178429271&amp;sdata=rQGH0rRv7jgECRGAazrLB3bFUuADkbANHgQVowiXAY0%3D&amp;reserved=0