Subject: Re: [Cfrg] Adoption call for draft-arciszewski-xchacha

From: "David McGrew (mcgrew)" <[email-masked]>
Date: Tue, 20 Nov 2018 21:04:24 +0000

Hi Kenny,

I support adoption, and will review the draft (actually, I already commented on the draft on Oct 12).  Some important nits: the draft needs a security considerations section and an IANA section to register the new AEAD.  

best

David

On 11/20/18, 6:23 AM, "Cfrg on behalf of Paterson, Kenny" <[email-masked] on behalf of [email-masked]> wrote:

>Dear CFRG,
>
>This email starts a 2-week adoption call for:
>
>https://datatracker.ietf.org/doc/draft-arciszewski-xchacha/
>
>XChaCha: eXtended-nonce ChaCha and AEAD_XChaCha20_Poly1305
>
>Please give your views on whether this document should be adopted as a CFRG draft, and if so, whether you'd be willing to help work on it/review it.
>
>Thanks,
>
>Kenny (for the chairs)
>
>_______________________________________________
>Cfrg mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/cfrg

---

From: Scott Arciszewski <[email-masked]>
Date: Tue, 20 Nov 2018 18:57:22 -0500

Hi David,

I've started work on these sections since draft02. I'm not sure how to go
about getting the IANA reservations.

https://github.com/bikeshedders/xchacha-rfc/blob/984b586f3cb3c32ae475c2580c505755e6de97dd/draft-arciszewski-xchacha-rfc-03.txt#L310-L406

Kind regards,

Scott Arciszewski
Chief Development Officer
Paragon Initiative Enterprises <https://paragonie.com>

On Tue, Nov 20, 2018 at 4:04 PM David McGrew (mcgrew) <[email-masked]>
wrote:

> Hi Kenny,
>
> I support adoption, and will review the draft (actually, I already
> commented on the draft on Oct 12).  Some important nits: the draft needs a
> security considerations section and an IANA section to register the new
> AEAD.
>
> best
>
> David
>
>
>
> On 11/20/18, 6:23 AM, "Cfrg on behalf of Paterson, Kenny" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> >Dear CFRG,
> >
> >Please give your views on whether this document should be adopted as a
> CFRG draft, and if so, whether you'd be willing to help work on it/review
> it.
> >
> >Thanks,
> >
> >Kenny (for the chairs)
> >

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 21 Nov 2018 09:42:15 +0300

Dear colleagues,

I support the adoption of this draft as a RG item.

Best regards,
Stanislav

ср, 21 нояб. 2018 г. в 02:58, Scott Arciszewski <[email-masked]>:

> <https://github.com/bikeshedders/xchacha-rfc/blob/984b586f3cb3c32ae475c2580c505755e6de97dd/draft-arciszewski-xchacha-rfc-03..txt#L310-L406>
>
> Kind regards,
>
> Scott Arciszewski

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 23 Nov 2018 19:44:16 -0600

> https://github.com/bikeshedders/xchacha-rfc/blob/984b586f3cb3c32ae475c2580c505755e6de97dd/draft-arciszewski-xchacha-rfc-03.txt#L310-L406

See RFC 8126, though the text linked above ought to be sufficient to convey
the needed information.

-Ben

---

From: Yoav Nir <[email-masked]>
Date: Sat, 24 Nov 2018 23:56:46 +0200

Hi, Scott.

The usual way is to add an IANA considerations section with text like this:

IANA is requested to assign an entry in the "Authenticated Encryption with Associated Data (AEAD) Parameters" registry with "AEAD_XChaCha20_Poly1305" as the name and this document as reference.

(I just copied from the last draft of ChaCha20-Poly1305 and substituted the name)

This will get you an assignment when the draft goes to the RFC Editor.

If for some reason you want this allocation earlier, you can fill out a form here: https://www.iana.org/form/protocol-assignment <https://www.iana.org/form/protocol-assignment>

What IANA does when such a request is made is contact the designated experts for this particular registry ( https://www.iana.org/assignments/aead-parameters/aead-parameters.xhtml#aead-parameters-2 <https://www.iana.org/assignments/aead-parameters/aead-parameters.xhtml#aead-parameters-2> ), and ask them if it’s appropriate. David is one of those experts, BTW.

In any case, I don’t think the AEAD number appears in any protocol AFAICT, so I don’t think there’s much value in getting an early assignment.

Yoav

> On 21 Nov 2018, at 1:57, Scott Arciszewski <[email-masked]> wrote:
> 
> Hi David,
> 
> I've started work on these sections since draft02. I'm not sure how to go about getting the IANA reservations.
> 
> https://github.com/bikeshedders/xchacha-rfc/blob/984b586f3cb3c32ae475c2580c505755e6de97dd/draft-arciszewski-xchacha-rfc-03.txt#L310-L406 <https://github.com/bikeshedders/xchacha-rfc/blob/984b586f3cb3c32ae475c2580c505755e6de97dd/draft-arciszewski-xchacha-rfc-03..txt#L310-L406>
> 
> Kind regards,
> 
> Scott Arciszewski
> Paragon Initiative Enterprises <https://paragonie.com/>
> 
> On Tue, Nov 20, 2018 at 4:04 PM David McGrew (mcgrew) <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Kenny,
> 
> On 11/20/18, 6:23 AM, "Cfrg on behalf of Paterson, Kenny" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
> >Dear CFRG,
> >
> >https://datatracker.ietf.org/doc/draft-arciszewski-xchacha/ <https://datatracker.ietf.org/doc/draft-arciszewski-xchacha/>
> >
> >[email-masked] <mailto:[email-masked]>
> >https://www.irtf.org/mailman/listinfo/cfrg <https://www.irtf.org/mailman/listinfo/cfrg>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/cfrg <https://www.irtf.org/mailman/listinfo/cfrg>