Subject: Re: [CHANNEL-BINDING] Re: draft-ietf-sasl-gs2 AD review comments

From: "Jeffrey Hutzelman" <[email-masked]>
Date: 09 Oct 2007 21:07:00 -0400

Fine; I don't have any particular reason to prefer nul.  But, why not; what problem are you concerned about?

-----Original Message-----
From: Sam Hartman <[email-masked]>
Date: Tuesday, Oct 9, 2007 8:48 pm
Subject: Re: [CHANNEL-BINDING] Re: draft-ietf-sasl-gs2 AD review comments
To: Jeffrey Hutzelman <[email-masked]>
CC: Nicolas Williams <[email-masked]>, [email-masked],        [email-masked]

>>>>> "Jeffrey" == Jeffrey Hutzelman <[email-masked]> writes:
>
>    Jeffrey> On Tuesday, October 09, 2007 04:25:16 PM -0500 Nicolas
>
>    Jeffrey> I'm inclined to specify that all protocols should work
>    Jeffrey> the same way, transporting a single octet string which
>    Jeffrey> consists of the prefix, followed by a NUL octet, followed
>    Jeffrey> by the actual binding data.
>
>Please don't use nul; use : or something like that and forbid that
>character from prefixes.
>
>
>

_______________________________________________
CHANNEL-BINDING mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/channel-binding

---

From: Sam Hartman <[email-masked]>
Date: Wed, 10 Oct 2007 09:03:34 -0400

>>>>> "Jeffrey" == Jeffrey Hutzelman <[email-masked]> writes:

    Jeffrey> Fine; I don't have any particular reason to prefer nul.
    Jeffrey> But, why not; what problem are you concerned about?

C strings.
Yes, a correct implementation will not have this problem.
I see no reason to make it harder though.