Subject: Re: [clue] Comment on the presentation use case

From: <[email-masked]>
Date: Mon, 8 Aug 2011 15:56:48 +0000

Hi,

To me, it should be part of the telepresence protocols at least to enable the interoperability, as the presentation based on video stream allows it. 

The point is that video stream is not convenient for the use cases I suggested. But it does not necessarily mean that we should bundle a full data sharing protocol with telepresence. Something simpler, like the RFB option of draft-garcia-mmusic-sdp-collaboration, could be a candidate.

Stephane.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Paul Kyzivat
Envoyé : jeudi 28 juillet 2011 13:41
À : CHATRAS Bruno RD-CORE-ISS
Cc : [email-masked]
Objet : Re: [clue] Comment on the presentation use case

On 7/28/11 2:37 AM, [email-masked] wrote:
> I think we should take a look to
> http://tools.ietf.org/html/draft-garcia-mmusic-sdp-collaboration-00

Maybe. But that is almost orthogonal to what I was suggesting.

	THanks,
	Paul
	(as individual)

> Bruno
>
>> -----Message d'origine-----
>> De : [email-masked] [mailto:[email-masked]] De la part de
>> Paul Kyzivat
>> Envoyé : jeudi 28 juillet 2011 06:05
>> À : Roni Even
>> Cc : [email-masked]
>> Objet : Re: [clue] Comment on the presentation use case
>>
>> On 7/27/11 11:28 PM, Roni Even wrote:
>>> Hi,
>>> HTTP is not defining a common data sharing protocol. WebEx may be
>> carried
>>> over HTTP but the data sharing application is not standard. What I
>> meant is
>>> that it can either be something that is a common data sharing
>> protocol or
>>> something that is carried as an RTP payload which require some common
>>> defined protocol on top.
>>
>> I was being a bit tongue in cheek, though not entirely.
>> Of course you are right - that if you want to push data to everybody
>> you
>> need more.
>>
>> But data sharing by pointing a video camera at a piece of paper is a
>> tad
>> out of date. Connecting the video port on a user's computer as a video
>> source and distributing it with the other video is better than that.
>> But
>> its not nearly as convenient as webex or any of its competitors.
>>
>> It isn't entirely clear that its *necessary* to bundle the data sharing
>> application with the telepresence protocols. Its kind of limiting since
>> the web apps evolve very rapidly. Perhaps we should be doing the
>> opposite of that: providing a way to embed the control of the
>> telepresence system into a web app.
>>
>> 	Thanks,
>> 	Paul
>>
>>>> -----Original Message-----
>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of
>>>> Paul Kyzivat
>>>> Sent: Thursday, July 28, 2011 1:29 AM
>>>> To: [email-masked]
>>>> Subject: Re: [clue] Comment on the presentation use case
>>>>
>>>> On 7/27/11 6:07 PM, Roni Even wrote:
>>>>> Hi Stephane,
>>>>>
>>>>> Is there a standard protocol that is used for conveying this
>>>>> information, is it RTP based.
>>>>
>>>> AFAIK this is often http. (E.g. webex)
>>>>
>>>>> To me this is a separate application that can be integrated in the
>>>>> application level and not as part of the multistream.
>>>>
>>>> I guess this depends on whether the support for it is integrated
>> into
>>>> the "room", or is just incidental equipment brought by the users,
>> not
>>>> formally related to the telepresence session.
>>>>
>>>> 	Thanks,
>>>> 	Paul
>>>> 	(speaking as an individual)
>>>>
>>>>> Roni
>>>>>
>>>>> [email-masked] [mailto:[email-masked]] *On Behalf Of
>>>>> [email-masked]
>>>>> *Sent:* Thursday, July 21, 2011 2:33 PM
>>>>> *To:* [email-masked]
>>>>> *Subject:* [clue] Comment on the presentation use case*
>>>>>
>>>>> **
>>>>>
>>>>> *Hi,*
>>>>>
>>>>> **
>>>>>
>>>>> *The presentation use case as described in the use-cases document
>> is
>>>>> based on the assumption that the presentation stream relies on a
>>>> video
>>>>> stream, and is limited to usage of presentation video streams. But
>> we
>>>>> could also consider collaborative use cases, meaningful for
>>>>> telepresence, which are not covered by the existing text.*
>>>>>
>>>>> *I propose to complete the existing text as follows:*
>>>>>
>>>>> **
>>>>>
>>>>> *Furthermore, although most today's systems use video streams for
>>>>> presentations, there are use cases where this is not suitable. For
>>>> example:*
>>>>>
>>>>> *- The professor which shares an electronic whiteboard (could be a
>>>>> whiteboard application on a PC, with screen capture of the PC)
>> where
>>>> all
>>>>> students can participate. Students will take control of the shared
>>>>> whiteboard in turns.*
>>>>>
>>>>> *- In a multipoint meeting, a shared document can be kept always
>>>> visible
>>>>> in a screen, while other documents are presented on other screens
>>>> (with
>>>>> possible in turns presentation). For instance, for the purpose of
>>>> shared
>>>>> design document, notes taking, polls, etc. A shared document
>> implies
>>>>> that all participants can modify it in turns.*
>>>>>
>>>>> *"*
>>>>>
>>>>> **
>>>>>
>>>>> **
>>>>>
>>>>> *St ephane. v>
>>>>> *
>>>>>
>>>>> *
>>>>> *
>>>>>
>>>>> *_______________________________________________
>>>>> clue mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/clue
>>>>> *
>>>>
>>>> _______________________________________________
>>>> clue mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/clue
>>>
>>>
>>
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>

_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 08 Aug 2011 15:22:43 -0400

> The point is that video stream is not convenient for the use cases I suggested. But it does not necessarily mean that we should bundle a full data sharing protocol with telepresence. Something simp…

What I was suggesting is that maybe it would make sense to turn those 
relationships "inside out".

For instance when I use a collaboration tool like Webex, the 
collaboration is set up first via the web, and defines the set of 
participants. Then a voice session can be added. For pragmatic reasons, 
the voice conferencing seems to be pretty distinct. (I'm not certain how 
webex handles video. I suspect it is doing it via the web, not the 
telephony conference.)

Its not hard to imagine the same sort of setup, but with a multiparty 
telepresence session instead of the traditional voice conference. In 
such a case, you would probably want the collaboration tool (webex, or 
whatever) to mediate the UI for the web collaboration, the roster, etc. 
It might delegate a lot of that to the telepresence infrastructure.

But that does raise some questions about how all the components fit 
together. Is there a single screen for the collaboration session in a 
telepresence room? What about input to that - keyboard, mouse, etc.? Or 
do we assume that each person in the room has their own computer with 
input, display, etc. and maybe a way to slave the web collaboration 
session to one or more of the big displays in the room?

What probably *can't* be done right now is nail down a particular web 
collaboration service (e.g. Webex) or protocol. That does complicate 
slaving the collaboration session to a screen, unless its done by having 
someone connect a video connection to their own computer.

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Fri, 12 Aug 2011 08:48:41 +0000

Hi Paul,

I understand your suggestion, and I am aware that it could be a solution. It certainly makes sense, but I am not sure of how it could be integrated in CLUE. To me, this is a matter of application integration, at application level.

My suggestion is that we should think of a solution that provides more satisfying collaboration within telepresence, with the same level of interoperability and multistream interaction as presentation video stream provides, but with more satisfying quality (video is not suitable for all kinds of shared documents) and more collaborative features.
I don't think that the kind of relationship that you suggest is the only solution.

Stephane. 

-----Message d'origine-----
De : Paul Kyzivat [mailto:[email-masked]] 
Envoyé : lundi 8 août 2011 21:23
À : CAZEAUX Stephane RD-BIZZ-CAE
Cc : [email-masked]
Objet : Re: [clue] Comment on the presentation use case

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Aug 2011 11:30:43 -0400

> I don't think that the kind of relationship that you suggest is the only solution.

IMO the main thing is to not constrain the mechanism used for 
collaboration/web sharing. That stuff is evolving at "web speed". 
Anything you nail down that is constraining will be obsolete before it 
gets out.

(I've been looking more at RTCWEB recently, and I'm wondering if perhaps 
CLUE ought to be based on that.)

	Thanks,
	Paul (as individual)