Subject: Re: [clue] Support for information about the spacing between monitors.

From: Stephen Botzko <[email-masked]>
Date: Sun, 25 Sep 2011 10:20:02 -0400

Ok.  So the signaling that is needed is the gap between captures, not the gap between monitors. 

I don't think pixels is the right measure, since the relationship of pixels to distance depends on resolution.

Steve

-----Original Message-----
From: Roni Even <[email-masked]>
Sent: Sunday, September 25, 2011 8:41 AM
To: 'Stephen Botzko' <[email-masked]>
Cc: 'Duckworth, Mark' <[email-masked]>; [email-masked]
Subject: RE: [clue] Support for information about the spacing between monitors.

Hi,

What I mean is that the local capture is fixed based on the gap between the
local monitors such that a person that stands between two cameras will look
correct on the local two displays, There will be a missing part that is
proportional  to the gap. This is based on the gaps between the local
monitors.

Now if the remote monitors will have the same gap (In pixels) the rendering
on the receiver will look the same as the local display, otherwise the
renderer will need to adjust.

Roni

From: Stephen Botzko [mailto:[email-masked]] 
Sent: Sunday, September 25, 2011 4:21 AM

[The entire original message is not included]

---

From: Roni Even <[email-masked]>
Date: Sun, 25 Sep 2011 19:44:18 +0300

Steve,
It is east to measure based on the local monitors using pixels since I think
that you can calibrate the captures using the local monitors.
Roni

> Sent: Sunday, September 25, 2011 5:20 PM
> To: Roni Even
> Cc: 'Duckworth, Mark'; [email-masked]
> I don't think pixels is the right measure, since the relationship of
> pixels to distance depends on resolution.
> 
> Steve
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 26 Sep 2011 12:55:27 +0200

I guess there is something I'm not getting here.

If the idea of the receiving side is to present a single continuous image of what is sent why is it not asking for a single view that happens to have an aspect ratio of 32x9 rather that 16x9. Surely it is then up to the receiver how that is then divided between 2 screens, if indeed it is. 

Surely how I choose to break up a single view between multiple monitors is up to the local side, the same as if I choose to make one big screen out of a 4x4 matrix of smaller screens?

Or are you implying that the source actually needs to be 2 cameras to support this?

Keith

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Roni Even
> Sent: 25 September 2011 17:44
> To: 'Stephen Botzko'
> Cc: [email-masked]
> Subject: Re: [clue] Support for information about the spacing between
> monitors.
> 
> Steve,
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 26 Sep 2011 07:16:23 -0400

One reason Telepresence systems use multiple cameras because that is the
most cost-effective way to create a high resolution panorama.  Creating and
encoding a 5760 x 1080 image is not that easy.  It is much simpler to create
3 1920x1080 images.  This will only get worse when resolution increases to
4K.

Using multiple captures to create the panorama also has advantages when
there are multiple receivers and senders.  You often want to see a portion
of multiple rooms instead of just a single room.  There are significant
bandwidth issues if you are sending 2-4x more pixels than the receiver
wants.

One of the main reasons CLUE was formed was to enable such use of multiple
captures.

Stephen Botzko

On Mon, Sep 26, 2011 at 6:55 AM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> If the idea of the receiving side is to present a single continuous image
> of what is sent why is it not asking for a single view that happens to have
> an aspect ratio of 32x9 rather that 16x9. Surely it is then up to the
> receiver how that is then divided between 2 screens, if indeed it is.
>
> Surely how I choose to break up a single view between multiple monitors is
> up to the local side, the same as if I choose to make one big screen out of
> a 4x4 matrix of smaller screens?
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 26 Sep 2011 13:24:30 +0200

So I guess what I am now getting is that:

The sender is sending a single view which happens to be made up from two cameras. So the sender is saying, I am sending you two video streams which you can stitch together to make a single view.

How the receiver then presents them, be it as a narrow slot on a single monitor, on two monitors that directly equate to video streams, or on more monitors is entirely up to the receiver.

Keith

________________________________
From: Stephen Botzko [mailto:[email-masked]]
Sent: 26 September 2011 12:16
To: DRAGE, Keith (Keith)
Cc: Roni Even; [email-masked]
Subject: Re: [clue] Support for information about the spacing between monitors.

One reason Telepresence systems use multiple cameras because that is the most cost-effective way to create a high resolution panorama.  Creating and encoding a 5760 x 1080 image is not that easy.  It is much simpler to create 3 1920x1080 images.  This will only get worse when resolution increases to 4K.

Using multiple captures to create the panorama also has advantages when there are multiple receivers and senders.  You often want to see a portion of multiple rooms instead of just a single room.  There are significant bandwidth issues if you are sending 2-4x more pixels than the receiver wants.

One of the main reasons CLUE was formed was to enable such use of multiple captures.

Stephen Botzko

On Mon, Sep 26, 2011 at 6:55 AM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
I guess there is something I'm not getting here.

Keith

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of
> Roni Even
> Cc: [email-masked]<mailto:[email-masked]>
> > From: Stephen Botzko [mailto:[email-masked]<mailto:[email-masked]>]
> > Cc: 'Duckworth, Mark'; [email-masked]<mailto:[email-masked]>
> > From: Roni Even <[email-masked]<mailto:[email-masked]>>
> > To: 'Stephen Botzko' <[email-masked]<mailto:[email-masked]>>
> > Cc: 'Duckworth, Mark' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> > From: Stephen Botzko [mailto:[email-masked]<mailto:[email-masked]>]
> [email-masked]<mailto:[email-masked]>

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 26 Sep 2011 07:38:55 -0400

Yes, that is the basic idea.

We are calling the "view" a "scene", which is made up of an arbitrary number
of audio or video "captures".  There is some support for enabling multiple
scenes within the same room (showing different parts of the room).

Note also that there are some applications for having multiple cameras aimed
at the same area (giving a left image, straight on image, and right image of
the same space).

Steve B.

On Mon, Sep 26, 2011 at 7:24 AM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>  So I guess what I am now getting is that:****
>
> ** **
>
> The sender is sending a single view which happens to be made up from two
> cameras. So the sender is saying, I am sending you two video streams which
> you can stitch together to make a single view.****
>
> ** **
>
> How the receiver then presents them, be it as a narrow slot on a single
> monitor, on two monitors that directly equate to video streams, or on more
> monitors is entirely up to the receiver.****
>
> ** **
>
> Keith****
>
> ** **
>   ------------------------------
>
> *From:* Stephen Botzko [mailto:[email-masked]]
> *Sent:* 26 September 2011 12:16
> *To:* DRAGE, Keith (Keith)
> *Cc:* Roni Even; [email-masked]
>
> *Subject:* Re: [clue] Support for information about the spacing between
> monitors.
> ****
>
>  ** **
>
> ****
> [email-masked]> wrote:****
>
> Keith****
> > Roni Even****
> > Subject: Re: [clue] Support for information about the spacing between***
> *
>
> > monitors.
> >
> > Steve,
> >****
> > https://www.ietf.org/mailman/listinfo/clue****
>
> ** **
>