Subject: [clue] #2: Use cases for selecting composed captures

From: "clue issue tracker" <[email-masked]>
Date: Tue, 10 Jan 2012 18:15:28 -0000

#2: Use cases for selecting composed captures

 Roni Even to post use cases for selecting composed captures, on the
 mailing list.

-- 
------------------------------------+-----------------------
 Reporter:  pkyzivat@…              |      Owner:  Roni Even
     Type:  task                    |     Status:  new
 Priority:  major                   |  Milestone:
Component:  telepresence-use-cases  |    Version:
 Severity:  Active WG Document      |   Keywords:
------------------------------------+-----------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/2>
clue <http://tools.ietf.org/wg/clue/>

---

From: Roni even <[email-masked]>
Date: Tue, 10 Jan 2012 19:26:33 +0000

Hi,
I do not understand why you this issue is still on my name. I sent previous emails to the list about the use cases. I hope this is my last email for the tracker on the issue and it will start the discussion.

The current description of composed in section 5.4.2 is    
"A Boolean variable to indicate whether the MC is a mix or composition
   of other MCs or Streams.  (This could indicate for example a
   continuous presence view of multiple images in a grid, or a large
   image with smaller picture-in-picture images in it.  When applied to
   an audio capture, it indicates a composition of ACs by some mixing
   algorithm)
   This attribute is not intended to differentiate between different
   ways of composing or mixing images.  For possible extension of the
   framework, additional attributes could be defined to distinguish
   between different ways of composing or mixing captures.  For example,
   with different video layout arrangements of composing multiple images
   into one, or different audio mixing algorithms."

Note that it says that there can be different composition options and the editors decided that the attribute should not differentiate between them and do it only in extensions. So the issue is not what are the use cases since the draft talk about different cases but whether the cases should be specified here and provide more options for the provider to propose different mixes allowing the consumer to select between them.

I can give again the most obvious use case which is the support for site switch and segment switch modes that are part of the use cases draft.
The provider should be able to specify if the video capture is based on site switch or segment switch or say that it can support one of them or both. The consumer should be able to ask for a specific view based on the mixed policy.

For point to point calls that use case for the provider to specify what is being offered. Examples of different options may be a view of current speaker with a PiP that has the previous speaker, or the whole room or a mix of the other capture devices. Another option is a mix of the active speaker with the center capture device if the speaker is not in the center. 
All these options cannot be specified by a Boolean called composed.

The current description of auto switch in term of capture area does not provide any information about the actual size of each view. Note that auto switch algorithm is not defined and is not meant to be unique. (voice activated is an option) other options are switch input every 30 seconds, ...

Roni Even 

________________________________________
From: clue issue tracker [[email-masked]]
Sent: Tuesday, January 10, 2012 20:15
To: [email-masked]
Cc: [email-masked]; Roni even
Subject: [clue] #2: Use cases for selecting composed captures

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 11 Jan 2012 14:12:33 -0500

> I do not understand why you this issue is still on my name. I sent previous emails to the list about the use cases. I hope this is my last email for the tracker on the issue and it will start the d…

 From the minutes on the discussion of the framework in Taipei:

| Selecting Composed Captures:
|
| Options-
|
| ·      do nothing
|
| ·      attempt to define a few specific policies
|
| Charles Eckel - "hints" in prev. framework draft may be sufficient.
|
| Jonathan Lennox - do we have details on policies?
|
| Stephen Botzko - lots of different conference/composition policies, 
very difficult to structure this information meaningfully.
|
| Allyn Romanow - agrees this is difficult, would rather postpone this
|
| Roni Even - sees distinction between requesting and selecting
|
| Mary Barnes - "Policy" word is scary, XCON struggled with a similar issue.
|
| Action - Roni Even to provide use cases on list for discussion.
|
| Conclusion: there is agreement that source selection work needs to 
continue, at least as requirements. Actual mechanism might be handed off 
to another group.

This is the source of the action item. The option to do nothing was 
discarded, leaving the need to do something more. I don't find anything 
on the list subsequent to this session directly addressing this subject.

The goal was to initiate more discussion towards what to specify.

Maybe this mail will at least start that discussion.

	Thanks,
	Paul

> Ticket URL:<http://trac.tools.ietf.org/wg/clue/trac/ticket/2>
> clue<http://tools.ietf.org/wg/clue/>

---

From: "Roni Even" <[email-masked]>
Date: Tue, 17 Jan 2012 09:49:02 +0200

Hi,
I posted an email that addresses this issue http://www.ietf.org/mail-archive/web/clue/current/msg00950.html 
How and when will the issue tracker be updated
Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> clue issue tracker
> Sent: Tuesday, January 10, 2012 8:15 PM
> Cc: [email-masked]
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "clue issue tracker" <[email-masked]>
Date: Mon, 23 Jan 2012 22:12:04 -0000

Changes (by mary.ietf.barnes@…):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 mailing list.

 Per Roni's comment, he posted an email with the use cases for selecting
 composed captures.   Thus, this issue is closed.

-- 
------------------------------------+------------------------
 Reporter:  pkyzivat@…              |       Owner:  Roni Even
     Type:  task                    |      Status:  closed
 Priority:  major                   |   Milestone:
Component:  telepresence-use-cases  |     Version:
 Severity:  Active WG Document      |  Resolution:  fixed
 Keywords:                          |
------------------------------------+------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/2#comment:2>
clue <http://tools.ietf.org/wg/clue/>