Subject: [clue] Minutes: Design Team Meeting - Jan. 17th, 2012

From: Mary Barnes <[email-masked]>
Date: Fri, 20 Jan 2012 16:15:36 -0600

Hi all,

Below, please find the minutes from the design team meeting held on
Jan 17th, 2012.   The minutes are also on the wiki.  Thanks to
Marshall and John Leslie for taking notes.
http://trac.tools.ietf.org/wg/clue/trac/wiki/Design-Team

I will shortly forward Webex details for next Tuesday's call.

Regards,
Mary.

======================================================

CLUE WG Design Team Call   January 17th, 2012
Chairs: Mary Barnes

Attendees:
Stephen Botzko
Mark Duckworth
Marshall Eubanks
Roni Even
Jonathan Lennox
John Leslie
Andy Pepperell
Allyn Romanow

Summary of action items:
- Close Ticket #2, Open a new ticket for any changes to the framework
that may be necessary based on WG consensus [Chairs]
- Ticket #3. Assign Roni as the owner. [Chairs]
- Ticket #5.  Add link to Stephan's proposal:   Update ticket to
reflect that the issue is eliciting WG feedback on the proposal.
[Chairs]

Notes by Marshall Eubanks (starting at 10:14:42 EST):

Administrivia. This call will repeat at the same time every Tuesday.

The issue tracker link is in an email from Paul.

Paul or Mary will edit the issue tracker, with links to relevant email posts.

Ticket 2 :

Roni : The open issue on "my" action

Action item to the chair is to update the ticket to reflect that the
component is the framework document.

Roni : Who is the owner ?

Mary : The WG Chairs make the call.

Mark would be the owner.

Mark : If you do that, aren't you changing everything about the
ticket. Stephan Wenger won't be doing this. Can't you close this one
and open another?

Mary : We can do that, to actually reflect the fact that there will a
change to the framework.

Mark : And we would need a discussion about this on the ML.

Mary : Ticket # 3 : Use case to feed into RTCWEB.

Do we have a volunteer ?

Roni : I can draft a statement, but I am not sure what is the point.

Stephen : It might impact the signaling design?

Roni : That would be dependent on the transport we chose.

Stephen : You have a short use case and that implies requirements on
CLUE and RTCWEB.

Roni : For the moment, all we can say is that it exists. I can't even
describe how RTCWEB  clients work.  I will draft something and send it
to the list.

Stephen : Should it go to the RTCWEB list ?

Mary : I would rather discuss it on the CLUE list first.

Mary : Ticket 4 : We are going to identify all of the metadata used in clue.

Roni : That's the framework. That's the agreement as I understand it.

? : What is metadata ?

Marshall : Data are things like bit rates, while metadata are things
like spatial relationships. things not in most existing systems.

Roni : I was under the impression that this is being worked on in the
framework document.

Mary : This is likely to be open for quite a while.

Ticket 5 :

Mark : There was discussions of this but I don't think that we came to
conclusions.  We need to go back to the group

Mary : Stephan made the proposal and we need to decide what we are
going to do about it.

Roni : This one is different - we need a proposal about what we are
going about it.

First, is this just a Boolean or not ? If not, what is the data
structure we are going to give it.

Allyn : I don't think that there is agreement as to whether or not
this is a Boolean.

Ticket 6: [MB]

Jonathan : I will send an email. This is necessary work for telepresence.

Roni : It is connected to ticket 1, for which Jonathan is the owner.
He said that he would do that.

Mary : I think we are done with the tickets.

Roni : What about the editors who are supposed to rev the framework document.

Allyn : I am hoping by end of next week. We are trying to make it more
accessible.

Mark : Will Mary or Paul send out an agenda and a notice for the next call ?

Mary : Yes.

Thanks everyone !

Call ended @ Tue Jan 17 10:46:58 EST 2012
Notes by John Leslie:

1010 Marshall agreed to take notes
? next call… every Tuesday, same time (potential conflict for Marshall)
Mary: we could re-do the doodle…
Mary: walk-through issue tracker, the WGCs will do any updates
Roni: issue #2 is done… we're not clear what belongs in use-cases vs frameworks
Mary: action. get this into framework
Roni: not my action item anymore
Mary: WGC to update ticket to say belongs to framework document --
action was initially for Roni to post
Mark: are you changing everything? if so, suggest close & open a new ticket
Mary: we can close this and open a new one
Mark: discussion how framework handles use cases
Mary: #3, should have use case to feed into RTCWEB; we need a physical person
Roni: I can draft something about RTCWEB, but what's the difference
which client?
Stephen: if RTCWEB needs to be CLUE-aware, that's a difference: short
use-case implies requirements for both
Roni: I'll draft something and send it to the (CLUE) list
1025
Mary: #4, not necessarily belongs to framework
Roni: the metadata definition will be in the framework
Mary: I'd have to check my notes, I'll take action to do that
Mark: what is the "metadata"
Roni: what we call data model
Mary: all the information that has to be exchanges
Marshall: I thought metadata was things like left vs. right channel;
things most existing applications don't handle (like WebEx)
Mark: people might contribute XML-like description; haven't seen any
Stephen: I recall some reference (vaguely)… metadata-XML -- maybe
cisco working on that
Allyn: things have changed, but basically yes
Mark: premature to get it to W3C
Mary: do we need a separate ticket for detailing?
Roni: we need to discuss on-list
1032
Mary: #5,
Mark: discussed somewhat by Stephan
Mary: will update with link to discussion
Mark: need to discuss on-list to see what we agree on
Mary: Stephan has made the proposal, should I thus close this ticket
Marshall: it should be turned over to someone else, in other WGs they
submerge in details, you may get 15 ticket changes in one day
Mary: update to next-step WG discuss
Roni: I think it's different -- how deeply we go into describing
composed captures
John: aren't different vendors going to do it differently anyway
Stephen: think we need to discuss anyway, but limit the scope
Allyn: some folks strongly want it to be (just) boolean
Roni: point-to-point case; multipoint case… is this something we want to discuss
Mary: update: framework will be updated to reflect consensus
1040
Mary: #6
Roni: question arose whether this in in charter scope
Jonathan: I'm mostly muted… I think this is necessary
(confusion what ticket Jonathan is talking about)
Mary: Paul & I will double-check ticket 6
Mary: 15 minutes left
Roni: what about updates to other parts of the documents
Allyn: hoping for next version by the end of next week… make it more accessible
Mark: keep the intent the same, explain better
Allyn: end of next week should be possible
Mark: that's the earliest
Mary: latest is week of February 3rd
Mark: for next week, will Mary/Paul send notice
Mary: yes, by noon Monday… if no discussion, we might not hold it
1046 adjourn

---

From: Roni even <[email-masked]>
Date: Fri, 20 Jan 2012 23:28:53 +0000

Hi Mary,
The action item "Close Ticket #2, Open a new ticket for any changes to the framework
that may be necessary based on WG consensus [Chairs]"
My understanding is that the new ticket will be about getting consensus about the compose attribute if it is a Boolean or a data structure describing the composed image.

Roni

________________________________________
From: [email-masked] [[email-masked]] on behalf of Mary Barnes [[email-masked]]
Sent: Saturday, January 21, 2012 0:15
To: CLUE
Subject: [clue] Minutes: Design Team Meeting - Jan. 17th, 2012

Hi all,

Regards,
Mary.

Attendees:
Stephen Botzko
Mark Duckworth
Marshall Eubanks
Roni Even
Jonathan Lennox
John Leslie
Andy Pepperell
Allyn Romanow

Summary of action items:

Ticket 2 :

Mark would be the owner.

Do we have a volunteer ?

? : What is metadata ?

Ticket 5 :

Ticket 6: [MB]

Mary : Yes.

Thanks everyone !

_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: Mary Barnes <[email-masked]>
Date: Fri, 20 Jan 2012 18:17:20 -0600

Correct.  We'll be explicit in the text when we open the issue.

Thanks,
Mary.