Subject: [clue] #3: Use case for an RTCWEB client

From: "clue issue tracker" <[email-masked]>
Date: Tue, 10 Jan 2012 18:19:14 -0000

#3: Use case for an RTCWEB client

 CLUE should have a use case for an RTCWEB client.

-- 
-------------------------+-------------------------------------------------
 Reporter:  pkyzivat@…   |      Owner:  draft-ietf-clue-telepresence-use-
     Type:  task         |  cases@…
 Priority:  major        |     Status:  new
Component:               |  Milestone:
  telepresence-use-      |    Version:
  cases                  |   Keywords:
 Severity:  Active WG    |
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://ebook.tools.ietf.org/wg/clue/trac/ticket/3>
clue <http://tools.ietf.org/wg/clue/>

---

From: "clue issue tracker" <[email-masked]>
Date: Mon, 23 Jan 2012 22:30:39 -0000

Changes (by mary.ietf.barnes@…):

 * owner:  draft-ietf-clue-telepresence-use-cases@… => even.roni@…

-- 
------------------------------------+--------------------------
 Reporter:  pkyzivat@…              |       Owner:  even.roni@…
     Type:  task                    |      Status:  new
 Priority:  major                   |   Milestone:
Component:  telepresence-use-cases  |     Version:
 Severity:  Active WG Document      |  Resolution:
 Keywords:                          |
------------------------------------+--------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/3#comment:1>
clue <http://tools.ietf.org/wg/clue/>

---

From: "Roni Even" <[email-masked]>
Date: Tue, 24 Jan 2012 11:31:33 +0200

Hi,
This is my attempt to address this issue. Please review since I am not the expert on RTCweb
Roni Even

The RTCweb overview document http://tools.ietf.org/id/draft-ietf-rtcweb-overview-02.txt says that "the model of real-time support for browser-based applications does not envisage that the browser will contain all the functions that need to be performed in order to have a function such as a telephone  or a videoconferencing unit; the vision is that the browser will have the functions that are needed for a Web application, working in conjunction with its backend servers, to implement these functions.
 
This means that two vital interfaces need specification: The protocols that browsers talk to each other, without any intervening servers, and the APIs that are offered for a Javascript application to take advantage of the browser's functionality."

The RTCweb based application with use the API to communicate through the browser and the application server with the remote application for the call signaling and media channel negotiation while the media channel will flow end to end between both browsers (note – my understanding is that the RTP media is sent by the browser but I am not sure how non video/audio channels content is sent end to end, is it done by the browser or the application?) 

The CLUE support for multistreams adds support for multiple media streams of the same type by providing information about the content or semantics of each stream based on the use cases in http://tools.ietf.org/html/draft-ietf-clue-telepresence-use-cases-02 . A typical example is a TP system with 3 cameras and 3 monitors communicating with a similar system. In this use case the added information to a simple video call may be the spatial information describing the view provided by each camera with relations to the conference room. 

Note: Currently CLUE have not decided how to negotiate the CLUE data over the wire, if done by SDP it will probably be handled like the rest of the RTCweb API. If there will be a different transport, the CLUE working group will add the requirements for the browser API to support this transport.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> clue issue tracker
> Sent: Tuesday, January 24, 2012 12:31 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [clue] #3: Use case for an RTCWEB client
> 
> Ticket URL:
> <http://trac.tools.ietf.org/wg/clue/trac/ticket/3#comment:1>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "clue issue tracker" <[email-masked]>
Date: Tue, 24 Jan 2012 17:53:58 -0000

Comment (by mary.ietf.barnes@…):

 Roni's proposal: http://www.ietf.org/mail-
 archive/web/clue/current/msg00976.html

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/3#comment:2>
clue <http://tools.ietf.org/wg/clue/>