Subject: [clue] CLUE information transport criteria

From: Christer Holmberg <[email-masked]>
Date: Mon, 14 May 2012 20:04:16 +0200

Hi,

In order to decide what is the best and most suitable transport mechanism for CLUE related information, we made a decision to start defining criteria, and then map the information to that criteria, and it will then hopefully make it easier to choose transport mechanism (the two main options are of course in-band and out-of-band transport, but there are different variants of those options).

The purpose of this e-mail is not to collect the information to be sent, but the *criterias* we will match it against.

I would request that we, before we start arguing about whether certain criteria is valid or not, I would like people to just throw out their ideas and suggestions. Of course, if you think that a suggested criteria is unclear, or should be split into two or more criterias, you can suggest a change. But, again, at this point the idea is not to discuss criteria, but to come up with suggestions :)

Some initial suggestions from myself:

- Whether signaling intermediaries (e.g. SBGs) need to have access to the information
- The expected size of the information to be sent
- The expected frequency of the information to be sent
- Whether the information is sent during session establishment, mid-session and/or session termination.
- Whether the transport of the information is delay sensitive
- Whether the information is sent as a notification, or whether some kind of response is needed
- Whether the information needs to be delivered reliably (either using a reliable transport mechanism, and/or some knid of higher-level acknowledgement)
- Whether the information is needed by a non-CLUE entity in order to participate in a CLUE conference

Regards,

Christer

---

From: "Roni Even" <[email-masked]>
Date: Tue, 15 May 2012 16:26:10 +0300

Hi,
Thanks for starting here are some more

Whether the CLUE information and the media description (SDP) need to be in
the same message.
Whether the CLUE information and the media description (SDP) need to use the
same transport path.
Whether the CLUE information is using one transport (E.g encoding group and
MC are using the same transport / message)

Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christer Holmberg
> Sent: Monday, May 14, 2012 9:04 PM
> To: [email-masked]
> Subject: [clue] CLUE information transport criteria
> 
> Hi,
> 
> In order to decide what is the best and most suitable transport
> mechanism for CLUE related information, we made a decision to start
> defining criteria, and then map the information to that criteria, and
> it will then hopefully make it easier to choose transport mechanism
> (the two main options are of course in-band and out-of-band transport,
> but there are different variants of those options).
> 
> The purpose of this e-mail is not to collect the information to be
> sent, but the *criterias* we will match it against.
> 
> I would request that we, before we start arguing about whether certain
> criteria is valid or not, I would like people to just throw out their
> ideas and suggestions. Of course, if you think that a suggested
> criteria is unclear, or should be split into two or more criterias, you
> can suggest a change. But, again, at this point the idea is not to
> discuss criteria, but to come up with suggestions :)
> 
> - Whether the information needs to be delivered reliably (either using
> a reliable transport mechanism, and/or some knid of higher-level
> acknowledgement)
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 15 May 2012 16:48:33 +0200

Hi Roni,

Thanks for your input!

I will *not* discuss your suggestions, simply ask for some clarification on a couple :)

> Whether the CLUE information and the media description (SDP) need to use the same transport path.

If you send CLUE information and SDP in the same SIP message, they will obviously take the same path.

However, if the SDP is sent in the INVITE, based on which entities insert themself in the route set the subsequent SIP messages (including those that contain may CLUE information) will not necessarily take the same path as the INVITE.

So, I think this needs a little clarification.

OR, do you mean that SIP could not be used to send CLUE information (and, obviously not SDP) in the first place if it matches this criteria?

> Whether the CLUE information is using one transport (E.g encoding group and MC are using the same 
> transport / message)

Do you mean to say: whether a piece of CLUE information needs to be sent in the same message, and/or using the same transport, as another piece of CLUE information?

Regards,

Christer

---

From: Michael Hammer <[email-masked]>
Date: Tue, 15 May 2012 16:25:39 +0000

Christer,

Too add on here.  To support CLUE exchanges:

When one says transport, I think of the question of TCP v. UDP v. SCTP?

As far as packaging:  Is it bundled into SDP or some other package/MIME
type?

As for as signaling:  
Is it carried by SIP and thus have the same route set, or does it use some
other signal type with its own route set?
(modulo the capability of SIP to have proxies leave them out of route set)

Separately, assuming SIP, does it use INVITES or some other message type to
carry?

Independent of INVITE or something else, must the exchange be coincident
with:
  - SDP media capability discovery (SDP and CLUE exchanges are independent
and in stages)
  - SIP session establishment (could CLUE be setup up before or after the
SIP session).
    (determine endpoint patterns and select media type later, i.e.
pre-configured with/without SDP)

Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Christer Holmberg
Sent: Tuesday, May 15, 2012 10:49 AM
To: Roni Even; [email-masked]
Subject: Re: [clue] CLUE information transport criteria

Hi Roni,

Thanks for your input!

I will *not* discuss your suggestions, simply ask for some clarification on
a couple :)

> Whether the CLUE information and the media description (SDP) need to use
the same transport path.

If you send CLUE information and SDP in the same SIP message, they will
obviously take the same path.

However, if the SDP is sent in the INVITE, based on which entities insert
themself in the route set the subsequent SIP messages (including those that
contain may CLUE information) will not necessarily take the same path as the
INVITE.

OR, do you mean that SIP could not be used to send CLUE information (and,
obviously not SDP) in the first place if it matches this criteria?

> Whether the CLUE information is using one transport (E.g encoding 
> group and MC are using the same transport / message)

Do you mean to say: whether a piece of CLUE information needs to be sent in
the same message, and/or using the same transport, as another piece of CLUE
information?

Regards,

Christer

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Christer Holmberg
> criteria is unclear, or should be split into two or more criterias, 
> you can suggest a change. But, again, at this point the idea is not to