Subject: [clue] Ticket #8 - add description text to a capture scene

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 18 May 2012 09:56:32 -0700

Regarding Ticket #8 - How consumer differentiates between multiple capture scenes.
We discussed this a bit on the list, and on the April 10 phone meeting.  I think the group agreed we should add a human readable text string attribute to a capture scene.

Here is a proposal for adding text to the framework document section 6.2.1 Capture scene attributes:

Description attribute

The description attribute is a human readable text string which describes the capture scene.  A provider that advertises multiple capture scenes may use different descriptions to differentiate between them.

Do we also want to add a similar description attribute to a media capture?

Mark Duckworth

---

From: "Roni Even" <[email-masked]>
Date: Fri, 18 May 2012 22:58:10 +0300

Hi Mark,
I am not sure about this agreement. My view is that we first need to
understand what is meant by multiple capture scenes. For example is each
identified by a separate co-ordinate space. 
When we have a room video and presentation is it two capture scene, if not
then how do I provide the area of interest for the presentation if the video
room is in real co-ordinate (mm).
If they are not the same we need to have a purpose value for the capture
scene which is machine readable.

I do not object having a human readable description but it is not enough and
it does not provide a way to differentiate between them.
What you can say is that a machine readable description can be used by a
user (!!!!) to select a capture scene if the information is rendered on a
monitor allowing hime to select as part of a menu system.

As for having user readable information for media capture it can be as
useful as the capture scene description. I think that an important
description is the whole system description ( e.g. Mark's home TP system)

Roni Even

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Duckworth, Mark
> Sent: Friday, May 18, 2012 7:57 PM
> To: [email-masked]
> Subject: [clue] Ticket #8 - add description text to a capture scene
> 
> We discussed this a bit on the list, and on the April 10 phone meeting.
> I think the group agreed we should add a human readable text string
> attribute to a capture scene.
> 
> The description attribute is a human readable text string which
> describes the capture scene.  A provider that advertises multiple
> capture scenes may use different descriptions to differentiate between
> them.
> 
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 18 May 2012 13:46:50 -0700

Hi Roni,

Thanks for the comments.
I didn't mean to say this proposed description attribute is enough to resolve Ticket #8, only that I thought the group agreed we should add the attribute to the framework, related to this ticket.

Yes each capture scene is identified by a different coordinate space.  From the framework:
    "A provider can express spatial relationships between media captures
    that are included in the same capture scene. But there is no spatial
    relationship between media captures that are in different capture scenes."

I think the typical case is for room video and presentation video to be in separate capture scenes.  From the framework:
    "A media provider might typically use one capture
    scene for main participant media and another capture scene for a
    computer generated presentation."

I remember people saying it would not be a good idea to prohibit putting a room video capture and a presentation capture into the same capture scene, but I don't know of a case when that would be desired.  You suggest maybe having a purpose attribute for the capture scene.  If we do that, does that mean every media capture in that scene has that same purpose?   That is okay with me, but I thought others might object.

For the whole system description, I thought there is already a standard way to provide "caller ID" information that serves that purpose.  Is that true?

Regards,
Mark

> From: Roni Even [mailto:[email-masked]]
> Sent: Friday, May 18, 2012 3:58 PM
> To: Duckworth, Mark; [email-masked]
> Subject: RE: [clue] Ticket #8 - add description text to a capture scene
> 
> Hi Mark,
> As for having user readable information for media capture it can be as useful
> as the capture scene description. I think that an important description is the
> whole system description ( e.g. Mark's home TP system)
> 
> Roni Even
> 
> 
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Duckworth, Mark

---

From: "Roni Even" <[email-masked]>
Date: Sat, 19 May 2012 00:08:04 +0300

Hi Mark,
I think that this goes back to the question of how we define a capture
scene. Just saying that each has a unique  co-ordinate system is not enough
unless we are saying that all media captures inside a capture scene MUST
provide spatial information using the same co-ordinate systems and units.
This means that the units can be part of the capture scene. It will also
mean that room video and presentation are different capture scenes. I think
that such definition will be in-line with the name "scene"

Roni

> Sent: Friday, May 18, 2012 11:47 PM
> To: [email-masked]
> Subject: Re: [clue] Ticket #8 - add description text to a capture scene
> 
> Hi Roni,
> 
> Thanks for the comments.
> I didn't mean to say this proposed description attribute is enough to
> resolve Ticket #8, only that I thought the group agreed we should add
> the attribute to the framework, related to this ticket.
> 
> I think the typical case is for room video and presentation video to be
> in separate capture scenes.  From the framework:
> I remember people saying it would not be a good idea to prohibit
> putting a room video capture and a presentation capture into the same
> capture scene, but I don't know of a case when that would be desired.
> You suggest maybe having a purpose attribute for the capture scene.  If
> we do that, does that mean every media capture in that scene has that
> same purpose?   That is okay with me, but I thought others might
> object.
> 
> For the whole system description, I thought there is already a standard
> way to provide "caller ID" information that serves that purpose.  Is
> that true?
> 
> Regards,
> Mark
> 
> > understand what is meant by multiple capture scenes. For example is
> > each identified by a separate co-ordinate space.
> > When we have a room video and presentation is it two capture scene,
> if
> > not then how do I provide the area of interest for the presentation
> if
> > the video room is in real co-ordinate (mm).
> > If they are not the same we need to have a purpose value for the
> > capture scene which is machine readable.
> >
> > I do not object having a human readable description but it is not
> > enough and it does not provide a way to differentiate between them.
> > What you can say is that a machine readable description can be used
> by
> > a user (!!!!) to select a capture scene if the information is
> rendered
> > on a monitor allowing hime to select as part of a menu system.
> >
> > > Here is a proposal for adding text to the framework document
> section
> > > 6.2.1 Capture scene attributes:
> > >
> > > Description attribute
> > >
> > > capture scenes may use different descriptions to differentiate
> > > between them.
> > >
> > >

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 18 May 2012 17:33:17 -0400

> provide spatial information using the same co-ordinate systems and units.

AFAIK we did decide this. Isn't that why it was decided that that the 
scale attribute is associated with the capture scene and not with the 
individual capture sets?

> This means that the units can be part of the capture scene.

They are, in 6.2.1 of the framework, not in 6.1.1.

> It will also

In some cases it may make sense for the presentation to be in the same 
scene as the room video, but there are also cases where having them 
separate makes sense. Unless we find some compelling reason to nail it 
down one way or another.

(E.g. If the presentation is being shown on a screen in the room, and 
the presenter is pointing to that screen, then it may make sense to have 
the presenter in one capture, the presentation in another, with both in 
the same scene, so there is enough info to display them both in a way 
that the pointing makes sense.)

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 18 May 2012 17:39:40 -0400

> I didn't mean to say this proposed description attribute is enough to resolve Ticket #8, only that I thought the group agreed we should add the attribute to the framework, related to this ticket.

I agree with this - its part of a resolution to #8.

> I remember people saying it would not be a good idea to prohibit putting a room video capture and a presentation capture into the same capture scene, but I don't know of a case when that would be desired.

I just posted another reply that gave one possible reason.

> You suggest maybe having a purpose attribute for the capture scene.  If we do that, does that mean every media capture in that scene has that same purpose?   That is okay with me, but I thought others might object.

I think this might be helpful, but needs more consideration of exactly 
what it would mean, what the possible values might be, etc.

	Thanks,
	Paul

---

From: "Roni Even" <[email-masked]>
Date: Sat, 19 May 2012 07:18:41 +0300

Paul,
This is OK if we have the scale attribute as mandatory or at least define
the default value and mandate that media captures must supply area of
capture information based on the scale parameter.
I think this will clarify what a scene is since it includes all entities
that have spatial relations.
I do not think that presentation has a spatial relation to a room. If
someone wants to include the presentation it will be good to say how to
render it with regards to the rest of the scene
Roni

> Paul Kyzivat
> Sent: Saturday, May 19, 2012 12:33 AM
> To: [email-masked]
> > scene. Just saying that each has a unique  co-ordinate system is not
> > enough unless we are saying that all media captures inside a capture
> > scene MUST provide spatial information using the same co-ordinate
> systems and units.
> 
> > mean that room video and presentation are different capture scenes. I
> > think that such definition will be in-line with the name "scene"
> 
> the presenter is pointing to that screen, then it may make sense to
> have the presenter in one capture, the presentation in another, with
> both in the same scene, so there is enough info to display them both in
> a way that the pointing makes sense.)
> 
> 	Thanks,
> 	Paul
> 
> > Roni
> >
> >> Yes each capture scene is identified by a different coordinate
> space.
> >>  From the framework:
> >> I think the typical case is for room video and presentation video to
> >> be in separate capture scenes.  From the framework:
> >> You suggest maybe having a purpose attribute for the capture scene.
> >> If we do that, does that mean every media capture in that scene has
> that
> >> For the whole system description, I thought there is already a
> >> standard way to provide "caller ID" information that serves that
> >> purpose.  Is that true?
> >>
> >> Regards,
> >> Mark
> >>

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 19 May 2012 12:58:50 -0400

> capture information based on the scale parameter.

I agree that the framework isn't very clear on this.
There are also some decisions to be made on how optional some of this 
information is:

- I *think* what is currently written implies that all captures in
   a scene that supply area of capture must do so using the common
   scale for the scene. But it seems that it would still be legal
   to provide area of capture for some captures in the scene and omit
   it for other captures in the scene.

- We could instead say that all captures in the scene must have an
   area of capture, except if the scene capture omits the scale attr
   or specifies it as "no scale".

> render it with regards to the rest of the scene

What did you think of my example? (In the message you were replying to.)

I have to admit that I haven't seen a presentation handled in any of the 
(Cisco) TP rooms I have been in. But ISTM there are at least two ways 
that presentations can be handled, somewhat related to room layout.

If you have the typical TP layout I have seen, with people at a desk 
facing cameras and displays depicting remote people at a desk, then 
there is no distinguished presenter/chair. Anybody could be presenting. 
This works ok if everybody has a computer or workstation in front of 
them that can be used to present, or to view a presentation. Then the 
presentation doesn't have any spatial relationship to the room.

If you want to have a more formal presentation, then you might want to 
have a speaker at a podium facing the other participants in his room. 
Then you might want to have a display for the presentation behind or to 
the side of the presenter and facing the other participants in the room. 
The presenter can then point at this display. The participants in the 
room would understand this pointing. This requires a camera facing the 
presenter (opposite direction of other cameras in the room). To make 
this work for remote rooms, you would want the presenter and the 
presentation displayed in a similar relationship to one another. So the 
capture of the presenter and the presentation capture should be in the 
same scene. It could be the same scene as the captures of the other 
participants in the room, or it could be in a different scene. (The 
implications of each are a little fuzzy to me right now.)

	Thanks,
	Paul