Subject: [clue] Consensus call: Add description text to a capture scene [Note subject changed]

From: Mary Barnes <[email-masked]>
Date: Tue, 22 May 2012 12:09:02 -0500

That's a good point.  We did discuss the optionality on the call and
it seemed that the folks that did not want it did not think it should
be optional either.  But, we can go ahead and pose the following
questions then:
1) Do you agree that we should add a mandatory element with human
readable text to the capture scene?
2) Do you agree that we should add an optional element with human
readable text to the capture scene?
3) Do you agree that we should not add any optional or mandatory human
readable text to the capture scene?

Note, I have changed the subject for this thread and will repost the
above to the other thread, so it's easier to track things.

Thanks,
Mary.

On Tue, May 22, 2012 at 12:02 PM, Marshall Eubanks
<[email-masked]> wrote:
> On Tue, May 22, 2012 at 12:35 PM, Mary Barnes
> <[email-masked]> wrote:
>> Hi all,
>>
>> Per the design team meeting this morning, we are doing a consensus call on
>> the question as to whether human readable text string should be added to the
>> capture scene.
>>
>> Note that while this came up during discussion of Ticket #8 in a previous
>> meeting, it does not impact the state of Ticket #8 which remains open:
>> http://trac.tools.ietf.org/wg/clue/trac/ticket/8 (How consumer
>> differentiates between multiple capture scenes)
>>
>> So, if folks could please respond to the following question with a "Yes" or
>> "No":
>>
>> Should a human readable text string be added to the capture scene in the
>> framework document?
>
> Should is ambiguous. Do you mean an optional or a mandatory human
> readable text string ?
>
> If you mean optional, I would say Yes. The ability to add comments is
> always useful, and in some cases
> might be essential.
>
> Regards
> Marshall
>
>>
>> It would also be helpful (but not required for consensus) if folks could
>> provide a brief statement justifying their response for the WG members that
>> did not hear the discussion on today's call.
>>
>> The consensus call closes on Thursday at 5pm Pacific.
>>
>> Thanks,
>> Mary
>> CLUE WG co-chair
>>
>>
>>
>>
>> On Fri, May 18, 2012 at 11:56 AM, Duckworth, Mark
>> <[email-masked]> wrote:
>>>
>>> Regarding Ticket #8 - How consumer differentiates between multiple capture
>>> scenes.
>>> We discussed this a bit on the list, and on the April 10 phone meeting.  I
>>> think the group agreed we should add a human readable text string attribute
>>> to a capture scene.
>>>
>>> Here is a proposal for adding text to the framework document section 6.2.1
>>> Capture scene attributes:
>>>
>>> Description attribute
>>>
>>> The description attribute is a human readable text string which describes
>>> the capture scene.  A provider that advertises multiple capture scenes may
>>> use different descriptions to differentiate between them.
>>>
>>>
>>> Do we also want to add a similar description attribute to a media capture?
>>>
>>> Mark Duckworth
>>> _______________________________________________
>>> clue mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/clue
>>
>>
>>
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>>

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 22 May 2012 13:11:07 -0400

> readable text to the capture scene?

No

> readable text to the capture scene?

Yes.

> readable text to the capture scene?

No.

Regards
Marshall

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 22 May 2012 18:49:52 -0400

Yes.

This might be controversial. The reason I say this is because in the 
absence of anything else it may not be possible to distinguish in any 
way between scenes. If there were some other guaranteed fallback then I 
would go for optional here.

AFAIK we don't currently have anything that would even provide a means 
of correlating elements of two successive advertisements from the same 
source. If there are two scenes in the first advertisement, and three 
scenes in the second advertisement, am I guaranteed to know which ones 
in the 2nd advertisement correspond to those in the first?

> readable text to the capture scene?

Yes, if not mandatory.

No.

IMO this is now structured in a confusing way.
Its posed as three separate questions, but they aren't independent.
If you agree with 3 then you must disagree with 1 & 2.
If feels like these three should be alternatives, at least in terms of 
preferences. But if you agree with 1 then you might also consider 2 to 
be a valid second choice.

	Thanks,
	Paul (as individual)