Subject: [clue] Incoming liaison statement from MPEG

From: Stephan Wenger <[email-masked]>
Date: Fri, 1 Jun 2012 16:29:27 +0000

Hi all,
MPEG is working towards codec independent code points, and has sent to MMUSIC a liaison statement asking for our input.  Especially the audio stuff may also be relevant to CLUE, so I copy CLUE here as well.  No deadline is provided, but I note that MPEG meets two weeks before the Vancouver IETF meeting and the text they sent us is already a CD, so our time to influence their decisions (if we choose to do so) is limited.
MPEG has observed that many code points relevant for audio and video are generic in the sense that they can be applicable to many video or audio codecs.  Recent MPEG (and joint MPEG/ITU) video coding standards have occasionally copy-pasted whole sections of code points concerning things like color primaries.  They want to avoid this in the future.  So they farm out stuff that is historically located in video/audio codec specs, but are likely to be common between different codecs.
My hunch is that the code point in their draft standard could be translated to SDP-ish syntax.  At this point, it is XML-ish.
Stephan

---

From: "Roni Even" <[email-masked]>
Date: Fri, 1 Jun 2012 20:00:14 +0300

Stephan,

I did not see the liaison statement yet in MMUSIC, so I hope it will be
available in time for us to review. 

>From the example of color primaries I am not sure why we need to have this
in SDP. if this is something that is sent as part of the payload do we need
to send it also in SDP?

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stephan Wenger
Sent: Friday, June 01, 2012 7:29 PM
To: [email-masked]; [email-masked]
Subject: [clue] Incoming liaison statement from MPEG

Hi all,

MPEG is working towards codec independent code points, and has sent to
MMUSIC a liaison statement asking for our input.  Especially the audio stuff
may also be relevant to CLUE, so I copy CLUE here as well.  No deadline is
provided, but I note that MPEG meets two weeks before the Vancouver IETF
meeting and the text they sent us is already a CD, so our time to influence
their decisions (if we choose to do so) is limited.

MPEG has observed that many code points relevant for audio and video are
generic in the sense that they can be applicable to many video or audio
codecs.  Recent MPEG (and joint MPEG/ITU) video coding standards have
occasionally copy-pasted whole sections of code points concerning things
like color primaries.  They want to avoid this in the future.  So they farm
out stuff that is historically located in video/audio codec specs, but are
likely to be common between different codecs.

My hunch is that the code point in their draft standard could be translated
to SDP-ish syntax.  At this point, it is XML-ish.

Stephan

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 1 Jun 2012 17:17:50 +0000

Hi Roni,
The statement was sitting in my inbox for a few days, and I have forwarded it to the secretariat for posting only this morning.  Therefore, it is not yet on the tracker, but should be on the tracker sometime soon.
Color primaries, as one example, can actually being sent in SDP today, as part of the VUI in the sequence parameter set of H.264.  And, color primaries are an interoperability point, at least for high quality applications (such as video contribution).  If your receiving box does not understand, or cannot meaningfully process color primaries as sent, then you may get a picture but it will look odd…  There is also other stuff in the MPEG doc that is even more needed for interoperability; for example, association of audio channels inside the codec bitstream with a speaker location.
The key point of the MPEG doc is that they are out farming generic codec things from the audio/video specs into this MPEG-A format, and we (as we are not using MPEG-A) will probably have to find a way to either encapsulate MPEG-A XML for cap exchange, or translate the code points to SDP-ish things.
Stephan

From: Roni Even <[email-masked]<mailto:[email-masked]>>
Date: Friday, 1 June, 2012 10:00
To: Stephan Wenger <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [clue] Incoming liaison statement from MPEG

Stephan,
I did not see the liaison statement yet in MMUSIC, so I hope it will be available in time for us to review.
>From the example of color primaries I am not sure why we need to have this in SDP. if this is something that is sent as part of the payload do we need to send it also in SDP?

Roni

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Friday, June 01, 2012 7:29 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [clue] Incoming liaison statement from MPEG

Hi all,

---

From: Thomas Stockhammer <[email-masked]>
Date: Fri, 1 Jun 2012 21:12:04 +0200

Stephan, all,

a bit more background.

MPEG is NOT defining the mapping of the code points to any specific syntax, such as XML or SDP or a bitstream format. However, it provides common code points (generally unsigned integers) and common definitions of the code points.

One of the relevant code points for IETF SDP are the frame-compatible video formats such as SbS or TaB. Others may relate to audio properties such as the number and configuration of audio channels.

One of the main motivations is to avoid copying such code points from one specification to the next as it happens today for example in video coding standards. 

The IETF is encouraged to support the unification of such code points and by providing input to MPEG and by using references to the MPEG specification in IETF documents.

Thomas

On Jun 1, 2012, at 7:17 PM, Stephan Wenger wrote:

> From: Roni Even <[email-masked]>
> To: Stephan Wenger <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---
Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49 89 978980 02 || cell +491725702667 || http://www.nomor-research.com
Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht: München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr. Thomas Stockhammer, Dr. Ingo Viering.

---

From: Mary Barnes <[email-masked]>
Date: Fri, 1 Jun 2012 15:54:13 -0500

I would appreciate it if folks could reply only to the MMUSIC WG mailing
list.  I suggest folks interested in this, follow the discussion on that
mailing list.  We are getting messages in the moderator queue from folks
that are not subscribed to CLUE.

Thanks,
Mary.

---------- Forwarded message ----------
From: Stephan Wenger <[email-masked]>
Date: Fri, Jun 1, 2012 at 11:29 AM
Subject: [clue] Incoming liaison statement from MPEG
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

 Hi all,
MPEG is working towards codec independent code points, and has sent to
MMUSIC a liaison statement asking for our input.  Especially the audio
stuff may also be relevant to CLUE, so I copy CLUE here as well.  No
deadline is provided, but I note that MPEG meets two weeks before the
Vancouver IETF meeting and the text they sent us is already a CD, so our
time to influence their decisions (if we choose to do so) is limited.
MPEG has observed that many code points relevant for audio and video are
generic in the sense that they can be applicable to many video or audio
codecs.  Recent MPEG (and joint MPEG/ITU) video coding standards have
occasionally copy-pasted whole sections of code points concerning things
like color primaries.  They want to avoid this in the future.  So they farm
out stuff that is historically located in video/audio codec specs, but are
likely to be common between different codecs.
My hunch is that the code point in their draft standard could be translated
to SDP-ish syntax.  At this point, it is XML-ish.
Stephan

_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue