Subject: [clue] Can we close Ticket #9 axis of capture?

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 24 Jul 2012 05:50:01 -0700

We recently added an attribute in the framework to address Ticket #9 Axis of capture description<http://trac.tools.ietf.org/wg/clue/trac/ticket/9>.  There were some suggestions and discussion on the email list about changing some details of the text.  But it seems there was no consensus to change anything.  So can we close this ticket and keep the text as is?  Personally, that is my preference.

Mark

---

From: Christian Groves <[email-masked]>
Date: Wed, 25 Jul 2012 11:28:12 +1000

Hello Mark,

I don't know if there was no consensus there just didn't appear to any 
conclusion. There appeared to be the following points:
- I think both John and I found the name confusing
- There was also discussion regards to the placement of the second 
point, i.e. that it should lie between the point of capture and the area 
of capture.
- John had a point about the action if the attribute is included in error.
- Paul proposed possibly making a single attribute with two values.

So taking into above what I would propose would be:

Point on line of capture: {(X,Y,Z)}

A field with a single Cartesian (X, Y, Z) point value (virtual or 
physical) which describes a position in space of a second point on the 
optical axis of the capturing device; the first point being the Point of 
Capture (see above). This point MUST lie between the Point of Capture 
and the Area area of capture.

The Point on Line of Capture MUST be ignored if the Point of Capture is 
not present for this capture device.  When the Point on Line of Capture 
attribute is specified, it must include X, Y and Z coordinates.  These 
coordinates MUST NOT be identical to the Point of Capture coordinates.  
If the Point on Line of Capture is not specified, no assumptions are 
made about the optical axis of the capturing device.

John or Paul may have something to add/modify.

Regards, Christian

On 24/07/2012 10:50 PM, Duckworth, Mark wrote:
>
> We recently added an attribute in the framework to address Ticket #9 
> Axis of capture description 
> <http://trac.tools.ietf.org/wg/clue/trac/ticket/9>.  There were some 
> suggestions and discussion on the email list about changing some 
> details of the text.  But it seems there was no consensus to change 
> anything.  So can we close this ticket and keep the text as is?  
> Personally, that is my preference.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 26 Jul 2012 05:21:05 -0700

Hi Christian,

Your proposal seems reasonable to me, it seems to be a bit more clear and exact than the current text.
I'd like to see more people express support for this change before I add it to the framework.  Does anybody else agree with this change?

Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christian Groves
> Sent: Tuesday, July 24, 2012 9:28 PM
> To: [email-masked]
> Subject: Re: [clue] Can we close Ticket #9 axis of capture?
> 
> Hello Mark,
> 
> - There was also discussion regards to the placement of the second point, i.e.
> that it should lie between the point of capture and the area of capture.
> physical) which describes a position in space of a second point on the optical axis
> of the capturing device; the first point being the Point of Capture (see above).
> This point MUST lie between the Point of Capture and the Area area of capture.
> 
> The Point on Line of Capture MUST be ignored if the Point of Capture is not
> present for this capture device.  When the Point on Line of Capture attribute is
> specified, it must include X, Y and Z coordinates.  These coordinates MUST NOT
> be identical to the Point of Capture coordinates.
> If the Point on Line of Capture is not specified, no assumptions are made about
> the optical axis of the capturing device.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 26 Jul 2012 09:43:28 -0400

> I'd like to see more people express support for this change before I add it to the framework.  Does anybody else agree with this change?

WFM

	Thanks,
	Paul

---

From: John Leslie <[email-masked]>
Date: Thu, 26 Jul 2012 11:56:40 -0400

Paul Kyzivat <[email-masked]> wrote:
>>I'd like to see more people express support for this change before I add 
>>it to the framework.  Does anybody else agree with this change?
> 
> WFM

   +1

--
John Leslie <[email-masked]>