Subject: [clue] Framework scene description attribute update

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 2 Jul 2012 14:12:24 -0700

Based on the decision at the interim meeting to support multiple description strings, each in a different language, here is my proposed updated text for the framework document.  I also addressed Christians comments  http://www.ietf.org/mail-archive/web/clue/current/msg01522.html

Please review this change.

   Description attribute

   The optional description attribute is a list of human readable text
   strings which describes the capture scene.  If there is more than one
   string in the list, then each string in the list should contain the
   same description, but in a different language.  A provider that
   advertises multiple capture scenes may use different descriptions to
   differentiate between them.  This attribute can contain text in any
   number of languages.

   Description Language attribute

   This attribute is a list of language tags, to identify the language
   of the corresponding description attribute text.  The number of
   language tags in this list must be the same as the number of strings
   in the description list.  The possible values for a language tag are
   the values of the 'Subtag' column for the "Type: language" entries in
   the "Language Subtag Registry" at [IANA-Lan] originally defined in
   [RFC5646].

Regards,
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 02 Jul 2012 17:20:52 -0400

Mark,

So you are proposing one list of descriptions, and a separate but 
parallel list of languages?

That seems clumsy, unnatural, and error prone. Why not a list of pairs 
of (description, language)? And I'd be inclined to specify that a 
particular language value MUST NOT be specified more than once.

	Thanks,
	Paul

On 7/2/12 5:12 PM, Duckworth, Mark wrote:
> Based on the decision at the interim meeting to support multiple
> description strings, each in a different language, here is my proposed
> updated text for the framework document. I also addressed Christians
> comments http://www.ietf.org/mail-archive/web/clue/current/msg01522.html
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Mon, 2 Jul 2012 21:37:55 +0000

In xml it would typically be modelled as
<description lang="en">capture of audience</description>

If multiple descriptions elements are added, add more description elements.

-Espen

----- Reply message -----
Fra: "Paul Kyzivat" <[email-masked]>
Til: "[email-masked]" <[email-masked]>
Emne: [clue] Framework scene description attribute update
Dato: man., juli 2, 2012 23:21

Mark,

        Thanks,
        Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 2 Jul 2012 15:23:27 -0700

Hi Paul,
I thought of your way too, which is also fine with me.  I can reword the text to do it that way if people prefer.
Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Monday, July 02, 2012 5:21 PM
> To: [email-masked]
> Subject: Re: [clue] Framework scene description attribute update
> 
> Mark,
> 
> So you are proposing one list of descriptions, and a separate but parallel list
> of languages?
> 
> That seems clumsy, unnatural, and error prone. Why not a list of pairs of
> (description, language)? And I'd be inclined to specify that a particular
> language value MUST NOT be specified more than once.
> 
> 	Thanks,
> 	Paul
> 
> > comments
> > http://www.ietf.org/mail-archive/web/clue/current/msg01522.html
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 02 Jul 2012 18:57:10 -0400

> I thought of your way too, which is also fine with me.  I can reword the text to do it that way if people prefer.

In practice I think we want to end up with what Espen commented.
But you have to get down into the xml to describe that. The model is too 
high level to talk about it that way. So what I said, or anything else 
that can clearly map to what Espen said works for me.

	Thanks,
	Paul

---

From: Christian Groves <[email-masked]>
Date: Tue, 03 Jul 2012 16:53:04 +1000

Hello Mark,

Having the language tag with the text as Paul suggests seems more 
natural to me.

Regards, Christian

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 3 Jul 2012 06:19:56 -0700

Okay, how about this text for the scene description attribute:

   Description attribute - list of {<description text>, <language tag>}

   strings which describe the capture scene.  If there is more than one

   The language tag identifies the language of the corresponding
   description text.  The possible values for a language tag are the
   values of the 'Subtag' column for the "Type: language" entries in the
   "Language Subtag Registry" at [IANA-Lan] originally defined in
   [RFC5646].  A particular language tag value MUST NOT be used more
   than once in the description attribute list.

Mark

> Sent: Monday, July 02, 2012 6:57 PM
> To: [email-masked]
> But you have to get down into the xml to describe that. The model is too high
> level to talk about it that way. So what I said, or anything else that can clearly
> map to what Espen said works for me.
> 
> 	Thanks,
> 	Paul
> 
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of Paul Kyzivat
> >> That seems clumsy, unnatural, and error prone. Why not a list of
> >> pairs of (description, language)? And I'd be inclined to specify that
> >> a particular language value MUST NOT be specified more than once.
> >>
> >> 	Thanks,
> >> 	Paul
> >>
> >>> description strings, each in a different language, here is my
> >>> proposed updated text for the framework document. I also addressed
> >>> Christians comments

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 4 Jul 2012 08:38:01 +0200

Hi,

Are the following sentences really needed?

     "If there is more than one string in the list, then each string in the list should contain the
      same description, but in a different language."

    "This attribute can contain text in any number of languages."

In addition, I would suggest to modify:

    "A provider that advertises multiple capture scenes may use different descriptions to
   differentiate between them."

...to:

   "A provider that adertises multiple capture scenes can provide descriptions for each
   of them"

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: 3. heinäkuuta 2012 16:20
To: [email-masked]
Subject: Re: [clue] Framework scene description attribute update

Mark

> > I thought of your way too, which is also fine with me.  I can reword 
> > the text
> to do it that way if people prefer.
> > Mark
> 
> But you have to get down into the xml to describe that. The model is 
> too high level to talk about it that way. So what I said, or anything 
> else that can clearly map to what Espen said works for me.
> 
>  Thanks,
>  Paul
> 
> >> From: [email-masked] [mailto:[email-masked]] On 
> >> Behalf Of Paul Kyzivat
> >> pairs of (description, language)? And I'd be inclined to specify 
> >> that a particular language value MUST NOT be specified more than once.
> >>
> >>  Thanks,
> >>  Paul
> >>
> >>> The optional description attribute is a list of human readable 
> >>> text strings which describes the capture scene. If there is more 
> >>> than one string in the list, then each string in the list should 
> >>> contain the same description, but in a different language. A 
> >>> provider that advertises multiple capture scenes may use different 
> >>> descriptions to differentiate between them. This attribute can 
> >>> contain text in any number of languages.
> >>>
> >>> This attribute is a list of language tags, to identify the 
> >>> language of the corresponding description attribute text. The 
> >>> number of language tags in this list must be the same as the 
> >>> number of strings in the description list. The possible values for 
> >>> a language tag are the values of the 'Subtag' column for the 
> >>> "Type: language" entries in the "Language Subtag Registry" at 
> >>> [IANA-Lan] originally defined in [RFC5646].
> >>>
> >>> Regards,
> >>>
> >>> Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 5 Jul 2012 05:53:04 -0700

Markd> comments below.

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, July 04, 2012 2:38 AM
> To: Duckworth, Mark; [email-masked]
> Subject: RE: [clue] Framework scene description attribute update
> 
> 
> Hi,
> 

Markd> I find those sentences useful.  But maybe not strictly necessary.

>    "A provider that adertises multiple capture scenes can provide descriptions

Markd> That is fine with me.

> Duckworth, Mark

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Wed, 11 Jul 2012 16:33:50 +0000

I suggest we add the description attribute to the capture, and not only to the capture-scene. 

Multiple captures in the same capture-scene can have different descriptions. An example could be one capture being the 'main presenter camera' and another capture being the 'whiteboard camera', they are in the same capture-scene since I want them to be described within the same coordinate system to express a left to right relationship.  

Regards 

-Espen 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: 5. juli 2012 14:53
To: [email-masked]
Subject: Re: [clue] Framework scene description attribute update

Markd> comments below.

> Of Duckworth, Mark
> > > I thought of your way too, which is also fine with me.  I can 
> > > reword the text
> > too high level to talk about it that way. So what I said, or 
> > anything else that can clearly map to what Espen said works for me.
> >
> >  Thanks,
> >  Paul
> >
> > >>> proposed updated text for the framework document. I also 
> > >>> addressed Christians comments 
> > >>> provider that advertises multiple capture scenes may use 
> > >>> different descriptions to differentiate between them. This 
> > >>> attribute can contain text in any number of languages.
> > >>>
> > >>> number of strings in the description list. The possible values 
> > >>> for a language tag are the values of the 'Subtag' column for the