Subject: [clue] origin attribute?

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 3 Jul 2012 13:35:06 -0700

Hi Paul,
I thought the group had this conversation before, with the conclusion that we do not want to have the provider try to indicate anything about the origin of the coordinate system.  I don't know how it is possible to specify an origin as an attribute.  Do you have a suggestion?
Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Tuesday, July 03, 2012 4:30 PM
> To: [email-masked]
> Subject: Re: [clue] Is there anything else to change in the framework right
> now?
> 
> On 7/3/12 3:36 PM, Duckworth, Mark wrote:
> > Hi Paul,
> >
> > You are correct about the scale, but the origin is not specified by an
> attribute.  I think that was the point of the clarification, which Roni pointed
> out some time ago but I forgot to add it in the previous version.
> 
> Then lets make sure that the origin is also an attribute of the scene.
> 
> 	Thanks,
> 	Paul
> 
> > Mark
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of Paul Kyzivat
> >> Sent: Tuesday, July 03, 2012 1:55 PM
> >> To: [email-masked]
> >> Subject: Re: [clue] Is there anything else to change in the framework
> >> right now?
> >>
> >> On 7/3/12 10:47 AM, Duckworth, Mark wrote:
> >>
> >>> 4. Clarify that the provider must use the same coordinate system
> >>> with same scale and origin for all coordinates within the same
> >>> capture scene.
> >>
> >> This is inescapable if the coordinate system scale and origin are
> >> only specifiable as attributes of the capture scene, because there is
> >> no way to violate this.
> >>
> >> 	Thanks,
> >> 	Paul
> >> _______________________________________________
> >> clue mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/clue
> > _______________________________________________
> > clue mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/clue
> >
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 03 Jul 2012 16:58:35 -0400

> I thought the group had this conversation before, with the conclusion that we do not want to have the provider try to indicate anything about the origin of the coordinate system.  I don't know how…

Hmm. OK - I guess you are right that we had this.
The scene has a single coordinate system. By a reasonable definition the 
origin is (0,0,0) and so need not be stated. All the coordinates used 
within the scene are relative to that. But the effect is the same.

But it doesn't hurt to emphasize that all coordinates are with respect 
to a single coordinate system associated with the scene. (And unrelated 
to coordinates in any other scene.)

	Thanks,
	Paul

---

From: Mary Barnes <[email-masked]>
Date: Thu, 5 Jul 2012 11:22:50 -0500

Do you have a specific suggestion of where and what specific text needs to
be added?   I would assume you are suggesting there is a need to add some
additional text in section 5 somewhere, although I think it might be
redundant.

Mary.

On Tue, Jul 3, 2012 at 3:58 PM, Paul Kyzivat <[email-masked]> wrote:

>> I thought the group had this conversation before, with the conclusion
>> that we do not want to have the provider try to indicate anything about the
>> origin of the coordinate system.  I don't know how it is possible to
>> specify an origin as an attribute.  Do you have a suggestion?
>>
>
> But it doesn't hurt to emphasize that all coordinates are with respect to
> a single coordinate system associated with the scene. (And unrelated to
> coordinates in any other scene.)
>
>
>         Thanks,
>         Paul
>
>  Mark
>>
>>> right
>>>>> ______________________________**_________________
>>>>> clue mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>>>>>
>>>> ______________________________**_________________
>>>> clue mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>>>>
>>>>
>>> ______________________________**_________________
>>> clue mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>>>
>> ______________________________**_________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>>
>>
> ______________________________**_________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 05 Jul 2012 12:51:10 -0400

On 7/5/12 12:22 PM, Mary Barnes wrote:
> Do you have a specific suggestion of where and what specific text needs
> to be added?   I would assume you are suggesting there is a need to add
> some additional text in section 5 somewhere, although I think it might
> be redundant.

On the contrary - my first thought was that nothing need be said about 
this because it was all implicit and unavoidable. (The best way to avoid 
doing the wrong thing is to make it impossible.)

I was just acknowledging that if people would like to add some words 
about it that is ok too.

	Thanks,
	Paul

> Mary.
>
> On Tue, Jul 3, 2012 at 3:58 PM, Paul Kyzivat <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         I thought the group had this conversation before, with the
>         conclusion that we do not want to have the provider try to
>         indicate anything about the origin of the coordinate system.  I
>         don't know how it is possible to specify an origin as an
>         attribute.  Do you have a suggestion?
>
>
>     The scene has a single coordinate system. By a reasonable definition
>     the origin is (0,0,0) and so need not be stated. All the coordinates
>     used within the scene are relative to that. But the effect is the same.
>
>     But it doesn't hurt to emphasize that all coordinates are with
>     respect to a single coordinate system associated with the scene.
>     (And unrelated to coordinates in any other scene.)
>
>
>              Thanks,
>              Paul
>
>         Mark
>
>             From: [email-masked] <mailto:[email-masked]>
>             [mailto:[email-masked]
>             <mailto:[email-masked]>] On Behalf Of
>             Paul Kyzivat
>             To: [email-masked] <mailto:[email-masked]>
>                     From: [email-masked]
>                     <mailto:[email-masked]>
>                     [mailto:[email-masked]
>                     <mailto:[email-masked]>] On Behalf
>                     Of Paul Kyzivat
>                     To: [email-masked] <mailto:[email-masked]>
>                     _________________________________________________
>                     clue mailing list
>                     [email-masked] <mailto:[email-masked]>
>                     https://www.ietf.org/mailman/__listinfo/clue
>                     <https://www.ietf.org/mailman/listinfo/clue>
>
>                 _________________________________________________
>                 clue mailing list
>                 [email-masked] <mailto:[email-masked]>
>                 https://www.ietf.org/mailman/__listinfo/clue
>                 <https://www.ietf.org/mailman/listinfo/clue>
>
>
>             _________________________________________________
>             clue mailing list
>             [email-masked] <mailto:[email-masked]>
>             https://www.ietf.org/mailman/__listinfo/clue
>             <https://www.ietf.org/mailman/listinfo/clue>
>
>         _________________________________________________
>         clue mailing list
>         [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mailman/__listinfo/clue
>         <https://www.ietf.org/mailman/listinfo/clue>
>
>
>     _________________________________________________
>     clue mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/clue
>     <https://www.ietf.org/mailman/listinfo/clue>
>
>

---

From: Mary Barnes <[email-masked]>
Date: Thu, 5 Jul 2012 12:00:16 -0500

I just re-read section 5 and I think it is sufficient.

On Thu, Jul 5, 2012 at 11:51 AM, Paul Kyzivat <[email-masked]> wrote:

> I was just acknowledging that if people would like to add some words about
> it that is ok too.
>
>         Thanks,
>         Paul
>
>  Mary.
>>
>> <mailto:[email-masked]>**> wrote:
>>
>>             <mailto:[email-masked]>**] On Behalf Of
>>             Paul Kyzivat
>>                     <mailto:[email-masked]>**] On Behalf
>>                     Of Paul Kyzivat
>>                     ______________________________**___________________
>>                     clue mailing list
>>                     https://www.ietf.org/mailman/_**_listinfo/clue<https://www.ietf.org/mailman/__listinfo/clue>
>>                     <https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>> >
>>
>>                 ______________________________**___________________
>>                 clue mailing list
>>                 https://www.ietf.org/mailman/_**_listinfo/clue<https://www.ietf.org/mailman/__listinfo/clue>
>>                 <https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>> >
>>
>>
>>             ______________________________**___________________
>>             clue mailing list
>>             https://www.ietf.org/mailman/_**_listinfo/clue<https://www.ietf.org/mailman/__listinfo/clue>
>>             <https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>> >
>>
>>         ______________________________**___________________
>>         clue mailing list
>>         https://www.ietf.org/mailman/_**_listinfo/clue<https://www.ietf.org/mailman/__listinfo/clue>
>>         <https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>> >
>>
>>
>>     ______________________________**___________________
>>     clue mailing list
>>     https://www.ietf.org/mailman/_**_listinfo/clue<https://www.ietf.org/mailman/__listinfo/clue>
>>     <https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>> >
>>
>>
>>
>