Subject: [clue] Minutes for design team meeting today, 1-oct-2012

From: Paul Kyzivat <[email-masked]>
Date: Mon, 01 Oct 2012 11:26:55 -0400

I posted my notes from the design team meeting today on the wiki.
You can look at them at:

http://trac.tools.ietf.org/wg/clue/trac/attachment/wiki/Design-Team/minutes-121001.txt

The entire meeting was spent discussing whether the spatialDescription 
element in the mediaCaptureType should be optional. This was really a 
discussion about the framework rather than the schema, because the 
schema is simply representing what the framework called for.

I don't think we reached a conclusion.

	Thanks,
	Paul

---

From: Mary Barnes <[email-masked]>
Date: Mon, 1 Oct 2012 11:15:35 -0500

I thought the conclusion was that we needed to have the spatialDescription
in the mediaCaptureType in the schema as mandatory (as opposed to the
current minoccurs="0").  Then, define the spatialDescriptionType to have
two (either/or) subtypes under that: 1) the existing schema 2)a schema
allowing less specific information in cases where the entirety of the
spatial description is not required.  I don't know right off what the XML
schema for that might be, but we can discuss that on the list.

I don't think we decided exactly how/if that might impact the framework,
since the framework doesn't necessarily require that a media capture have
spatial information.

Mary.

On Mon, Oct 1, 2012 at 10:26 AM, Paul Kyzivat <[email-masked]> wrote:

> http://trac.tools.ietf.org/wg/**clue/trac/attachment/wiki/**
> Design-Team/minutes-121001.txt<http://trac.tools.ietf.org/wg/clue/trac/attachment/wiki/Design-Team/minutes-121001.txt>
>
> discussion about the framework rather than the schema, because the schema
> is simply representing what the framework called for.
>
> ______________________________**_________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/clue<https://www.ietf.org/mailman/listinfo/clue>
>

---

From: Simon Pietro Romano <[email-masked]>
Date: Mon, 01 Oct 2012 19:37:00 +0200

Hi all,

first of all let me 'publicly' apologize for missing the call.
Please find in-line our answers to your first comments on the schema file.

> I thought the conclusion was that we needed to have the 
> spatialDescription in the mediaCaptureType in the schema as mandatory 
> (as opposed to the current minoccurs="0").
OK. No problem with this. Fixed in version -01 of the draft.
> Then, define the spatialDescriptionType to have two (either/or) 
> subtypes under that: 1) the existing schema 2)a schema allowing less 
> specific information in cases where the entirety of the spatial 
> description is not required.  I don't know right off what the XML 
This has also been taken into account in version -01 of the draft, which 
also contains an ad hoc "diff" section that should help you track down 
the changes we made. So, please comment on such version from now on.
In the meantime, we'll keep on working on our revision of the current 
documents and come back to you soon
on this list.

Looking forward to your comments and suggestions,

Simon and Roberta

>
> I don't think we decided exactly how/if that might impact the 
> framework, since the framework doesn't necessarily require that a 
> media capture have spatial information.
>
> Mary.
>
> On Mon, Oct 1, 2012 at 10:26 AM, Paul Kyzivat <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     The entire meeting was spent discussing whether the
>     spatialDescription element in the mediaCaptureType should be
>     optional. This was really a discussion about the framework rather
>     than the schema, because the schema is simply representing what
>     the framework called for.
>
>     _______________________________________________
>     clue mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/clue
>
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: "Roni Even" <[email-masked]>
Date: Sat, 6 Oct 2012 19:04:20 +0200

Hi,

My view is that Spatial description is a SHOULD in the framework in order to
provide the order. This was implied in the past by the order in the capture
scene entry but we decided to have explicit information

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mary
Barnes
Sent: 01 October, 2012 6:16 PM
To: Paul Kyzivat
Cc: CLUE
Subject: Re: [clue] Minutes for design team meeting today, 1-oct-2012

I thought the conclusion was that we needed to have the spatialDescription
in the mediaCaptureType in the schema as mandatory (as opposed to the
current minoccurs="0").  Then, define the spatialDescriptionType to have two
(either/or) subtypes under that: 1) the existing schema 2)a schema allowing
less specific information in cases where the entirety of the spatial
description is not required.  I don't know right off what the XML schema for
that might be, but we can discuss that on the list.

Mary. 

http://trac.tools.ietf.org/wg/clue/trac/attachment/wiki/Design-Team/minutes-
121001.txt

The entire meeting was spent discussing whether the spatialDescription
element in the mediaCaptureType should be optional. This was really a
discussion about the framework rather than the schema, because the schema is
simply representing what the framework called for.

        Thanks,
        Paul

---

From: Mary Barnes <[email-masked]>
Date: Sat, 6 Oct 2012 13:03:22 -0500

So, I am really puzzled since your concern on the call seemed to that the
spatialDescription was an optional element - which would be the case to
support a SHOULD.

Mary

On Sat, Oct 6, 2012 at 12:04 PM, Roni Even <[email-masked]> wrote:

> Hi,****
>
> My view is that Spatial description is a SHOULD in the framework in order
> to provide the order. This was implied in the past by the order in the
> capture scene entry but we decided to have explicit information****
>
> Roni****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Mary Barnes
> *Sent:* 01 October, 2012 6:16 PM
> *To:* Paul Kyzivat
> *Cc:* CLUE
> *Subject:* Re: [clue] Minutes for design team meeting today, 1-oct-2012***
> *
>
> ** **
>
> schema for that might be, but we can discuss that on the list.****
>
> ** **
>
> spatial information.****
> ** **
> Mary. ****
> On Mon, Oct 1, 2012 at 10:26 AM, Paul Kyzivat <[email-masked]>
> wrote:****
>
> https://www.ietf.org/mailman/listinfo/clue****
>
> ** **
>

---

From: "Roni Even" <[email-masked]>
Date: Sat, 6 Oct 2012 23:45:22 +0200

Hi,

There is a big difference between a may and a should. Should is mandatory
except for specific cases. My point is that an advertisement should provide
the area of capture with real co-ordinate using the the millimeter or
unknown scale and for the other cases where there is no real value it should
have the no scale value with the capture area.

As for the schema, I think that the Spatial description should be mandatory.
Even in the new schema the issue is not resolved.  My view is that the
capture area should not have a minoccur=0, every media capture should
provide capture area but using the scale to specify the spatial order or
none.

 

Roni

From: Mary Barnes [mailto:[email-masked]] 
Sent: 06 October, 2012 8:03 PM
To: Roni Even
Cc: Paul Kyzivat; CLUE
Subject: Re: [clue] Minutes for design team meeting today, 1-oct-2012

Mary

Hi,

Roni

Mary. 

        Thanks,
        Paul

---

From: Mary Barnes <[email-masked]>
Date: Mon, 8 Oct 2012 09:38:50 -0500

On Sat, Oct 6, 2012 at 4:45 PM, Roni Even <[email-masked]> wrote:

> unknown scale and for the other cases where there is no real value it
> should have the no scale value with the capture area.
>
[MB] We discussed on the call that this would be overloading the "scale"
element. [/MB]

> ****
>
> ** **
>
> As for the schema, I think that the Spatial description should be
> mandatory. Even in the new schema the issue is not resolved.  My view is
> that the capture area should not have a minoccur=0, every media capture
> should provide capture area but using the scale to specify the spatial
> order or none.
>
[MB] So, the spatialDescription is now mandatory in the updated schema,
which was your original concern. The captureArea isn't mandatory because
it's meaningless if you "noscale".

Can you provide an example that shows why it is better to have the
captureArea as mandatory?
 [/MB]

****
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> Roni****
>
> ** **
>
> *From:* Mary Barnes [mailto:[email-masked]]
> *Sent:* 06 October, 2012 8:03 PM
> *To:* Roni Even
> *Cc:* Paul Kyzivat; CLUE
>
> support a SHOULD.  ****
> Mary****
> ****
>  ****
>  ****
>  ****
>  ****
>  ****

---

From: "Roni Even" <[email-masked]>
Date: Mon, 8 Oct 2012 16:58:11 +0200

Hi,

If you have a capture scene entry of more than one media capture, the
capture area must be mandatory

Roni

From: Mary Barnes [mailto:[email-masked]] 
Sent: 08 October, 2012 4:39 PM
To: Roni Even
Cc: Paul Kyzivat; CLUE
Subject: Re: [clue] Minutes for design team meeting today, 1-oct-2012

Hi,

 [/MB]

 

Roni

Mary

Hi,

Roni

Mary. 

        Thanks,
        Paul