Subject: [clue] #18: Action Item (v): Limitations on Simulcast

From: "clue issue tracker" <[email-masked]>
Date: Sat, 13 Oct 2012 18:01:48 -0000

#18: Action Item (v):  Limitations on Simulcast

 From 19-20 Sept. 2012 interim.

 Andy:  Need to define the mechanism to indicate limitations on simulcast
 in the advertisement.

-- 
--------------------------------+-----------------------------------------
 Reporter:  mary.ietf.barnes@…  |      Owner:  draft-ietf-clue-framework@…
     Type:  defect              |     Status:  new
 Priority:  major               |  Milestone:
Component:  framework           |    Version:
 Severity:  -                   |   Keywords:
--------------------------------+-----------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/18>
clue <http://tools.ietf.org/wg/clue/>

---

From: "clue issue tracker" <[email-masked]>
Date: Sat, 13 Oct 2012 18:08:22 -0000

Changes (by mary.ietf.barnes@…):

 * type:  defect => task
 * milestone:   => milestone1

-- 
--------------------------------+------------------------------------------
 Reporter:  mary.ietf.barnes@…  |       Owner:  draft-ietf-clue-framework@…
     Type:  task                |      Status:  new
 Priority:  major               |   Milestone:  milestone1
Component:  framework           |     Version:
 Severity:  -                   |  Resolution:
 Keywords:                      |
--------------------------------+------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/18#comment:1>
clue <http://tools.ietf.org/wg/clue/>

---

From: Andy Pepperell <[email-masked]>
Date: Wed, 17 Oct 2012 17:35:33 +0100

I think I may have rashly volunteered to send something about this one...

The proposal is to define within the framework a new, optional,
"maxEncodings" attribute that can be applied to a media capture (audio or
video) in the provider's capture advertisement to convey to the consumer
the maximum number of capture encodings that can be simultaneously active
for the media capture in question. If absent, this parameter defaults to 1
- thus, systems that traditionally have not supported any form of simulcast
will not be obliged to do so as part of supporting CLUE, and systems which
are capable of simulcast can supply values greater than 1 for some or all
of their media captures. The number of capture encodings possible would
still be limited by the restrictions of the provider's media captures'
encoding groups, as before.

Hopefully this proposal is sufficiently detailed to at least foster some
debate. I have a small concern that having to cope with this extra
parameter for each media capture will make the consumer's task more
complex; however, just as a provider can now choose to omit this value at
leave all media captures with a default maxEncodings of 1, so a consumer
could choose to treat all values above 1 as 1 and so avoid the complexity
of simulcast itself too.

Regards,

Andy

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 17 Oct 2012 10:04:12 -0700

Hi Andy,
This proposal for a new "maxEncodings" attribute sounds good to me.  It fits nicely in the existing framework.  I don't see it adding too much extra complexity.
Regards,
Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Pepperell
Sent: Wednesday, October 17, 2012 12:36 PM
To: clue issue tracker
Cc: [email-masked]; [email-masked]
Subject: Re: [clue] #18: Action Item (v): Limitations on Simulcast

The proposal is to define within the framework a new, optional, "maxEncodings" attribute that can be applied to a media capture (audio or video) in the provider's capture advertisement to convey to the consumer the maximum number of capture encodings that can be simultaneously active for the media capture in question. If absent, this parameter defaults to 1 - thus, systems that traditionally have not supported any form of simulcast will not be obliged to do so as part of supporting CLUE, and systems which are capable of simulcast can supply values greater than 1 for some or all of their media captures. The number of capture encodings possible would still be limited by the restrictions of the provider's media captures' encoding groups, as before.

Hopefully this proposal is sufficiently detailed to at least foster some debate. I have a small concern that having to cope with this extra parameter for each media capture will make the consumer's task more complex; however, just as a provider can now choose to omit this value at leave all media captures with a default maxEncodings of 1, so a consumer could choose to treat all values above 1 as 1 and so avoid the complexity of simulcast itself too.

Regards,

Andy

On Sat, Oct 13, 2012 at 7:08 PM, clue issue tracker <[email-masked]<mailto:[email-masked]>> wrote:
#18: Action Item (v):  Limitations on Simulcast
Changes (by mary.ietf.barnes@...):

 * type:  defect => task

 Reporter:  mary.ietf.barnes@...  |       Owner:  draft-ietf-clue-framework@...

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 18 Oct 2012 14:13:22 -0700

Conclusion 2 from the interim meeting says we need a way for the provider to indicate limitations on simulcast.  So I'd like to add this to the next framework version for the Atlanta meeting, plus any improvements discussed on the list before the deadline.

Here is a more specific proposal to add this text to the framework, in the section for Media Capture Attributes.

==== begin new text =====
Max Capture Encodings: {unsigned integer}

An optional attribute indicating the maximum number of capture encodings that can be simultaneously active for the media capture.  If absent, this parameter defaults  to 1.  The number of simultaneous capture encodings is also limited by the restrictions of the encoding group for the media capture.
==== end new text =====

Should the minimum allowed value be 1?  Or is there some use for a value of 0 (zero)?  0 would mean the media provider can't encode this capture at all, so the consumer cannot ask for it.

Also modify this sentence from the section for "Associating Media Captures with Encoding Groups":

==== begin modified text =====
If there are multiple individual encodings in the group, then the media consumer can configure the media provider to encode a single media capture into multiple different capture encodings at the same time, subject to the Max Capture Encodings constraint, with each capture encoding following the constraints of a different individual encoding.
==== end modified text =====

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Wednesday, October 17, 2012 1:04 PM
To: [email-masked]
Subject: Re: [clue] #18: Action Item (v): Limitations on Simulcast

Hi Andy,

Regards,

Andy

 * type:  defect => task