Subject: [clue] usage of Conference Roles - valid only with switched captures?

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 30 Apr 2013 15:16:20 -0700

Question about section 4.4.2 Conference Roles from draft-groves-clue-capture-attr-01.  The initial set of roles here is Speaker and Controller, both of which are expected to apply to different Endpoints (or Media Capture originating from an Endpoint) at different times.  Given that, is the intent that these roles should be applied only to Media Captures which have the attribute switched=true?  We don't want a Provider to send a new advertisement every time the current speaker in a conference changes, do we?  It would make sense to me for a middlebox to use this type of attribute for a switched capture, or even an Endpoint could use it if it switches between different local captures.

Also, the Role=Controller would apply to an Endpoint, not a Media Capture, is that correct?  Or would it apply to every Media Capture that is sent from the Endpoint that is the current Controller?  If so, then the endpoint would have to change its advertisement when its Controller status changes?  That doesn't make sense to me.

Mark

---

From: Christian Groves <[email-masked]>
Date: Wed, 01 May 2013 11:43:37 +1000

Hello Mark,

I'm in the process of finishing a draft that discusses "role" in some 
more detail. Basically the premise is that the current set of roles 
semantically should be separated. After the discussions on the dispatch 
list it become apparent that people sees "role" for different semantics, 
i.e. there are different categories of roles.
e.g.
* Meeting Roles - These roles relate to typical traditional functions 
when a meeting is held, chairman, secretary, etc.
* Conference roles - These roles are related to the establishment and 
maintenance of the multimedia conference and are related to the scope of 
the conference system only, speaker, controller, participant etc.
* Person name title - These are roles (titles) given to a person 
depicted by the media capture e.g. Doctor, Professor.
* Occupational role - These are roles given to people in an organisation 
e.g. CEO, MD, VP etc. Again these would be the persons depicted in the 
media capture.
* Meeting Specific role - Some groups may want to assign their own role 
that has meaning to the participants in a particular conference.

They all could be considered as having some role in a conference and a 
media capture could be assigned multiple ones.

Regards, Christian

On 1/05/2013 8:16 AM, Duckworth, Mark wrote:
>
> Question about section 4.4.2 Conference Roles from 
> draft-groves-clue-capture-attr-01. The initial set of roles here is 
> Speaker and Controller, both of which are expected to apply to 
> different Endpoints (or Media Capture originating from an Endpoint) at 
> different times. Given that, is the intent that these roles should be 
> applied only to Media Captures which have the attribute switched=true? 
> We don’t want a Provider to send a new advertisement every time the 
> current speaker in a conference changes, do we? It would make sense to 
> me for a middlebox to use this type of attribute for a switched 
> capture, or even an Endpoint could use it if it switches between 
> different local captures.
>
[CNG] My definitions for Speaker / Controller / Participant would be:
• Speaker / Presenter – Can share content/media with others.
• Controller / Host – Indicates the person responsible for controlling 
admission to the conference. Sets up the meeting, adds and shares 
contents, control who presents, talks.
• Participant – Indicates a participant in the conference who does not 
have any special control. Receives media and content from presenter.

If it only applies to switched captures doesn't this imply that only an 
MCU could label a capture with these conference roles?

> Also, the Role=Controller would apply to an Endpoint, not a Media 
> Capture, is that correct? Or would it apply to every Media Capture 
> that is sent from the Endpoint that is the current Controller? If so, 
> then the endpoint would have to change its advertisement when its 
> Controller status changes? That doesn’t make sense to me.
>
[CNG] According to my definition above, I don't think this information 
would change often.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 30 Apr 2013 19:37:32 -0700

Hi Christian,
Thanks for the explanations, but I still don't understand about how it would work with roles that change often.  For example, the current speaker.  In common conference scenarios, the current speaker can change every few seconds.  I think we don't want to be doing new advertisements that change the value of role attributes for role=speaker (or role not equal speaker) every few seconds.

The draft says:
	Speaker - indicates that the capture relates to the current speaker.

My interpretation of "current speaker" is a dynamic choice, usually made by an MCU, based on audio energy or similar metric, of which audio stream (and other associated media streams) represents the current speaker.  And it can easily change every few seconds.  Is this what you mean by "current speaker"?

Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christian Groves
> Sent: Tuesday, April 30, 2013 9:44 PM
> To: [email-masked]
> Subject: Re: [clue] usage of Conference Roles - valid only with switched
> captures?
> 
> Hello Mark,
> 
> I'm in the process of finishing a draft that discusses "role" in some more
> detail. Basically the premise is that the current set of roles semantically
> should be separated. After the discussions on the dispatch list it become
> apparent that people sees "role" for different semantics, i.e. there are
> different categories of roles.
> e.g.
> * Meeting Roles - These roles relate to typical traditional functions when a
> meeting is held, chairman, secretary, etc.
> * Person name title - These are roles (titles) given to a person depicted by the
> media capture e.g. Doctor, Professor.
> * Occupational role - These are roles given to people in an organisation e.g.
> CEO, MD, VP etc. Again these would be the persons depicted in the media
> capture.
> * Meeting Specific role - Some groups may want to assign their own role that
> has meaning to the participants in a particular conference.
> 
> admission to the conference. Sets up the meeting, adds and shares contents,
> control who presents, talks.
> • Participant – Indicates a participant in the conference who does not have
> any special control. Receives media and content from presenter.
> 
> If it only applies to switched captures doesn't this imply that only an MCU
> could label a capture with these conference roles?
> 
> [CNG] According to my definition above, I don't think this information would
> change often.
> >
> > Mark
> >
> >
> >

---

From: Christian Groves <[email-masked]>
Date: Wed, 01 May 2013 12:48:35 +1000

Hello Mark,

I see it as a two step process. The attributes (including role) are used 
to choose the initial set of media captures and the media is then 
established. Any highly dynamic changes in attributes associated with 
established media such as changes to who is currently speaking is best 
handled by media path associated indications (i.e. BFCP).

The text from the draft does need updating that's why I'm working on a 
new draft about roles. I guess the CLUE role "speaker" would denote 
Speaker/Presentor as the person presenting material. The "current 
speaker" determined by audio energy etc would be handled by BFCP (or 
similar).

Regards, Christian