Subject: [clue] Simultaneous Sets in terms of Capture Scenes and Capture Scene Entries

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 30 Apr 2013 06:06:04 -0700

This is a follow up to an action item from IETF-86.  I said I would propose text based on the discussion to allow a Media Provider to represent Simultaneous Transmission Sets in terms of Capture Scenes and Capture Scene Entries.  Currently the framework says a Simultaneous Transmission Set is a set of Media Captures of a particular media type.

=== begin proposed new paragraph to add near end of section 6.3 ===
For shorthand convenience, a Provider may describe a Simultaneous Transmission Set in terms of Capture Scene Entries and Capture Scenes.  If a Capture Scene Entry is included in a Simultaneous Transmission Set, then all Media Captures in the Capture Scene Entry are included in the Simultaneous Transmission Set.  If a Capture Scene is included in a Simultaneous Transmission Set, then all its Capture Scene Entries (of the corresponding media type) are included in the Simultaneous Transmission Set.  The end result reduces to a set of Media Captures in any case.
=== end proposed new paragraph to add near end of section 6.3 ===

I suggest we do not make this change, and instead just describe a Simultaneous Transmission Set as a set of Media Captures.  I think allowing the additional ways to represent the set adds complication without adding value.  A Media Consumer that wants to use simultaneous sets would have more work to do to parse out the contents of the set.

Your thoughts?

Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 30 Apr 2013 12:45:32 -0400

On 4/30/13 9:06 AM, Duckworth, Mark wrote:
> This is a follow up to an action item from IETF-86.  I said I would
> propose text based on the discussion to allow a Media Provider to
> represent Simultaneous Transmission Sets in terms of Capture Scenes and
> Capture Scene Entries.  Currently the framework says a Simultaneous
> Transmission Set is a set of Media Captures of a particular media type.
>
> For shorthand convenience, a Provider may describe a Simultaneous
> Transmission Set in terms of Capture Scene Entries and Capture Scenes.
> If a Capture Scene Entry is included in a Simultaneous Transmission Set,
> then all Media Captures in the Capture Scene Entry are included in the
> Simultaneous Transmission Set.  If a Capture Scene is included in a
> Simultaneous Transmission Set, then all its Capture Scene Entries (of
> the corresponding media type) are included in the Simultaneous
> Transmission Set.  The end result reduces to a set of Media Captures in
> any case.
>

I see one issue with the above. AFAIK the only way one knows the media 
type of a Simultaneous Transmission Set is by observing the type of the 
captures it contains. In the above, if a STS contained *only* Capture 
Scenes, then there would be no way to decide what type it was.

(Of course this wouldn't be a problem is STSs contained all types.)

> I suggest we do not make this change, and instead just describe a
> Simultaneous Transmission Set as a set of Media Captures.  I think
> allowing the additional ways to represent the set adds complication
> without adding value.  A Media Consumer that wants to use simultaneous
> sets would have more work to do to parse out the contents of the set.
>
> Your thoughts?

I haven't got strong feelings pro or con. But not making the change 
means one doesn't have to solve the above problem.

	Thanks,
	Paul

---

From: Christian Groves <[email-masked]>
Date: Wed, 01 May 2013 11:53:07 +1000

On 1/05/2013 2:45 AM, Paul Kyzivat wrote:
> type of a Simultaneous Transmission Set is by observing the type of 
> the captures it contains. In the above, if a STS contained *only* 
> Capture Scenes, then there would be no way to decide what type it was.
>
[CNG] Yes I agree that this is an issue.
>> sets would have more work to do to parse out the contents of the set.
[CNG] In some respects not having the CS, CSE in an STS mirrors a 
configure response in that it only lists captures. However there appears 
to be a problem with a configure when having to return CSE parameters. 
If a consumer can "choose" attribute values what it mean for STSs? Does 
the value setting have an effect on what media capture combination can 
be supported in a capture?

> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 30 Apr 2013 19:46:02 -0700

Comments inline.
Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christian Groves
> Sent: Tuesday, April 30, 2013 9:53 PM
> To: [email-masked]
> Subject: Re: [clue] Simultaneous Sets in terms of Capture Scenes and Capture
> Scene Entries
> 
> 
> >> represent Simultaneous Transmission Sets in terms of Capture Scenes
> >> and Capture Scene Entries.  Currently the framework says a
> >> Simultaneous Transmission Set is a set of Media Captures of a particular
> media type.
> >>
> >> If a Capture Scene Entry is included in a Simultaneous Transmission
> >> Set, then all Media Captures in the Capture Scene Entry are included
> >> in the Simultaneous Transmission Set.  If a Capture Scene is included
> >> in a Simultaneous Transmission Set, then all its Capture Scene
> >> Entries (of the corresponding media type) are included in the
> >> Simultaneous Transmission Set.  The end result reduces to a set of
> >> Media Captures in any case.
> >>

> [CNG] Yes I agree that this is an issue.

[Duckworth, Mark] I think this issue is very easy to solve in the data model by including a media type parameter with the Simultaneous Transmission Set.  But still, I'm in favor of keeping it simple and not adding that new paragraph.

> >> without adding value.  A Media Consumer that wants to use
> >> simultaneous sets would have more work to do to parse out the contents
> of the set.
> >>
> >> Your thoughts?

> [CNG] In some respects not having the CS, CSE in an STS mirrors a configure
> response in that it only lists captures. However there appears to be a
> problem with a configure when having to return CSE parameters.
> If a consumer can "choose" attribute values what it mean for STSs? Does the
> value setting have an effect on what media capture combination can be
> supported in a capture?

[Duckworth, Mark] I don't understand the question.  What do you mean by "what media capture combination can be supported in a capture"?  I'll look for the Capture Scene Entry attribute question and respond separately, I don't see how it is related to this thread.