Subject: [clue] Comments on draft-kyzivat-clue-signaling-03

From: Cullen Jennings <[email-masked]>
Date: Tue, 25 Jun 2013 10:54:32 -0400

I think this draft is going in the wrong direction. It is punting on the what is done in SDP, what is done in clue and basically says all of clue data model goes in the clue protocol and some might also be in SDP. That will result in miserable conflicts resolutions and nasty interoperability failure as well as reducing the odds of folks implementing this widely. 

I'd rather see it split up the data model and put some of it in SDP and some of it CLUE with a very clean distinction between the two.  I'm fine with the concept that SDP forms an envelope of which other things are negotiated to be inside the limits set by the envelope.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 25 Jun 2013 11:23:00 -0400

Cullen.

> I'd rather see it split up the data model and put some of it in SDP and some of it CLUE with a very clean distinction between the two.  I'm fine with the concept that SDP forms an envelope of which…

I just want to check how carefully you looked.

Currently it explicitly says that the description of Encodings is done 
only in SDP, while Encoding Groups (referencing the encodings in SDP) 
and all the rest of the advertisement stuff is done in clue messages.

To fully realize this the data model should probably change. Currently 
the data model has an XML representation of Encoding and Encodings, but 
the signaling draft doesn't reference that part.

I'm not convinced this is the best way, but I wanted to explore it. It 
has some unpleasant consequences, that would be removed if encodings 
were described in the advertisement. But that is one of the discussions 
we need to have.

If you already understood the above, then what would you like to see 
different.

	Thanks,
	Paul