Subject: Re: [clue] hi there, question about the static mapping in draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

From: Roni Even <[email-masked]>
Date: Mon, 8 Jul 2013 09:18:04 +0000

Hi,

The question is what is mapped, is it mapping of a specific SSRC and m-line to the advertisement ,it will need to be mapped to captureID.

Roni

________________________________
From: [email-masked] [[email-masked]]
Sent: Monday, July 08, 2013 12:10 PM
To: [email-masked]; Roni Even
Subject: hi there, question about the static mapping in draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Hi there,

I noticed that in the clue-rtp-mapping draft. you described a static mapping method and also gave the example quoted below:

      m=video 49200 RTP/AVP 99
      a=extmap:1 urn:ietf:params:rtp-hdrex:clue-capture-id / for support
      of dynamic mapping
      a=rtpmap:99 H264/90000
      a=max-send-ssrc:{*:6}
      a=max-recv-ssrc:{*:4}
      a=ssrc:11111 CaptureID:1
      a=ssrc:22222 CaptureID:2
      a=ssrc:33333 CaptureID:3
      a=ssrc:44444 CaptureID:4
      a=ssrc:55555 CaptureID:5
      a=ssrc:66666 CaptureID:6

we can see the static mapping here is between the ssrc and CaptureID but not related whit the capture-encoding-ID.
when the consumer wants to select one CaptureID  but use different indivisual encoding it can't distinguish the streams from this kind of mapping.
for example, the provider supports two different indivisual encodings(ENC0, ENC1) with different bitrate, picture size and processed pixels rate in encoding group0(EG0).
The provide associate the media capture VC0 with EG0. The consumer wants the VC0 using both ENC0 and ENC1 simultaneously.
in this case can we use the static mapping like this? Do we have other meathod to support this case?

m=video 49200 RTP/AVP 99
 a=rtpmap:99 H264/90000
...
      a=ssrc:11111 CaptureID:1 EncodingID:ENC0
      a=ssrc:22222 CaptureID:1 EncodingID:ENC1

Thank you and Best regards,
Liang

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 08 Jul 2013 10:52:27 -0400

Roni,

On 7/8/13 5:18 AM, Roni Even wrote:
> Hi,
>
> The question is what is mapped, is it mapping of a specific SSRC and
> m-line to the advertisement ,it will need to be mapped to captureID.

This draft hasn't been updated recently, and it isn't clear if it will 
be consistent with whatever gets decided about bundling in MMUSIC. But I 
thought it was long settled that we need to map *capture-encodings* to 
RTP - that the same capture map be configured more than once, to 
different encoding, and each then needs to be correlated to the proper 
ssrc in RTP.

I had suggested that we could get by with mapping the RTP to an 
encoding, since at any point in time that encoding will have been 
configured to at most one capture. (So, if you know the encoding you can 
look up what capture has been configured to it, and so discover the 
capture-encoding.)

If we go with Rob's proposal to represent encodings as m-lines in SDP, 
then the RTP mapping can just be to a label/ID associated with that m-line.

ISTM its time to update this draft.

	Thanks,
	Paul

> Roni
>
> ------------------------------------------------------------------------
> *From:* [email-masked] [[email-masked]]
> *Sent:* Monday, July 08, 2013 12:10 PM
> *To:* [email-masked]; Roni Even
> *Subject:* hi there, question about the static mapping in
> draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'
>
>
> Hi there,
>
> I noticed that in the clue-rtp-mapping draft. you described a static
> mapping method and also gave the example quoted below:
>
>        m=video 49200 RTP/AVP 99
> we can see the static mapping here is between the ssrc and CaptureID but
> not related whit the capture-encoding-ID.
> when the consumer wants to select one CaptureID  but use different
> indivisual encoding it can't distinguish the streams from this kind of
> mapping.
> for example, the provider supports two different indivisual
> encodings(ENC0, ENC1) with different bitrate, picture size and processed
> pixels rate in encoding group0(EG0).
> The provide associate the media capture VC0 with EG0. The consumer wants
> the VC0 using both ENC0 and ENC1 simultaneously.
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>