Subject: Re: [clue] comments on description of RTP topologies

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 11 Jul 2013 13:05:00 -0700

Can anybody answer my questions below?  In particular, we aren't aiming for CLUE to support Topo-Video-switch-MCU, correct?

Is anybody else interested in clarifying the rtp-mapping document, to more explicitly use the same terminology for topologies from draft-ietf-avtcore-rtp-topologies-update?  (I assume this avtcore document will become an RFC)

Thanks,
Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Friday, June 14, 2013 10:35 AM
To: [email-masked]
Subject: [clue] comments on description of RTP topologies

This is regarding section 3. RTP topologies for CLUE, in draft-ietf-clue-rtp-mapping-00.

I'm having difficulty relating the topologies described here to the terminology described in draft-ietf-avtcore-rtp-topologies-update-00.  There doesn't seem to be a clean mapping, so I'd like to clarify this and make it cleaner, using the same terminology.

>From the beginning of section 3:
"For telepresence, the relevant topologies include point-to-point, as well as media mixers, media- switching mixers, and source-projection mixers."

So for these four categories, I would like to understand how they map to the topologies described in draft-ietf-avtcore-rtp-topologies-update.  The following list describes how I think the two documents relate.  Do I understand this correctly?  Can we make this more explicit in the CLUE document, to list the CLUE topologies directly using terminology from the rtp-topologies-update document, so we don't have to map it to a new set of CLUE terminology?

1.       point-to-point.  This includes:

a.       Topo-Point-to-Point

b.      Topo-PtP-Translator - not sure if this is meant to be included or not?

c.       Back to back RTP sessions - not sure if this is meant to be included or not?

2.       media mixers.  This includes:

a.       Topo-RTCP-terminating-MCU

b.      Topo-Mixer, Media Mixing variety (3.6.1 of rtp-topologies-update)

3.       media switching mixers.  This includes:

a.       Topo-Mixer, Media Switching variety (3.6.2 of rtp-topologies-update)

4.       source projection mixers. This includes:

a.       Source Projecting Middlebox (3.7 of rtp-topologies-update)

We should also add De-composite Endpoint (3.10 of rtp-topologies-update), as we agreed in the June 2012 interim meeting.

I believe we also agreed CLUE is not attempting to support Topo-Video-switch-MCU, so I suggest we remove reference to this one.  The document refers to this as if CLUE supports it, which I think is not the case.

I have a related question in avtcore, asking if source projection is intended to be a variety of Topo-Mixer.

Mark Duckworth

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jul 2013 13:19:28 +1000

Hello Mark,

I would agree it would be good to be consistent with the topology 
terminology between draft-ietf-clue-rtp-mapping and 
draft-ietf-avtcore-rtp-topologies-update.

With regards for CLUE support of Topo-Video-switch-MCU is this a real 
issue? The Advertisement/Configures could describe such a scenario where 
the consumer sees a switched view. The actual RTP would be described by 
SDP?

Regards, Christian

On 12/07/2013 6:05 AM, Duckworth, Mark wrote:
>
> Can anybody answer my questions below? In particular, we aren’t aiming 
> for CLUE to support Topo-Video-switch-MCU, correct?
>
> Is anybody else interested in clarifying the rtp-mapping document, to 
> more explicitly use the same terminology for topologies from 
> draft-ietf-avtcore-rtp-topologies-update? (I assume this avtcore 
> document will become an RFC)
>
> Thanks,
> Mark
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Duckworth, Mark
> *Sent:* Friday, June 14, 2013 10:35 AM
> *To:* [email-masked]
> *Subject:* [clue] comments on description of RTP topologies
>
> I’m having difficulty relating the topologies described here to the 
> terminology described in draft-ietf-avtcore-rtp-topologies-update-00. 
> There doesn’t seem to be a clean mapping, so I’d like to clarify this 
> and make it cleaner, using the same terminology.
>
> “For telepresence, the relevant topologies include point-to-point, as 
> well as media mixers, media- switching mixers, and source-projection 
> mixers.”
>
> So for these four categories, I would like to understand how they map 
> to the topologies described in 
> draft-ietf-avtcore-rtp-topologies-update. The following list describes 
> how I think the two documents relate. Do I understand this correctly? 
> Can we make this more explicit in the CLUE document, to list the CLUE 
> topologies directly using terminology from the rtp-topologies-update 
> document, so we don’t have to map it to a new set of CLUE terminology?
>
> 1.point-to-point. This includes:
>
> a.Topo-Point-to-Point
>
> b.Topo-PtP-Translator – not sure if this is meant to be included or not?
>
> c.Back to back RTP sessions – not sure if this is meant to be included 
> or not?
>
> 2.media mixers. This includes:
>
> a.Topo-RTCP-terminating-MCU
>
> b.Topo-Mixer, Media Mixing variety (3.6.1 of rtp-topologies-update)
>
> 3.media switching mixers. This includes:
>
> a.Topo-Mixer, Media Switching variety (3.6.2 of rtp-topologies-update)
>
> 4.source projection mixers. This includes:
>
> a.Source Projecting Middlebox (3.7 of rtp-topologies-update)
>
> We should also add De-composite Endpoint (3.10 of 
> rtp-topologies-update), as we agreed in the June 2012 interim meeting.
>
> I believe we also agreed CLUE is not attempting to support 
> Topo-Video-switch-MCU, so I suggest we remove reference to this one. 
> The document refers to this as if CLUE supports it, which I think is 
> not the case.
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 16 Jul 2013 09:41:45 -0700

Hello Christian,

Regarding "Topo-Video-switch-MCU" - 

I was going by the minutes of the June 2012 meeting.
http://www.ietf.org/proceedings/interim/2012/06/07/clue/minutes/minutes-interim-2012-clue-2.txt

One of the conclusions is:
  "4) RTP topologies: support per Magnus' presentation: p2p, distributed endpoint, 3 types of mixers."

Where the 3 types of mixers are: Media Mixer, Media Switching Mixer, and Source Projection Mixer.  These terms came from Magnus's presentation.  http://www.ietf.org/proceedings/interim/2012/06/07/clue/slides/slides-interim-2012-clue-2-6.pdf

I believe these three types of mixers map to:

1. Media mixers
  a. Topo-RTCP-terminating-MCU
  b. Topo-Mixer, Media Mixing variety (3.6.1 of rtp-topologies-update)
2. Media switching mixers - Topo-Mixer, Media Switching variety (3.6.2 of rtp-topologies-update)
3. Source projection mixers - Source Projecting Middlebox (3.7 of rtp-topologies-update)

I believe there was a reason why Topo-Video-switch-MCU was excluded, but I could be wrong.  Maybe it was supposed to be included in the "Media switching mixers" category from the presentation?  If so, I'd like to get clarification about that.

Maybe Jonathan, Roni, Magnus or somebody else can explain?

Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christian Groves
> Sent: Sunday, July 14, 2013 11:19 PM
> To: [email-masked]
> Subject: Re: [clue] comments on description of RTP topologies
> 
> Hello Mark,
> 
> terminology between draft-ietf-clue-rtp-mapping and draft-ietf-avtcore-rtp-
> topologies-update.
> 
> With regards for CLUE support of Topo-Video-switch-MCU is this a real issue?
> The Advertisement/Configures could describe such a scenario where the
> consumer sees a switched view. The actual RTP would be described by SDP?
> 
> Regards, Christian
> 
> 
> > Can anybody answer my questions below? In particular, we aren't aiming
> > I'm having difficulty relating the topologies described here to the
> > There doesn't seem to be a clean mapping, so I'd like to clarify this
> > "For telepresence, the relevant topologies include point-to-point, as
> > mixers."
> > document, so we don't have to map it to a new set of CLUE terminology?
> >
> > b.Topo-PtP-Translator - not sure if this is meant to be included or not?
> >
> > c.Back to back RTP sessions - not sure if this is meant to be included
> > or not?
> >