Subject: [clue] data model priority element

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 12 Jul 2013 13:44:08 -0700

About section 10.7 <priority> in the data model.
I think this needs more information to make it useful.
Should there be an allowed range?  Maybe make it unsigned, with a max value?
Need to specify if a larger number means higher or lower priority.

Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Jul 2013 17:17:13 -0400

> Should there be an allowed range?  Maybe make it unsigned, with a max value?

We need enough so that a data type can be selected to hold it. But the 
max value can be large. Signed or unsigned, 16 or 32 bits, would be fine 
with me. Its hardly worth specifying anything smaller.

> Need to specify if a larger number means higher or lower priority.

I agree we need to specify the sense of the ordering. I vote for bigger 
is higher priority.

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 12 Jul 2013 16:33:51 -0700

I'm not sure what an "xs:integer" really means.  Does it already have an upper bound?  I just don't want to allow arbitrarily large numbers.

Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Friday, July 12, 2013 5:17 PM
> To: [email-masked]
> Subject: Re: [clue] data model priority element
> 
> We need enough so that a data type can be selected to hold it. But the max
> value can be large. Signed or unsigned, 16 or 32 bits, would be fine with me.
> Its hardly worth specifying anything smaller.
> 
> I agree we need to specify the sense of the ordering. I vote for bigger is
> higher priority.
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 12 Jul 2013 16:55:40 -0700

I think I found the answer.
http://www.w3.org/TR/xmlschema-2/

I suggest we use something like "xs:unsignedInt" rather than the unbounded "xs:integer".

There are also a few other elements using the unbounded "xs:integer" type.  I think we should change those also to one of the bounded types.

Mark

> Duckworth, Mark
> Sent: Friday, July 12, 2013 7:34 PM
> To: Paul Kyzivat; [email-masked]
> I'm not sure what an "xs:integer" really means.  Does it already have an
> upper bound?  I just don't want to allow arbitrarily large numbers.
> 
> Mark
> 
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Paul Kyzivat
> > > Should there be an allowed range?  Maybe make it unsigned, with a
> > > max
> > value?
> >
> with me.
> > I agree we need to specify the sense of the ordering. I vote for
> > bigger is higher priority.
> >
> > 	Thanks,
> > 	Paul
> >

---

From: James Polk <[email-masked]>
Date: Fri, 12 Jul 2013 20:04:19 -0500

with the US debt north of $17 trillion, I'm sure no one will consider 
4 billion an "...arbitrarily large number..."...

...really, they won't

;-)

-j

At 06:55 PM 7/12/2013, Duckworth, Mark wrote:
>There are also a few other elements using the unbounded "xs:integer" 
>type.  I think we should change those also to one of the bounded types.
>
>Mark
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jul 2013 12:44:59 +1000

Hello Mark,

I'm OK with the bounded type. With regards to the priority values I tend 
to think of a line analogy when considering priority, i.e. if your 
number 1 in line you get in before number 256. However I'm easy so long 
as its defined. It may also pay to specify a special value say "0" which 
is a default "not subject to priority".

Regards, Christian