Subject: [clue] Consumer should always respond to Advertisement with a Configure

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 11 Jul 2013 13:20:21 -0700

The framework has these contradicting statements in section 9, and a note asking for input:
  Each Advertisement is acknowledged by a corresponding Configure.

  The Consumer need not send a new Configure message to the Provider
  when it receives a new Advertisement from the Provider unless the
  contents of the new Advertisement cause the Consumer's current
  Configure message to become invalid.

  Edt. Note: The editors solicit input from the working group as to
  whether or not a Consumer must respond to every Advertisement with
  a new Configure message.

I propose we say the Consumer must send a Configure message to acknowledge an Advertisement, and remove the paragraph about "The Consumer need not send a new Configure ...".  This seems to be consistent with the Media Provider state machine in draft-presta-clue-protocol-00, which says the Provider expects to receive a Configure after sending an Advertisement.

Any comments or suggestions?

Thanks,
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Jul 2013 18:02:28 -0400

On 7/11/13 4:20 PM, Duckworth, Mark wrote:

> I propose we say the Consumer must send a Configure message to
> acknowledge an Advertisement, and remove the paragraph about “The
> Consumer need not send a new Configure …”.  This seems to be consistent
> with the Media Provider state machine in draft-presta-clue-protocol-00,
> which says the Provider expects to receive a Configure after sending an
> Advertisement.

This decision has tight coupling with working out the protocol aspects 
of the signaling. I'd prefer to have this loose in the fw for now.

I think it is becoming clear that we probably need some sort of ack/nak 
for the Advertisement. But whether the Config *is* an ack is a signaling 
issue. And we probably don't want to send a Config for an Advertisement 
that has problems.

Hopefully will have this figured out before long.

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 12 Jul 2013 16:31:13 -0700

Hi Paul,
That's okay with me.  I will remove the contradiction in the framework, and change the note to reflect this.

Thinking again, maybe it doesn't make sense to require a Configure within some time limit.  The Consumer application might want to ask the human user for input before constructing a Configure message.  That could take "forever".

Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Friday, July 12, 2013 6:02 PM
> To: [email-masked]
> Subject: Re: [clue] Consumer should always respond to Advertisement with a
> Configure
> 
> > acknowledge an Advertisement, and remove the paragraph about "The
> > Consumer need not send a new Configure ...".  This seems to be
> > consistent with the Media Provider state machine in
> > draft-presta-clue-protocol-00, which says the Provider expects to
> > receive a Configure after sending an Advertisement.
> 
> This decision has tight coupling with working out the protocol aspects of the
> signaling. I'd prefer to have this loose in the fw for now.
> 
> I think it is becoming clear that we probably need some sort of ack/nak for
> the Advertisement. But whether the Config *is* an ack is a signaling issue.
> And we probably don't want to send a Config for an Advertisement that has
> problems.
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jul 2013 12:47:52 +1000

Hello Mark,

I'd agree with Paul. I think we do need an ACK of the advertisement, but 
whether that's an Configure message with CaptureEncoding et al. is 
another thing.

Regards, Christian