Subject: [clue] about encoding a single Media Capture into multiple different Capture Encodings simultaniously and mapping

From: [email-masked]
Date: Tue, 9 Jul 2013 11:36:15 +0800

hi there,

framework section 8 descibes one requirement:
 
   If there are multiple Individual Encodings in the group, then the
   Consumer can configure the Provider, via a Configure message, to
   encode a single Media Capture into multiple different Capture
   Encodings at the same time, subject to the Max Capture Encodings
   constraint, with each capture encoding following the constraints of
   a different Individual Encoding.

 in what situation the consumer needs the same media capture in different 
individual encodings simultaniously?

and about the mapping is that better if we use an additional demultiplexID 
which is from captureID-encodingID.
because in the dynamic mapping method like RTP head extention if we use 
multiplexID we only need one RTP extention. 
But if we use two fields(captureID-encodingID) it will take two 
extentions.
the consumer can configure the demultiplexID in the configure message.

Thank you and Best regards,
Liang

[email-masked] 
发件人:  [email-masked]
2013/07/09 02:58
请答复 给
[email-masked]

收件人
[email-masked]
抄送

主题
clue Digest, Vol 32, Issue 4

If you have received this digest without all the individual message
attachments you will need to update your digest options in your list
subscription.  To do so, go to 

https://www.ietf.org/mailman/listinfo/clue

Click the 'Unsubscribe or edit options' button, log in, and set "Get
MIME or Plain Text Digests?" to MIME.  You can set this option
globally for all the list digests you receive at this point.

Send clue mailing list submissions to
                 [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
                 https://www.ietf.org/mailman/listinfo/clue
or, via email, send a message with subject or body 'help' to
                 [email-masked]

You can reach the person managing the list at
                 [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of clue digest..."
Today's Topics:

   1. Re: hi there, question about the static mapping in
 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'
      (Roni Even)
   2. Re: hi there, question about the static mapping in
 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'
      (Paul Kyzivat)
   3. Adopting draft-presta-clue-data-model-schema as a WG document
      (Mary Barnes)
   4.  #32: Definitions of Roles (clue issue tracker)
   5.  #33: Security for Framework document (clue issue tracker)
   6. Re: #20: Action item vii:  Rejecting Configure
      (clue issue tracker)

----- Message from Roni Even <[email-masked]> on Mon, 8 Jul 
2013 09:18:04 +0000 -----
To:
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
cc:
"[email-masked]" <[email-masked]>
Subject:
Re: [clue] hi there, question about the static mapping in 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Hi,
The question is what is mapped, is it mapping of a specific SSRC and 
m-line to the advertisement ,it will need to be mapped to captureID. 
Roni

From: [email-masked] [[email-masked]]
Sent: Monday, July 08, 2013 12:10 PM
To: [email-masked]; Roni Even
Subject: hi there, question about the static mapping in 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Hi there, 

I noticed that in the clue-rtp-mapping draft. you described a static 
mapping method and also gave the example quoted below: 

      m=video 49200 RTP/AVP 99 
      a=extmap:1 urn:ietf:params:rtp-hdrex:clue-capture-id / for support 
      of dynamic mapping 
      a=rtpmap:99 H264/90000 
      a=max-send-ssrc:{*:6} 
      a=max-recv-ssrc:{*:4} 
      a=ssrc:11111 CaptureID:1 
      a=ssrc:22222 CaptureID:2 
      a=ssrc:33333 CaptureID:3 
      a=ssrc:44444 CaptureID:4 
      a=ssrc:55555 CaptureID:5 
      a=ssrc:66666 CaptureID:6 

we can see the static mapping here is between the ssrc and CaptureID but 
not related whit the capture-encoding-ID. 
when the consumer wants to select one CaptureID  but use different 
indivisual encoding it can't distinguish the streams from this kind of 
mapping. 
for example, the provider supports two different indivisual 
encodings(ENC0, ENC1) with different bitrate, picture size and processed 
pixels rate in encoding group0(EG0). 
The provide associate the media capture VC0 with EG0. The consumer wants 
the VC0 using both ENC0 and ENC1 simultaneously. 
in this case can we use the static mapping like this? Do we have other 
meathod to support this case? 

m=video 49200 RTP/AVP 99 
 a=rtpmap:99 H264/90000 
... 
      a=ssrc:11111 CaptureID:1 EncodingID:ENC0 
      a=ssrc:22222 CaptureID:1 EncodingID:ENC1 

Thank you and Best regards,
Liang

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail 
(and any attachment transmitted herewith) is privileged and confidential 
and is intended for the exclusive use of the addressee(s).  If you are not 
an intended recipient, any disclosure, reproduction, distribution or other 
dissemination or use of the information contained is strictly prohibited. 
If you have received this mail in error, please delete it and notify us 
immediately.

----- Message from Paul Kyzivat <[email-masked]> on Mon, 08 Jul 
2013 10:52:27 -0400 -----
To:
[email-masked]
Subject:
Re: [clue] hi there, question about the static mapping in 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Roni,

On 7/8/13 5:18 AM, Roni Even wrote:
> Hi,
>
> The question is what is mapped, is it mapping of a specific SSRC and
> m-line to the advertisement ,it will need to be mapped to captureID.

This draft hasn't been updated recently, and it isn't clear if it will 
be consistent with whatever gets decided about bundling in MMUSIC. But I 
thought it was long settled that we need to map *capture-encodings* to 
RTP - that the same capture map be configured more than once, to 
different encoding, and each then needs to be correlated to the proper 
ssrc in RTP.

I had suggested that we could get by with mapping the RTP to an 
encoding, since at any point in time that encoding will have been 
configured to at most one capture. (So, if you know the encoding you can 
look up what capture has been configured to it, and so discover the 
capture-encoding.)

If we go with Rob's proposal to represent encodings as m-lines in SDP, 
then the RTP mapping can just be to a label/ID associated with that 
m-line.

ISTM its time to update this draft.

                 Thanks,
                 Paul

> Roni
>
> ------------------------------------------------------------------------
> *From:* [email-masked] [[email-masked]]
> *Sent:* Monday, July 08, 2013 12:10 PM
> *To:* [email-masked]; Roni Even
> *Subject:* hi there, question about the static mapping in
> 
draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'
>
>
> Hi there,
>
> I noticed that in the clue-rtp-mapping draft. you described a static
> mapping method and also gave the example quoted below:
>
>        m=video 49200 RTP/AVP 99
>        a=extmap:1 urn:ietf:params:rtp-hdrex:clue-capture-id / for 
support
>        of dynamic mapping
>        a=rtpmap:99 H264/90000
>        a=max-send-ssrc:{*:6}
>        a=max-recv-ssrc:{*:4}
>        a=ssrc:11111 CaptureID:1
>        a=ssrc:22222 CaptureID:2
>        a=ssrc:33333 CaptureID:3
>        a=ssrc:44444 CaptureID:4
>        a=ssrc:55555 CaptureID:5
>        a=ssrc:66666 CaptureID:6
>
> we can see the static mapping here is between the ssrc and CaptureID but
> not related whit the capture-encoding-ID.
> when the consumer wants to select one CaptureID  but use different
> indivisual encoding it can't distinguish the streams from this kind of
> mapping.
> for example, the provider supports two different indivisual
> encodings(ENC0, ENC1) with different bitrate, picture size and processed
> pixels rate in encoding group0(EG0).
> The provide associate the media capture VC0 with EG0. The consumer wants
> the VC0 using both ENC0 and ENC1 simultaneously.
> in this case can we use the static mapping like this? Do we have other
> meathod to support this case?
>
> m=video 49200 RTP/AVP 99
>   a=rtpmap:99 H264/90000
> ...
>        a=ssrc:11111 CaptureID:1 EncodingID:ENC0
>        a=ssrc:22222 CaptureID:1 EncodingID:ENC1
>
>
> Thank you and Best regards,
> Liang
>
>
>
> --------------------------------------------------------
> ZTE Information Security Notice: The information contained in this mail 
(and any attachment transmitted herewith) is privileged and confidential 
and is intended for the exclusive use of the addressee(s).  If you are not 
an intended recipient, any disclosure, reproduction, distribution or other 
dissemination or use of the information contained is strictly prohibited. 
If you have received this mail in error, please delete it and notify us 
immediately.
>
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

----- Message from Mary Barnes <[email-masked]> on Mon, 8 Jul 
2013 13:36:26 -0500 -----
To:
CLUE <[email-masked]>
Subject:
[clue] Adopting draft-presta-clue-data-model-schema as a WG document

Hi all,

As was discussed at the virtual interim on June 25th, there is a
proposal for the WG to approve the adoption of
draft-presta-clue-data-model-schema as a CLUE WG document:
http://datatracker.ietf.org/doc/draft-presta-clue-data-model-schema/

Please respond "Yes" or "No" as to whether you believe the document
should be adopted no later than Sunday July 14th, 2013, so the authors
have time to submit as a WG document before the deadline, noting that
there is a single deadline for IETF-87 (July 15th, 24:00 UTC).

If you have specific comments on the document, PLEASE post those in a
separate thread with an appropriate title to facilitate tracking.

Thanks,
Mary.

Note: we are working on the minutes from the virtual interim and will
post within the next 24 hours.

----- Message from "clue issue tracker" <[email-masked]> on 
Mon, 08 Jul 2013 18:51:20 -0000 -----
To:
[email-masked], [email-masked]
cc:
[email-masked]
Subject:
[clue] #32: Definitions of Roles

#32: Definitions of Roles

 There are a number of places where the term "Role" is defined.   We need
 to figure out which are most appropriate for CLUE.   Note, this has also
 been discussed on DISPATCH WG mailing list: http://www.ietf.org/mail-
 archive/web/clue/current/msg02527.html

 Note: Component will be changed to data-model once that's a WG document.

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:
  [email-masked]         |  [email-masked]
     Type:  task                     |     Status:  new
 Priority:  critical                 |  Milestone:  milestone1
Component:  charter                  |    Version:  1.0
 Severity:  Candidate WG Document    |   Keywords:
-------------------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/clue/trac/ticket/32>
clue <http://tools.ietf.org/wg/clue/>

----- Message from "clue issue tracker" <[email-masked]> on 
Mon, 08 Jul 2013 18:54:58 -0000 -----
To:
[email-masked], [email-masked]
cc:
[email-masked]
Subject:
[clue] #33: Security for Framework document

#33: Security for Framework document

 The security considerations for the framework need to be documented.
 Note, that the content should be based on the security threats identified
 in the requirements document (TBD) as well as any additional security
 threats related to the overall framework itself.

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:
  [email-masked]         |  [email-masked]
     Type:  task                     |     Status:  new
 Priority:  critical                 |  Milestone:
Component:  framework                |    Version:
 Severity:  Active WG Document       |   Keywords:
-------------------------------------+-------------------------------------

Ticket URL: <http://tools.ietf.org/wg/clue/trac/ticket/33>
clue <http://tools.ietf.org/wg/clue/>

----- Message from "clue issue tracker" <[email-masked]> on 
Mon, 08 Jul 2013 18:58:26 -0000 -----
To:
[email-masked], [email-masked]
cc:
[email-masked]
Subject:
Re: [clue] #20: Action item vii: Rejecting Configure

#20: Action item vii:  Rejecting Configure

Changes (by [email-masked]):

 * owner:  Andy Pepperell => [email-masked]
 * priority:  minor => major

Old description:

> Action item vii from 19-20 Sept. 2012 interim.
>
> Andy: Add text to Framework for rejecting Configure

New description:

 Action item vii from 19-20 Sept. 2012 interim.

 Andy: Add text to Framework for rejecting Configure

 As discussed at virtual interim on May 21st, this needs to be mentioned 
in
 the framework, so that the subsequent actions can be described. (E.g.,
 does the prior configure remain in effect?)

 The details of how this is communicated belong in the solution.

--

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |       Owner:
  [email-masked]         |  [email-masked]
     Type:  task                     |      Status:  new
 Priority:  major                    |   Milestone:
Component:  framework                |     Version:
 Severity:  -                        |  Resolution:
 Keywords:                           |
-------------------------------------+-------------------------------------

Ticket URL: <http://tools.ietf.org/wg/clue/trac/ticket/20#comment:1>
clue <http://tools.ietf.org/wg/clue/>

_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 10 Jul 2013 10:51:52 -0700

Hello Liang,

A Media Consumer in an MCU might want to receive different encodings of the same capture simultaneously.  For example it could receive a high resolution and a low resolution video encoding, and distribute one or the other to a different endpoint Media Consumer depending on the capabilities of that other consumer and bandwidth availability.

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 08, 2013 11:36 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [clue] about encoding a single Media Capture into multiple different Capture Encodings simultaniously and mapping

hi there,

 in what situation the consumer needs the same media capture in different individual encodings simultaniously?

and about the mapping is that better if we use an additional demultiplexID which is from captureID-encodingID.
because in the dynamic mapping method like RTP head extention if we use multiplexID we only need one RTP extention.
But if we use two fields(captureID-encodingID) it will take two extentions.
the consumer can configure the demultiplexID in the configure message.

[email-masked]<mailto:[email-masked]>
发件人:  [email-masked]<mailto:[email-masked]>

2013/07/09 02:58
请答复 给
[email-masked]<mailto:[email-masked]>

收件人

[email-masked]<mailto:[email-masked]>

抄送

主题

Send clue mailing list submissions to
                [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
                https://www.ietf.org/mailman/listinfo/clue
or, via email, send a message with subject or body 'help' to
                [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
                [email-masked]<mailto:[email-masked]>

----- Message from Roni Even <[email-masked]<mailto:[email-masked]>> on Mon, 8 Jul 2013 09:18:04 +0000 -----
To:

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

cc:

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Subject:

Re: [clue] hi there, question about the static mapping in draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Hi,
The question is what is mapped, is it mapping of a specific SSRC and m-line to the advertisement ,it will need to be mapped to captureID.
Roni
________________________________

From: [email-masked]<mailto:[email-masked]> [[email-masked]]
Sent: Monday, July 08, 2013 12:10 PM
To: [email-masked]<mailto:[email-masked]>; Roni Even
Subject: hi there, question about the static mapping in draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Hi there,

I noticed that in the clue-rtp-mapping draft. you described a static mapping method and also gave the example quoted below:

     m=video 49200 RTP/AVP 99

we can see the static mapping here is between the ssrc and CaptureID but not related whit the capture-encoding-ID.
when the consumer wants to select one CaptureID  but use different indivisual encoding it can't distinguish the streams from this kind of mapping.
for example, the provider supports two different indivisual encodings(ENC0, ENC1) with different bitrate, picture size and processed pixels rate in encoding group0(EG0).
The provide associate the media capture VC0 with EG0. The consumer wants the VC0 using both ENC0 and ENC1 simultaneously.
in this case can we use the static mapping like this? Do we have other meathod to support this case?

m=video 49200 RTP/AVP 99
a=rtpmap:99 H264/90000
...

----- Message from Paul Kyzivat <[email-masked]<mailto:[email-masked]>> on Mon, 08 Jul 2013 10:52:27 -0400 -----
To:

[email-masked]<mailto:[email-masked]>

Subject:

Re: [clue] hi there, question about the static mapping in draft'http://tools.ietf.org/html/draft-ietf-clue-rtp-mapping-00#section-4.5'

Roni,

If we go with Rob's proposal to represent encodings as m-lines in SDP,
then the RTP mapping can just be to a label/ID associated with that m-line.

                Thanks,
                Paul

> *From:* [email-masked]<mailto:[email-masked]> [[email-masked]]
> *To:* [email-masked]<mailto:[email-masked]>; Roni Even
> [email-masked]<mailto:[email-masked]>

----- Message from Mary Barnes <[email-masked]<mailto:[email-masked]>> on Mon, 8 Jul 2013 13:36:26 -0500 -----
To:

CLUE <[email-masked]<mailto:[email-masked]>>

Subject:

Hi all,

Thanks,
Mary.

----- Message from "clue issue tracker" <[email-masked]<mailto:[email-masked]>> on Mon, 08 Jul 2013 18:51:20 -0000 -----
To:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

cc:

[email-masked]<mailto:[email-masked]>

Subject:

 [email-masked]<mailto:[email-masked]>         |  [email-masked]<mailto:[email-masked]>

----- Message from "clue issue tracker" <[email-masked]<mailto:[email-masked]>> on Mon, 08 Jul 2013 18:54:58 -0000 -----
To:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

cc:

[email-masked]<mailto:[email-masked]>

Subject:

 [email-masked]<mailto:[email-masked]>         |  [email-masked]<mailto:[email-masked]>

----- Message from "clue issue tracker" <[email-masked]<mailto:[email-masked]>> on Mon, 08 Jul 2013 18:58:26 -0000 -----
To:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

cc:

[email-masked]<mailto:[email-masked]>

Subject:

Changes (by [email-masked]<mailto:[email-masked]>):

* owner:  Andy Pepperell => [email-masked]<mailto:[email-masked]>
* priority:  minor => major

New description:

As discussed at virtual interim on May 21st, this needs to be mentioned in
the framework, so that the subsequent actions can be described. (E.g.,
does the prior configure remain in effect?)

--

 [email-masked]<mailto:[email-masked]>         |  [email-masked]<mailto:[email-masked]>

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue