Subject: Re: [clue] Global CSE List in framework

From: Roberta Presta <[email-masked]>
Date: Tue, 01 Apr 2014 12:53:53 +0200

Hello Mark,

just a minor question about your definition:

Il 27/03/2014 18:10, Duckworth, Mark ha scritto:
> An Advertisement can include an optional global Capture Scene Entry 
> list, for each media type.  Each item in this list is a set of one or 
> more Capture Scene Entries.

Do you mean that we have a global capture scene entry list for video and 
a global capture scene entry list for audio?
Otherwise, what about "...global Capture Scene Entry list. Each item in 
the list is a set of one or more Capture Scene Entries of the same media 
type."? That last approach is more similar to the one adopted for the 
content of capture scenes.

Regards,

Roberta

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 2 Apr 2014 14:55:50 -0700

Hi Christian, thanks for the suggestions.  Comments below.
Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Monday, March 31, 2014 9:22 PM
> To: [email-masked]
> Subject: Re: [clue] Global CSE List in framework
> 
> Hello Mark,
> 
> Thanks for providing a start for the text. Some comments below.
> 
> Regards, Christian
> 
> On 28/03/2014 4:10 AM, Duckworth, Mark wrote:
> >
> > Here is a new section I'm adding to the framework. Please send any
> > comments or suggestions.
> >
> > ==============================
> >
> > 7.3.3. Global Capture Scene Entry List
> >
> > more Capture Scene Entries. Each set of CSEs in the list is a
> > suggestion from the Provider to the Consumer for which CSEs represent
> > the entire advertisement, across multiple scenes.
> >
> [CNG] I'm not sure about the wording about "..for which CSEs represent the
> entire advertisement..." For me the "advertisement" is the CLUE message.
> So it seems strange to talk about CSEs representing the advertisement.
> Perhaps something like "... for which CSEs provide a complete representation
> of the simultaneous captures provided by the provider, across multiple
> scenes."?
[Duckworth, Mark] I agree

> > The Provider can include multiple sets, to accommodate different
> > Consumers with varying capability to receive multiple encodings. This
> > is very similar to how each CSE represents a particular scene.
> >
> [CNG] Is the GCSE about providing sets for multiple "encodings"? You can
> provide multiple encodings without GSEs. Isn't it about providing different
> sets of captures so that a receiver can best determine what the set of
> captures it wants based on the service it wants to provide.
> I.e. a consumer may only support three media streams (3 encodings) but
> these may be used in a number of ways.
[Duckworth, Mark] Are you suggesting just replace "encodings" with "captures"?  That's fine with me, maybe "captures" better expresses the meaning.

> > As an example, suppose an advertisement has three scenes, and each
> > scene has three CSEs, ranging from one to three video captures in each
> > CSE. The provider is advertising a total of nine video captures across
> > three scenes. The provider can use the Global CSE list to suggest
> > alternatives for consumers that can't receive all nine video captures.
> >
> [CNG] Maybe we should add at the end "... all nine video captures <as
> separate media streams>."?
[Duckworth, Mark] I agree

> > For accommodating a consumer that wants to receive three video
> > captures, a provider might suggest a single CSE with three captures
> > and nothing from the other two scenes. Or a provider might suggest
> > three different CSEs, one from each scene, with a single video capture
> > in each. The choice of how to make these suggestions in the Global CSE
> > list for what represents the entire advertisement is up to the provider.
> >
> > Some additional rules:
> >
> [CNG] Perhaps also? "A CSE may be used in multiple sets." Otherwise its not
> clear whether this is allowed or not. Also I take it there's at most one CSE
> instance per SET.
[Duckworth, Mark] I agree

> > * The ordering of items (sets of CSEs) in the global CSE list is not
> > important.
> >
> > * The ordering of CSEs within each set is not important.
> >
> > * The Provider must be capable of encoding and sending all Captures
> > within the CSEs of a given set simultaneously.
> >
> [CNG] Do we need to add some text to the simultaneous set section of the
> framework indicating this? We should probably say something about the
> interaction. i.e. If a GCSE set is included should the provider actually need to
> provide a STS? Sendings CSEs in a STS indicates the those CSE/captures may
> be used simultaneously. There appears to be alot of overlap with the GCSE in
> this respect.
[Duckworth, Mark] I think I see what you mean.  We have this paragraph already:
"If an Advertisement does not include Simultaneous Transmission Sets, then the Provider MUST be able to provide all Capture Scenes simultaneously.  If multiple capture Scene Entries are in a Capture Scene then the Consumer chooses at most one Capture Scene Entry per Capture Scene for each media type."

[Duckworth, Mark] I suggest we also add "If there is no STS and there is a global CSE list, then the Consumer chooses at most one set of CSEs of each media type, from the global CSE list."

> 
> 
> > ==============================
> >
> > I also added a statement in 7.3 saying a CSE has an advertisement
> > unique identity.
> >
> > I also plan to add an example in 12.3 for Global CSE List, taken from
> > my IETF89 slides.
> >
> [CNG] OK
> >
> > Mark
> >
> >
> >
> > _______________________________________________
> > clue mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/clue
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 2 Apr 2014 14:58:18 -0700

Hi Roberta,

Thanks for the suggestion, it makes sense.  I think the meaning is the same either way, but keeping it consistent with the different media types in a CSE list sounds good.  I'll change the text in the framework.

Mark

From: Roberta Presta [mailto:[email-masked]]
Sent: Tuesday, April 01, 2014 6:54 AM
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] Global CSE List in framework

Hello Mark,

Il 27/03/2014 18:10, Duckworth, Mark ha scritto:
 An Advertisement can include an optional global Capture Scene Entry list, for each media type.  Each item in this list is a set of one or more Capture Scene Entries.

Do you mean that we have a global capture scene entry list for video and a global capture scene entry list for audio?
Otherwise, what about "...global Capture Scene Entry list. Each item in the list is a set of one or more Capture Scene Entries of the same media type."? That last approach is more similar to the one adopted for the content of capture scenes.

Regards,

Roberta

---

From: Christian Groves <[email-masked]>
Date: Fri, 04 Apr 2014 10:26:44 +1100

Hello Mark,

Please see below.

Regards, Christian

..snip..
> [Duckworth, Mark] Are you suggesting just replace "encodings" with "captures"?  That's fine with me, maybe "captures" better expresses the meaning.
[CNG] Whilst "captures" is probably better than "encodings" I'm not sure 
that "receive multiple captures" is the point. How about "The Provider 
can include multiple sets, to allow a consumer to choose sets of 
captures appropriate to its capabilities or application..."

> ...snip ...
[CNG] I'm OK with the above sentence. I think in addition we need to add 
some text regarding what happens when an STS AND GCSE is included. 
There's some overlap between them.

E.g.
Scene1(CSE1(VC1,VC2,VC3)
Scene2(CSE2(VC4,VC5,VC6)
Scene3(CSE3(VC7,VC8,VC9)
GCSE([CSE1,CSE3],[CSE2,CSE3])
STS([CSE1,CSE3],[CSE2,CSE3])

If the provider includes a GCSE as above and wants to include a STS does 
it have to contain the exact same CSE sets?, i.e. because according to 
the above bullet the CSE must capable of being send simultaneously. Or 
is the interaction that a GCSE set indicates that at least one capture 
from each CSE can be sent simultaneously, or?

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 4 Apr 2014 07:25:18 -0700

Hi Christian,
Thanks again.  See below.
Mark

> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, April 03, 2014 7:27 PM
> >>> Consumers with varying capability to receive multiple encodings.
> >>> This is very similar to how each CSE represents a particular scene.
> >>>
> >> [CNG] Is the GCSE about providing sets for multiple "encodings"? You
> >> can provide multiple encodings without GSEs. Isn't it about providing
> >> different sets of captures so that a receiver can best determine what
> >> the set of captures it wants based on the service it wants to provide.
> >> I.e. a consumer may only support three media streams (3 encodings)
> >> but these may be used in a number of ways.
> > [Duckworth, Mark] Are you suggesting just replace "encodings" with
> "captures"?  That's fine with me, maybe "captures" better expresses the
> meaning.
> [CNG] Whilst "captures" is probably better than "encodings" I'm not sure that
> "receive multiple captures" is the point. How about "The Provider can include
> multiple sets, to allow a consumer to choose sets of captures appropriate to
> its capabilities or application..."
[Duckworth, Mark] Thanks, I think that says it better.

> >> [CNG] Do we need to add some text to the simultaneous set section of
> >> the framework indicating this? We should probably say something about
> >> the interaction. i.e. If a GCSE set is included should the provider
> >> actually need to provide a STS? Sendings CSEs in a STS indicates the
> >> those CSE/captures may be used simultaneously. There appears to be
> >> alot of overlap with the GCSE in this respect.
> > "If an Advertisement does not include Simultaneous Transmission Sets,
> then the Provider MUST be able to provide all Capture Scenes
> simultaneously.  If multiple capture Scene Entries are in a Capture Scene then
> the Consumer chooses at most one Capture Scene Entry per Capture Scene
> for each media type."
> >
> > [Duckworth, Mark] I suggest we also add "If there is no STS and there is a
> global CSE list, then the Consumer chooses at most one set of CSEs of each
> media type, from the global CSE list."
> If the provider includes a GCSE as above and wants to include a STS does it
> have to contain the exact same CSE sets?, i.e. because according to the
> above bullet the CSE must capable of being send simultaneously. Or is the
> interaction that a GCSE set indicates that at least one capture from each CSE
> can be sent simultaneously, or?
> 
[Duckworth, Mark] No, it shouldn't have to contain the exact same CSE sets in both.  The point is that if there are STS in the advertisement, then the STSs must make it possible for: "The Provider must be capable of encoding and sending all Captures within the CSEs of a given set (in the global CSE list) simultaneously."  In other words, the STSs must not express any restriction that prohibits the consumer from requesting all the captures in all the CSEs in a set of CSEs in the global CSE list.  But it can express restrictions that do not violate the global CSE list.
So from your example, the GCSE list is saying the consumer can choose from these sets of captures:
    VC1,VC2,VC3,VC7,VC8,VC9
    or VC4,VC5,VC6,VC7,VC8,VC9
So there could still be STSs that don't contradict that, but do express limitations.  For example:
    STS([VC1,VC2,VC3,VC4,VC7,VC8,VC9],[VC1,VC4,VC5,VC6,VC7,VC8,VC9])
So with these STSs, the consumer could choose everything from the first set in the GCSE list (VC1,VC2,VC3,VC7,VC8,VC9) plus also VC4 if it wants.  But not VC5 or VC6.

[Duckworth, Mark] Do you have a suggestion for how to make this more clear in the framework?

---

From: Christian Groves <[email-masked]>
Date: Mon, 07 Apr 2014 12:17:28 +1000

Hello Mark,

Please see below.

Regards, Christian

..snip..

> [Duckworth, Mark] Do you have a suggestion for how to make this more clear in the framework?
[CNG] I think we agree. Using "exact" probably wasn't the best word, I 
probably should have used "at least".
I think what we're trying to say is: "If an STS is used then it a 
minimum MUST contain captures that reflect the simultaneity expressed by 
any global CSE sets."

Not for the framework, but we should probably make a mental note that we 
include an error code/case for if the STSs, CSEs and GCSEs don't match. 
I would assume that the consumer would return an error, unless people 
can think of another handling?

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 7 Apr 2014 06:32:36 -0700

Thanks Christian.  I will collect all the clarifications from this conversation and add them to the next version of the framework.
Mark

> Sent: Sunday, April 06, 2014 10:17 PM
> >>>>> * The ordering of items (sets of CSEs) in the global CSE list is
> >>>>> not important.
> >>>>>
> >>>>> * The Provider must be capable of encoding and sending all
> >>>>> Captures within the CSEs of a given set simultaneously.
> >>>>>
> >>>> [CNG] Do we need to add some text to the simultaneous set section
> >>>> of the framework indicating this? We should probably say something
> >>>> about the interaction. i.e. If a GCSE set is included should the
> >>>> provider actually need to provide a STS? Sendings CSEs in a STS
> >>>> indicates the those CSE/captures may be used simultaneously. There
> >>>> appears to be alot of overlap with the GCSE in this respect.
> >>> [Duckworth, Mark] I think I see what you mean.  We have this
> >>> paragraph
> >> already:
> >> simultaneously.  If multiple capture Scene Entries are in a Capture
> >> Scene then the Consumer chooses at most one Capture Scene Entry per
> >> Capture Scene for each media type."
> >> global CSE list, then the Consumer chooses at most one set of CSEs of
> >> each media type, from the global CSE list."
> >> [CNG] I'm OK with the above sentence. I think in addition we need to
> >> add some text regarding what happens when an STS AND GCSE is
> included.
> >> If the provider includes a GCSE as above and wants to include a STS
> >> does it have to contain the exact same CSE sets?, i.e. because
> >> according to the above bullet the CSE must capable of being send
> >> simultaneously. Or is the interaction that a GCSE set indicates that
> >> at least one capture from each CSE can be sent simultaneously, or?
> >>
> > [Duckworth, Mark] No, it shouldn't have to contain the exact same CSE sets
> in both.  The point is that if there are STS in the advertisement, then the STSs
> must make it possible for: "The Provider must be capable of encoding and
> sending all Captures within the CSEs of a given set (in the global CSE list)
> simultaneously."  In other words, the STSs must not express any restriction
> that prohibits the consumer from requesting all the captures in all the CSEs in
> a set of CSEs in the global CSE list.  But it can express restrictions that do not
> violate the global CSE list.
> > So with these STSs, the consumer could choose everything from the first
> set in the GCSE list (VC1,VC2,VC3,VC7,VC8,VC9) plus also VC4 if it wants.  But
> not VC5 or VC6.
> 
> >
> I think what we're trying to say is: "If an STS is used then it a minimum MUST
> contain captures that reflect the simultaneity expressed by any global CSE
> sets."
> 
> I would assume that the consumer would return an error, unless people can
> think of another handling?
> >
> >