Subject: Re: [clue] I-D Action: draft-ietf-clue-protocol-02.txt

From: Christian Groves <[email-masked]>
Date: Fri, 07 Nov 2014 19:32:40 +1100

Hello Roberta,

Sorry for the delay in getting back to you.

In my understanding a retry mechanism would only apply if there was a 
transport related problem. I thought the READV was used in the case 
where the MC looses the CLUEinfo description to some internal event 
where the transport isn't affected. In this case the only option for the 
MC would be to restart the CLUE session. Having the READV would prevent 
the need for that.

Regards, Christian

On 30/10/2014 9:02 PM, Roberta Presta wrote:
> Hello Christian,
>
> we found that with the current state machines, in any case the MC 
> might need a new copy of the ADV, that copy will arrive even without 
> asking for it.
> We considered:
> - when there might be channel errors for example, or end of session 
> events;
> - when the received ADV is nacked by the MC;
> - when the MP does not receive any ACK (/NACK/CONF) from the MC
> In each of the aforementioned situations, what happens is that the MP 
> (sooner or later, thanks to a retry mechanism) will send a new ADV to 
> the MC and that the MC will be reached by that ADV.
> What is your feeling about these considerations?
>
> Regards,
>
> Roberta
>
>
> Il 30/10/2014 03:52, Christian Groves ha scritto:
>> Hello Paul and Roberta,
>>
>>>
>>>>> Why has READV been *removed*? Has something changed so that we don't
>>>>> need it? (I was advocating for renaming it, not removing it.)
>>>>>
>>>> While reviewing the state machines, we found the message redundant in
>>>> each case where in the past we  thought it could be useful. It is 
>>>> one of
>>>> the topic of the today's discussion.
>>>
>>> Based on discussion in design team call today I agree that we don't 
>>> seem to need it.
>>
>> [CNG] I thought READV the message was needed in case the MP lost the 
>> CLUE data model information and needed an update. It allowed the MP 
>> to request an update from the MC. If we remove that what is now the 
>> assumption?  Can you elaborate, as I wasn't in the meeting?
>>
>> Regards, Christian
>>
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>>
>
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 7 Nov 2014 07:22:33 -0800

I agree with Christian.  I think there should be a way for the consumer to ask the provider what is the current advertisement. If the provider receives a READV request from the consumer, it would treat it the same as a "changed telepresence settings" event in the provider state machine, which goes back to the ADV state and sends an advertisement.  Could it be that simple?

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Friday, November 07, 2014 3:33 AM
> To: Roberta Presta; [email-masked]
> Subject: Re: [clue] I-D Action: draft-ietf-clue-protocol-02.txt
> 
> Hello Roberta,
>