Subject: [clue] provider ESTABLISHED and WAIT FOR CONF states

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 11 Nov 2014 13:06:39 -0800

Hello all,
I have a question about the protocol state machine for a media provider.  Suppose it is in the ESTABLISHED state, and then the consumer sends a new configure message.  The provider receives it, and goes to CONF RESPONSE state.  Suppose for some reason the provider has to send an error response back to the consumer.  According to the state diagram, the provider then goes to the WAIT FOR CONF state.  This means it is now waiting for a new configure message, and if it doesn't receive one it will eventually time out and go to TERMINATED state.

Is this really what we want?  It seems to me that in this case the provider is still sending media that was previously configured with the most recent valid configure message that got it into the ESTABLISHED state in the first place.  Since there was no change to the advertisement, and there was a valid configure message previously, and valid media is flowing, would it be better to maintain this state rather than go back to WAIT FOR CONF?  In other words, if the provider is already in ESTABLISHED state, and it receives a configure and sends an error response, should it go back to ESTABLISHED state rather than go to WAIT FOR CONF?

Mark

---

From: Christian Groves <[email-masked]>
Date: Wed, 12 Nov 2014 15:40:24 +1100

Hello Mark,

Yes, good catch. After the ESTABLISHED state the MP should transition to 
another state where additional CONFs could be received. These additional 
CONFs shouldn't be subject to the same time outs associated with the 
initial ADV/CONF.

Regards, Christian

On 12/11/2014 8:06 AM, Duckworth, Mark wrote:
>
> Hello all,
>
> I have a question about the protocol state machine for a media 
> provider. Suppose it is in the ESTABLISHED state, and then the 
> consumer sends a new configure message. The provider receives it, and 
> goes to CONF RESPONSE state. Suppose for some reason the provider has 
> to send an error response back to the consumer. According to the state 
> diagram, the provider then goes to the WAIT FOR CONF state. This means 
> it is now waiting for a new configure message, and if it doesn’t 
> receive one it will eventually time out and go to TERMINATED state.
>
> Is this really what we want? It seems to me that in this case the 
> provider is still sending media that was previously configured with 
> the most recent valid configure message that got it into the 
> ESTABLISHED state in the first place. Since there was no change to the 
> advertisement, and there was a valid configure message previously, and 
> valid media is flowing, would it be better to maintain this state 
> rather than go back to WAIT FOR CONF? In other words, if the provider 
> is already in ESTABLISHED state, and it receives a configure and sends 
> an error response, should it go back to ESTABLISHED state rather than 
> go to WAIT FOR CONF?
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue