Subject: [clue] Draft new version: clue-datachannel-03

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Nov 2014 01:10:11 +0000

Hi,

I've submitted a new version (-03) of the CLUE data channel draft.

The main technical change from the previous version is that I have now added details for usage of Keith Richard's draft.

NOTE that my assumption is that we will still use DCEP to actually open the CLUE data channel, once it has been negotiated the draft.

I have also removed the SDP O/A procedures, and added a reference to the CLUE protocol draft for that.

And, yes, I know I have to fix table 3 :)

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Nov 2014 01:14:17 +0000

Hi,

In addition, I also removed the text about SCTP interleaving, based on the assumption that there is nothing CLUE specific regarding that.

Regards,

Christer

-----Original Message-----
From: clue [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 21 November 2014 03:10
To: [email-masked]
Subject: [clue] Draft new version: clue-datachannel-03

Hi,

Regards,

Christer
_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Fri, 21 Nov 2014 14:23:18 +1100

Hello Christer,

A few of comments:
1. You need to update table 3.... :-)
2. Cl.3.2.1 - It's draft-ietf-clue-signaling-04 
<https://datatracker.ietf.org/doc/draft-ietf-clue-signaling/> that 
describes the SDP O/A procedures not the protocol draft.
3. Cl.3.2.4 - WebRTC datachannel indicates that the subprotocol is 
optional. However for CLUE I assume that this is a mandatory parameter 
with value equal to "CLUE"? The table suggests it's optional.
4. Cl.3.2.4 - What's your intention on the use of label? The table 
suggests that its optional but if included must have the value "CLUE 
Data Channel"
5. Cl.3.3.1 - Can we now delete the note in this section also?
6. Cl.3.3.2 - Should we move the note to the IANA considerations section 
given that it applies to both clauses 3.2.4 and 3.3.2?
7. Cl.3.2.4 - I'm not sure the SCTP stream ID always need to be provided 
especially if there's only one CLUE subprotocol instance for each 
DTLS/SCTP association. This is more of a comment on the ejzak draft.

Regards, Christian

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Nov 2014 06:18:32 +0000

Hi,

>1. You need to update table 3.... :-)

I'm glad you told me :)

>2. Cl.3.2.1 - It's draft-ietf-clue-signaling-04 <https://datatracker.ietf.org/doc/draft-ietf-clue-signaling/> that describes the SDP O/A procedures not the protocol draft.

I'll fix that.

In addition, in the same section, I'll change "media channels" to "media streams".

>3. Cl.3.2.4 - WebRTC datachannel indicates that the subprotocol is optional. However for CLUE I assume that this is a 
>mandatory parameter with value equal to "CLUE"? The table suggests it's optional.

I am using the names used in the syntax of draft-ejzak, and according to section 5.1.1.3 the parameter is mandatory. 

I guess the "opt" wording in the syntax is confusing, and it would probably be better to NOT use the syntax names to begin with.

>4. Cl.3.2.4 - What's your intention on the use of label? The table suggests that its optional but if included must have the value "CLUE Data Channel"

According to section 5.1.1.2 it is mandatory. My understanding is that it is needed for the W3C API, to identity the data channel, and data channel events.

>5. Cl.3.3.1 - Can we now delete the note in this section also?

In my opinion, yes.

>6. Cl.3.3.2 - Should we move the note to the IANA considerations section given that it applies to both clauses 3.2.4 and 3.3.2?

Yes.

>7. Cl.3.2.4 - I'm not sure the SCTP stream ID always need to be provided especially if there's only one CLUE 
>subprotocol instance for each DTLS/SCTP association. This is more of a comment on the ejzak draft.

True.

Regards,

Christer

---

From: Christian Groves <[email-masked]>
Date: Mon, 24 Nov 2014 10:58:16 +1100

Hello Christer,

> According to section 5.1.1.2 it is mandatory. My understanding is that it is needed for the W3C API, to identity the data channel, and data channel events.
Should CLUE be mandating a value for label? Its use is for distinguish 
between RTCdatachannel objects. It seems any value would suffice so long 
it is different and an endpoint may use different schemes to allocate it.

Regards, Christian

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 23 Nov 2014 19:16:24 -0500

On 11/23/14 6:58 PM, Christian Groves wrote:
>> According to section 5.1.1.2 it is mandatory. My understanding is that
>> it is needed for the W3C API, to identity the data channel, and data
>> channel events.
>>

If we are doing the negotiation of the channel in SDP, choosing the 
stream id, then I see no reason to mandate any particular label.

	Thanks,
	Paul