Subject: Re: [clue] Can CLUE signaling help reduce size of SDP?

From: Stephan Wenger <[email-masked]>
Date: Thu, 8 Jan 2015 17:47:19 +0000

Hi all, and happy new year!
My apologies for this late reply, and thanks to Mark for reminding me.
Yes, the language regarding the potential of reducing the SDP size through information gathered in the CLUE message exchange was originally from me.  It stems from a time when we were considering (had agreed on?  At least in principle?  I don't recall...) a multiphase negotiation: 1) set-up CLUE channel, 2) negotiate (over the CLUE channel, in a fashion similar to O/A) parameters that included parameters traditionally negotiated over SDP using the much richer XML-based CLUE syntax, and 3) only then pro-forma "negotiate" via SDP O/A with the side effect of setting up the media.  A few years ago, that line of thought was popular.  Personally, I still find it sensible, given the limitations and awkwardness of SDP.  But it's not how CLUE works today, as far as I understand it.
Paul's comments below sound sensible to me, but I'm not sufficiently well versed in CLUE and O/A to assert correctness or lack thereof.
Regards,
Stephan

From: <Duckworth>, "Duckworth, Mark" <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 22, 2014 at 14:10
To: Paul Kyzivat <[email-masked]<mailto:[email-masked]>>, CLUE <[email-masked]<mailto:[email-masked]>>, Stephan Wenger <[email-masked]<mailto:[email-masked]>>
Subject: Can CLUE signaling help reduce size of SDP?

>From Paul's comments on the framework:

> Section 5:

> I'm struggling to understand the following paragraph:

>     Second, it MAY, but is not necessarily REQUIRED to, use the

>     information provided to tailor the SDP it is going to send during

>     the following SIP offer/answer exchange, and its reaction to SDP it

>     receives in that step.  It is often a sensible implementation

>     choice to do so, as the representation of the media information

>     conveyed over the CLUE channel can dramatically cut down on the

>     size of SDP messages used in the O/A exchange that follows.

>     Spatial relationships associated with the Media can be included in

>     the Advertisement, and it is often sensible for the Media Consumer

>     to take those spatial relationships into account when tailoring the

>     SDP.

> This seems to me to say that the consumer can use the advertisement to

> reduce the size of the sdp, which isn't really true. I think the problem

> is that this text doesn't distinguish between what is done by providers

> and consumers.

> For a provider, it may well be infeasible to send SDP covering every

> encoding in the advertisement. It could potentially reduce the size of

> SDP to a more manageable size by only offering those encodings that are

> configured. BUT, as we have things structured now a consumer needs to

> see the encodings in the SDP to decide what to configure. So this

> potential can't be realized.

> For a consumer the potential is not to reduce the size of SDP, but

> rather to reduce the number of encodings it must set up resources to

> receive. It probably doesn't want to receive encodings that it doesn't

> intend to use. I think this is the key point to make in this paragraph.

> (These comments also apply the the following paragraph.)

I thought I understood this idea of reducing the SDP size, but now I
can't recall the details of that.  I think Stephan wrote these paragraphs.

Stephan, can you explain what the intent was here?

Thanks,
Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 8 Jan 2015 14:27:49 -0800

Okay, so based on Paul and Stephan's comments, here is a proposal to change those two paragraphs to remove the part about reducing SDP size, and add Paul's point about not wasting consumer resources.

Proposed changed text:

Also, the Consumer MAY use the information provided to tailor the SDP it is going to send during any following SIP offer/answer exchange, and its reaction to SDP it receives in that step.  It is often a sensible implementation choice to do so.  Spatial relationships associated with the Media can be included in the Advertisement, and it is often sensible for the Media Consumer to take those spatial relationships into account when tailoring the SDP.  The Consumer can also limit the number of encodings it must set up resources to receive, and not waste resources on unwanted encodings, because it has the Provider's Advertisement information ahead of time to determine what it really wants to receive.

This initial CLUE exchange is followed by an SDP offer/answer exchange that not only establishes those aspects of the media that have not been "negotiated" over CLUE, but has also the side effect of setting up the media transmission itself, involving potentially security exchanges, ICE, and whatnot.  This step is plain vanilla SIP.

Mark

From: Stephan Wenger [mailto:[email-masked]]
Sent: Thursday, January 08, 2015 12:47 PM
To: Duckworth, Mark; [email-masked]; [email-masked]
Subject: Re: Can CLUE signaling help reduce size of SDP?

Thanks,
Mark

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 9 Jan 2015 01:27:58 +0000

Good with me.
Stephan

From: <Duckworth>, "Duckworth, Mark" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 8, 2015 at 14:27
To: Stephan Wenger <[email-masked]<mailto:[email-masked]>>, Paul Kyzivat <[email-masked]<mailto:[email-masked]>>, CLUE <[email-masked]<mailto:[email-masked]>>
Subject: RE: Can CLUE signaling help reduce size of SDP?

Okay, so based on Paul and Stephan’s comments, here is a proposal to change those two paragraphs to remove the part about reducing SDP size, and add Paul’s point about not wasting consumer resources.

Proposed changed text:

Also, the Consumer MAY use the information provided to tailor the SDP it is going to send during any following SIP offer/answer exchange, and its reaction to SDP it receives in that step.  It is often a sensible implementation choice to do so.  Spatial relationships associated with the Media can be included in the Advertisement, and it is often sensible for the Media Consumer to take those spatial relationships into account when tailoring the SDP.  The Consumer can also limit the number of encodings it must set up resources to receive, and not waste resources on unwanted encodings, because it has the Provider’s Advertisement information ahead of time to determine what it really wants to receive.

Mark

From: Stephan Wenger [mailto:[email-masked]]
Sent: Thursday, January 08, 2015 12:47 PM
To: Duckworth, Mark; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Can CLUE signaling help reduce size of SDP?

Hi all, and happy new year!
My apologies for this late reply, and thanks to Mark for reminding me.
Yes, the language regarding the potential of reducing the SDP size through information gathered in the CLUE message exchange was originally from me.  It stems from a time when we were considering (had agreed on?  At least in principle?  I don’t recall…) a multiphase negotiation: 1) set-up CLUE channel, 2) negotiate (over the CLUE channel, in a fashion similar to O/A) parameters that included parameters traditionally negotiated over SDP using the much richer XML-based CLUE syntax, and 3) only then pro-forma “negotiate” via SDP O/A with the side effect of setting up the media.  A few years ago, that line of thought was popular.  Personally, I still find it sensible, given the limitations and awkwardness of SDP.  But it’s not how CLUE works today, as far as I understand it.
Paul’s comments below sound sensible to me, but I’m not sufficiently well versed in CLUE and O/A to assert correctness or lack thereof.
Regards,
Stephan

>From Paul’s comments on the framework:

I thought I understood this idea of reducing the SDP size, but now I
can’t recall the details of that.  I think Stephan wrote these paragraphs.

Thanks,
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 09 Jan 2015 12:25:53 -0500

+1

On 1/8/15 8:27 PM, Stephan Wenger wrote:
> To: Stephan Wenger <[email-masked] <mailto:[email-masked]>>, Paul
> Kyzivat <[email-masked] <mailto:[email-masked]>>, CLUE
> <[email-masked] <mailto:[email-masked]>>
> Okay, so based on Paul and Stephan’s comments, here is a proposal to
> change those two paragraphs to remove the part about reducing SDP size,
> and add Paul’s point about not wasting consumer resources.
>
> Proposed changed text:
>
> Also, the Consumer MAY use the information provided to tailor the SDP it
> is going to send during any following SIP offer/answer exchange, and its
> reaction to SDP it receives in that step.  It is often a sensible
> implementation choice to do so.  Spatial relationships associated with
> the Media can be included in the Advertisement, and it is often sensible
> for the Media Consumer to take those spatial relationships into account
> when tailoring the SDP.  The Consumer can also limit the number of
> encodings it must set up resources to receive, and not waste resources
> on unwanted encodings, because it has the Provider’s Advertisement
> information ahead of time to determine what it really wants to receive.
>
> This initial CLUE exchange is followed by an SDP offer/answer exchange
> that not only establishes those aspects of the media that have not been
> "negotiated" over CLUE, but has also the side effect of setting up the
> media transmission itself, involving potentially security exchanges,
> ICE, and whatnot.  This step is plain vanilla SIP.
>
> Mark
>
> *From:*Stephan Wenger [mailto:[email-masked]]
> *Sent:* Thursday, January 08, 2015 12:47 PM
> *To:* Duckworth, Mark; [email-masked]
> <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: Can CLUE signaling help reduce size of SDP?
>
> Yes, the language regarding the potential of reducing the SDP size
> through information gathered in the CLUE message exchange was originally
> from me.  It stems from a time when we were considering (had agreed on?
>   At least in principle?  I don’t recall…) a multiphase negotiation: 1)
> set-up CLUE channel, 2) negotiate (over the CLUE channel, in a fashion
> similar to O/A) parameters that included parameters traditionally
> negotiated over SDP using the much richer XML-based CLUE syntax, and 3)
> only then pro-forma “negotiate” via SDP O/A with the side effect of
> setting up the media.  A few years ago, that line of thought was
> popular.  Personally, I still find it sensible, given the limitations
> and awkwardness of SDP.  But it’s not how CLUE works today, as far as I
> understand it.
>
> Paul’s comments below sound sensible to me, but I’m not sufficiently
> well versed in CLUE and O/A to assert correctness or lack thereof.
>
> Regards,
>
> Stephan
>
> *From: *<Duckworth>, "Duckworth, Mark" <[email-masked]
> <mailto:[email-masked]>>
> *Date: *Monday, December 22, 2014 at 14:10
> *To: *Paul Kyzivat <[email-masked]
> <mailto:[email-masked]>>, CLUE <[email-masked]
> <mailto:[email-masked]>>, Stephan Wenger <[email-masked]
> <mailto:[email-masked]>>
> *Subject: *Can CLUE signaling help reduce size of SDP?
>