Subject: [clue] MCC attribute Allow Subset Choice

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 16 Jan 2015 14:51:25 -0800

Here is proposed framework text changes for a new MCC attribute.  Please comment.

Add to section 7:

7.2.1.4. Allow Subset Choice

The Allow Subset Choice MCC attribute is a boolean value, indicating whether or not the Provider allows the Consumer to choose a specific subset of the Captures referenced by the MCC.  If this attribute is true, and the MCC references other Captures, then the Consumer MAY select (in a Configure message) a specific subset of those Captures to be included in the MCC.  If this attribute is false, or the MCC does not reference other Captures, then the Consumer MUST NOT select a subset.

Change text in section 9:

- If the MCC attribute Allow Subset Choice is true, then the Consumer may or may not choose to receive all the indicated Captures.  It can choose to receive a sub-set of Captures indicated by the MCC.

For example if the Consumer receives:
        MCC1(VC1,VC2,VC3){attributes}

A Consumer could choose all the Captures within a MCCs however if the Consumer determines that it doesn't want VC3 it can return MCC1(VC1,VC2).  If it wants all the individual Captures then it returns only the MCC identity (i.e. MCC1).  If the MCC in the advertisement does not reference any individual captures, or the Allow Subset Choice attribute is false, then the Consumer cannot choose what is included in the MCC, it is up to the Provider to decide.

Mark

---

From: Robert Hansen <[email-masked]>
Date: Mon, 19 Jan 2015 16:12:11 +0000

Hi Mark,

That looks good to me.

Rob

On 16/01/15 22:51, Duckworth, Mark wrote:
> The Allow Subset Choice MCC attribute is a boolean value, indicating 
> whether or not the Provider allows the Consumer to choose a specific 
> subset of the Captures referenced by the MCC.  If this attribute is 
> true, and the MCC references other Captures, then the Consumer MAY 
> select (in a Configure message) a specific subset of those Captures to 
> be included in the MCC.  If this attribute is false, or the MCC does 
> not reference other Captures, then the Consumer MUST NOT select a subset.
>
> - If the MCC attribute Allow Subset Choice is true, then the Consumer 
> may or may not choose to receive all the indicated Captures.  It can 
> choose to receive a sub-set of Captures indicated by the MCC.
>
> A Consumer could choose all the Captures within a MCCs however if the 
> Consumer determines that it doesn't want VC3 it can return 
> MCC1(VC1,VC2).  If it wants all the individual Captures then it 
> returns only the MCC identity (i.e. MCC1).  If the MCC in the 
> advertisement does not reference any individual captures, or the Allow 
> Subset Choice attribute is false, then the Consumer cannot choose what 
> is included in the MCC, it is up to the Provider to decide.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Tue, 20 Jan 2015 17:44:46 +1100

Hello Mark,

Should we document what the behaviour is of the provider in response to 
the CONFIGURE when Allow subset choice is true? i.e. Allow Subset Choice 
is true and the consumer returns a sub-set then the provider MUST send 
that subset.

A small nit on the text "A Consumer could choose all the Captures within 
a MCC<s> however if the...". The <s> can be deleted.

Regards, Christian

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 20 Jan 2015 06:33:53 -0800

Hi Christian,
Yes, I agree, I was thinking that when I wrote it, but forgot to put it in the text!
Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Tuesday, January 20, 2015 1:45 AM
> To: [email-masked]
> Subject: Re: [clue] MCC attribute Allow Subset Choice
> 
> Hello Mark,
>