Subject: Re: final URI scheme question (non-trivial)

From: Nicolas Popp <[email-masked]>
Date: Tue, 30 May 2000 09:35:59 -0700

If it is syntactically correct, sounds good to me...
Anyone?

-Nico

-----Original Message-----
From: Michael Mealling [mailto:[email-masked]]
Sent: Tuesday, May 30, 2000 9:15 AM
To: [email-masked]
Subject: Re: final URI scheme question (non-trivial)

On Mon, May 29, 2000 at 08:39:07PM -0700, Nicolas Popp wrote:
> To support different datasets, a service can always define a custom
property
> (suh as "datasetID"). Then, the client can use that property in the query
to
> restrict the results to a specific dataset.
>
> An alternative for a CNRP service implementor with multiple datasets is to
> define multiple services (a service for trademarks only, a service for
> generice term only an possibly a third service encompassing both
datasets).
>
> Yet another way would be to simply use the "category" property.
>
> In other words, there is enough flexibility in the exisiting mechanisms to
> support the notions of datasets.
>
> To keep things simple, I would therefore get rid of the PATH...

This is my point of view as well. This would leave us with a URI
that looks like this:

cnrp://[host:port]/?[<common-name>]*[;<attribute>=<value>]

Now, one question: RFC 2396 defines the slash after the port to be
part of the path which means we take it out leaving us with
something that usually looks like this:

cnrp://foo.com?Motorola;language=en
or
cnrp://foo.com:7654?Motorola;language=en

Is that ok? Its consistent and syntactically correct according to 2396...

-MM

--
----------------------------------------------------------------------------
----
Michael Mealling        |      Vote Libertarian!       |
www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:
14198821
Network Solutions       |          www.lp.org          |
[email-masked]

---

From: "Marshall L. Moseley" <[email-masked]>
Date: Tue, 30 May 2000 10:00:50 -0700

Yes, remove the slash if we're not doing paths.  It's confusing.

--Marshall