Subject: Re: CNRP based service?

From: Angelo Gonzalez <[email-masked]>
Date: Tue, 3 Jul 2001 22:44:18 +0200

Hello,
Have two questions that may not belong in this list but...
maybe somebody can give me an answer:

    1) Do internationalized names have to be registered with
         Realnames or Microsoft?. If so, any fee?

     2) I am a Netscape user. When I type an URL that is not
         recognized by the DNS, it redirects the string to their search
         engine. I wonder if they (Netscape) are working on a similar
         approach as IE for their browser?

Thank you,

                     Angelo Gonzalez
  .                  Vigo, Spain
=======================================

Nicolas Popp wrote:

> Theinternational domain names are resolving through RealNames Keywords
> resolvers.
> It is not based on CNRP as the existing versions of IE does not implement
> CNRP (CNRP is not an RFC yet), but the resolution still happens through a
> common name resolution system.
> The way it works is as follows.
>
> 0. The user types ML.com
> 1. The browser tries DNS but it fails
> 2. The browser then tries the RealNames Keyword resolution system (using a
> simple HTTP query interface)
> 3. The Keywords resolver recognizes the suffix .com (or .org or .net). It
> namepreps the ML string and encodes it using RACE encoding (DUDE tomorrow)
> according to the iDN Working Group drafts.
> 4. The resolver redirects the browser to bq--xxxx.mtbld.com (the Verisign
> testbed)
> 5. DNS and the test bed do the rest
>
> The nice thing about this approach is that:
>
> . No change is required at the client or at the ISP level.
> . It is a server side implementation that can quickly be changed as the iDN
> standard is finalized (we can backward enable IE with the final iDN standard
> so that iDN names reolve properly). However, note that the name displayed in
> the browser bar is the ascii encoded name not the language friendly name
> that was typed initially.
>
> Obviously, it only works in IE at this point (where the keyword resolution
> mechanism is built-in), but Web browsing is clearly a key application.
>
> Although, this is not specifically using CNRP, this is a great example of
> the kind of things (extended naming services) that can be implemented
> through CNRP enabled applications.
>
> -Nico
>
> -----Original Message-----
> From: Kazuo NISHIYAMA [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 3:58 AM
> To: [email-masked]
> Subject: CNRP based service?
>
> Hello, I'm a newcomer of this ML.
>
> I found following news.
>
> > VeriSign Announces Breakthrough in Web Navigation
> > For Tens of Millions of Users Worldwide
> >
> > Users can now reach Web sites via domain names in
> > their own languages through Microsoft Internet Explorer 5.0
> >
> > http://corporate.verisign.com/news/2001/pr_20010620.html
>
> Is this service uses CNRP or different technology?
>
> ---
> Kazuo NISHIYAMA
> [email-masked]

---

From: Leslie Daigle <[email-masked]>
Date: Tue, 3 Jul 2001 17:22:25 -0400

Howdy,

This really is getting beyond the scope of this mailing list.

If anyone wants to pursue this -- please take it off line, unless
you want to speak to specific issues in the CNRP protocol.

Thanks,
Leslie.

--

-------------------------------------------------------------------
"The best laid plans
    are written in pencil."
   -- ThinkingCat

Leslie Daigle
[email-masked]
-------------------------------------------------------------------