Subject: Re: associating constant feature sets wi

From: Graham Klyne <[email-masked]>
Date: Thu, 21 Jan 1999 12:34:50 +0000

At 10:14 20/01/99 -0500, Reynolds Franklin NRC/Boston wrote:
[...]
>I agree with Graham that we can separate most of the issues of naming
>and representation of feature sets from "transfer". I am very interested
>in an HTTP specific version of the negotiation protocol but I don't have
>a strong preference about where the work takes place.

Nor I...  I'm just keen to maintain the separation.

The little precedent that we have (i.e. fax) suggests that the transfer
elements for HTTP would be dealt with by an HTTP-oriented group.

#g

------------
Graham Klyne
([email-masked])

---

From: Graham Klyne <[email-masked]>
Date: Thu, 21 Jan 1999 12:34:52 +0000

At 16:33 20/01/99 +0100, Johan Hjelm wrote:
[...]
>In a work that is being done in conjunction with the WAP Forum, myself and
>Hidetaka Ohto of Panasonic are currently developing exactly that. We should
>be able to make the protocol available for review here when the spec is in
>a decent state. 

>It turns out that HTTP is a rather good fit for this (if you use extension
>headers), but departs a lot from the protocol-independent direction the
>conneg group has been taking, since several of our ideas are using generic
>HTTP 1.1 functions to accomplish the process. 

Is this helpful?  It sounds to me as if a purely HTTP-based solution would
not be applicable to, say, e-mail environments.

IMO, one of the greatest benefits of pursuing a protocol-independent
approach is that the capability semantics are to some extent unified across
different protocols.  This in turn means that gatewaying between protocols
is easier to achieve without loss or distortion of information.

Can the *semantics* developed in this group be mapped exactly by the HTTP
extension syntax that you are proposing?

#g

------------
Graham Klyne
([email-masked])

---

From: "Hidetaka Ohto" <[email-masked]>
Date: Fri, 29 Jan 1999 21:14:09 -0500

As Johan noticed, Johan and I are currently developing
capability negotiation protocol for HTTP/1.1named
"CC/PP exchange protocol based on HTTP Extension Framework ".

We believe that the CC/PP exchange protocol
is a rather generic spec.
So the protocol might be applied for another format.

The spec is available now.
Please see at:
http://www.w3.org/TR/NOTE-CCPPexchange

Any comment is always welcome.

Best Regards,
-- Hidetaka "Taka" Ohto

-----------------------------------------
Hidetaka  "Taka" Ohto
   Panasonic Technologies Inc
   Visiting Engineer at the W3C
      [email-masked]
      Fax +1-617-258 5999, Phone +1-617-258-0982
      MIT/LCS, 545 Tech. Sq. Cambridge MA 02139 USA

-----Original Message-----
From: Johan Hjelm <[email-masked]>
To: Reynolds Franklin NRC/Boston <[email-masked]>
Cc: Graham Klyne <[email-masked]>; Koen Holtman <[email-masked]>;
ietf-medfree <[email-masked]>
Date: Wednesday, January 20, 1999 10:48
Subject: Re: associating constant feature sets wi

>At 10:14 1999-01-20 -0500, Reynolds Franklin NRC/Boston wrote:
>>
>>I agree with Koen, that a generic or transport independent negotiation
>>protocol may have only  limited value. On the other hand,  I would like to
>>see a capability negotiation protocol for HTTP. I am not sure whether the
>>work should be done in this group or the HTTP group.
>>
>Johan
>************************************************************
>                     Johan HJELM
>            Ericsson RCUR T/K & Cyberlab NY
>         Currently visiting engineer at the W3C
>             The World Wide Web Consortium
>                     [email-masked]
>   http://www.w3.org/People/W3Cpeople.html#Hjelm
>    Fax +1-617-258 5999, Phone +1-617-263-9630
>   MIT/LCS, 545 Tech. Sq. Cambridge MA 02139 USA
>        opinions are personal, always my own,
>  and not necessarily those of Ericsson or the W3C.
>============================================================