Subject: RE: Ted's concerns about wastefulness (Accept-* problem)

From: "Martin J. Duerst" <[email-masked]>
Date: Sun, 31 Jan 1999 10:11:28 +0900

At 22:52 99/01/29 PST, Larry Masinter wrote:
> > The lookup problem bothers me, because I believe there will be
> > relatively few cases where the hash as given would be instantly
> > recognizable (since it includes both features and feature values).
> 
>    (SONY_VGA_MODELXXX) :-
>       (| (& (pix-x=640)
>             (pix-y=280)
>             (color=256))
>          (& (pix-x=1028)
>             (pix-y=1028)
>             (color=256)))
> is equivalent in this regard to
>    (fh=1aXb124AsDfg) :-
>        (| (& (pix-x=640) ...)

   (SONY_VGA_MODELXXX) :-
      (| (& (pix-x=640)
            (pix-y=280)
            (color=256))
         (& (pix-x=1028)
            (pix-y=1028)
            (color=256)))

is obviously equivalent to:

   (SONY_VGA_MODELXXX) :-
      (| (& (pix-x=640)
            (color=256)
            (pix-y=280))
         (& (pix-y=1028)
            (pix-x=1028)
            (color=256)))

or

   (SONY_VGA_MODELXXX) :- (| (& (pix-x=640) (color=256) (pix-y=280))
                             (& (pix-y=1028) (pix-x=1028) (color=256)))

or a lot of other combinations. Can you make sure that all these
things hash the same?

Regards,  Martin.

#-#-#  Martin J. Du"rst, World Wide Web Consortium
#-#-#  mailto:[email-masked]   http://www.w3.org

---

From: Graham Klyne <[email-masked]>
Date: Mon, 01 Feb 1999 19:15:41 +0000

At 10:11 31/01/99 +0900, Martin J. Duerst wrote:
[...]
>or a lot of other combinations. Can you make sure that all these

The short answer is "yes".  Less clear is whether doing so justifies the
added complexity in relation to simple hashing (given that, in many cases,
the hash may be derived from the same source as the text it identifies).

#g

------------
Graham Klyne
([email-masked])