Subject: RE: [VPIM] Analogy to Content-Duration for Faxes

From: "Neystadt, John" <[email-masked]>
Date: Wed, 8 Mar 2000 13:31:36 +0200

So, what should be a way to advance with this, should I try to write a draft
for this feature?

John Neystadt
[email-masked]
http://www.neystadt.org/john/

> -----Original Message-----
> From: Graham Klyne [mailto:[email-masked]]
> Sent: Wed, March 08, 2000 12:45 PM
> To: Neystadt, John
> Cc: conneg WG; IETF VPIM List; [email-masked]
> Subject: RE: [VPIM] Analogy to Content-Duration for Faxes
> 
> 
> John,
> 
> I think there's nothing wrong with a small RFC :-)
> 
> <draft-ietf-conneg-content-features-02.txt> has already gone 
> forward for 
> last call, and the IESG review is (at least) partially done.  
> Also, there's 
> not an obvious linkage between registration of "pages" and the 
> "content-features:" header proposal, so I think they are 
> better kept separate.
> 
> BTW, I think Larry's proposal was always to register "pages", as you 
> suggest, and that the reference to "UA-media" was simply a 
> (subsidiary) 
> possibility to qualify the kind of "page" being indicated.
> 
> Regards,
> 
> #g
> --
> 
> 
> At 11:38 PM 3/7/00 +0200, Neystadt, John wrote:
> >ua-media doesn't fits well, we are not talking about user 
> agents here.
> >
> >I think registering media feaure "pages" is a better one.
> >
> >What should be done to go forward with this. It seems to 
> small item for an
> >RFC, can't we take tremp and add it into
> >draft-ietf-conneg-content-features.txt?
> >
> >John Neystadt
> >[email-masked]
> >http://www.neystadt.org/john/
> >
> >
> >
> > > -----Original Message-----
> > > From: Larry Masinter [mailto:[email-masked]]
> > > Sent: Thu, February 10, 2000 4:35 AM
> > > To: [email-masked]
> > > Cc: Neystadt, John; IETF VPIM List; [email-masked]
> > > Subject: RE: [VPIM] Analogy to Content-Duration for Faxes
> > >
> > >
> > >
> > > # > Content-Features: pages=10
> > >
> > > # > to note a 10-page document.
> > >
> > > # Might even want to have an additional attribute to say what
> > > sort of "page"
> > > # you're talking about.
> > >
> > > RFC 2534 already registers 'ua-media' tag with values such as
> > > 'screen-paged'
> > > and 'stationery' (most likely the kind of pages you'd want
> > > with faxes), and
> > > a 'paper-size' tag with additional token values. At the time
> > > RFC 2534 was
> > > written, we were focusing mainly on media features for
> > > recipients rather
> > > than
> > > for content; you might still want to characterize a fax
> > > recipient as having
> > > a maximum number of pages its willing to receive, though.
> > >
> > >
> > >
> > >
> 
> ------------
> Graham Klyne
> ([email-masked])
> 
>

---

From: [email-masked]
Date: Wed, 8 Mar 2000 13:11:12 -0800 (PST)

John,
	Writing a draft for the feature is the correct next step for a
feature to be considered in the unfaceted IETF registration tree.
Please cc: the conneg working group when the internet drafts editor
issues it, but do not request it be issued as a working document of
the conneg group.  The area directors do not wish the conneg group to
become a permanent working group for features; they prefer that features,
like MIBs, be definted by the groups which need them.
	If you have further questions on the administratrivia,
please let me know.
			regards,
				Ted Hardie
				chair, conneg