Subject: FW: Terminology, etc.

From: "Larry Masinter" <[email-masked]>
Date: Tue, 7 Mar 2000 07:29:46 -0800

To the media feature registry working group:

In your opinion, is it appropriate to register "character repertoires" (ability to render a subset
of characters) as media features? 
 
... (from another message in a different forum) ...

 See http://www.isi.edu/in-notes/iana/assignments/media-feature-tags 
Should we use Media Feature (more flexible) or Locale (no delay in registering)? 
I note ISO-639-2 has a language called "mul" (for multilingual), so we could rename character collections as follows (and then register as Media Features at IANA) : 
mul-WORLDA.charcol 
    US-ASCII 
mul-WORLDB.charcol 
    GSM 03.38, or 3G TS 23.038 ??? 
mul-WORLDC.charcol 
    Latin-1 (deprecated) 
mul-WORLDD.charcol 
    minimised MES-1 with Greek 
mul-WORLDE.charcol 
    WGL4 (what Asian characters could be added while keeping font size 
   'manageable' - Hiragana, Katakana??) 
mul-EUROB.charcol 
    MES-2 
mul-EUROC.charcol 
    MES-3 fixed 
jp-JP.charcol 
    something like JIS 208 and some JIS 212...  

....

---

From: "Martin J. Duerst" <[email-masked]>
Date: Wed, 08 Mar 2000 11:37:58 +0900

Several comments:

- The names choosen below, in particular 'worlda', 'worldb',...,
  don't seem appropriate.

- Registering multilingual locales when all one wants to do is
  register character collections doesn't look appropriate to me.

- There is a proposal on how to describe character collections,
  available as a W3C Note at http://www.w3.org/TR/charcol.
  This is NOT a W3C Recommendation, but just a private proposal
  by myself. But it makes sense to have descriptions available
  in some formally defined way.
  [Aaron and Toshiyuki already know that Note, I'm just mentioning
   it here for the others on this group].

Regards,   Martin.

>     something like JIS 208 and some JIS 212...  

#-#-#  Martin J. Du"rst, World Wide Web Consortium
#-#-#  mailto:[email-masked]   http://www.w3.org

---

From: Aaron Irvine <[email-masked]>
Date: Wed, 08 Mar 2000 12:58:44 +0000

> - The names choosen below, in particular 'worlda', 'worldb',...,

Maybe CORE or BASIC would be clearer.

>   register character collections doesn't look appropriate to me.

Feature tag name
----------------
output-character-repertoire

Comment
----------
Describes what glyphs are present in a font (for example of mobile phone)

Legal values
------------
well known values:
US-ASCII
GSM
ISO-8859-1
MES-1
MES-2
MES-3-fixed
WGL4
JIS208
or any URI to a character collection, for example:
http://www.wapforum.org/I18N/core-1.charcol
http://www.wapforum.org/I18N/jp-jp-1.charcol

(but should values also have versions/dates)

(I keep thinking - does the Unicode Consortium already have names for character repertoires?)

Aaron

--

refs.
http://www.w3.org/TR/charcol
http://www.isi.edu/in-notes/iana/assignments/media-feature-tags

-----------------------------------------------------
Aaron Irvine
  mailto:[email-masked]
-----------------------------------------------------

---

From: [email-masked]
Date: Wed, 8 Mar 2000 13:16:08 -0800 (PST)

Do you want the character repetoire feature to reference the glyphs
available in a font, or the subset of characters available for a
particular charset?

Also, registered features are typed and mixing tokens and URIs would
create some parsing problems.  I would recommend using tokens if at
all possible; else you will end up using strings and have to deal with
the string matching problems.
			regards,
				Ted Hardie

---

From: "Larry Masinter" <[email-masked]>
Date: Wed, 8 Mar 2000 22:33:57 -0800

> Feature tag name

char-repertoire?

> Comment

Well, and which other control characters are renderable; for
example, space & tab, but not other EOL characters.

> Legal values

It's not clear that there's much value in using something
that corresponds to "every character in a charset". 

> JIS208

Where are these defined such that they are "well known"?

> http://www.wapforum.org/I18N/jp-jp-1.charcol

The only problem with this is that there is no way to determine
inclusion. For example, the name of "Latin 1 with Euro symbol"
would be different than the name of "Latin 1 without Euro symbol",
even though someone capable of rendering the former would be able
to render the latter.

Of course, no one is every going to ever do anything like adding
a Euro symbol again, so we don't have to worry about problems like
this, right?

Larry (sarcastic)
-- 
http://larry.masinter.net

---

From: Aaron Irvine <[email-masked]>
Date: Thu, 09 Mar 2000 10:10:40 +0000

> available in a font, or the subset of characters available for a

Glyphs available in a font.

> the string matching problems.

Okay thanks.

--

---

From: Aaron Irvine <[email-masked]>
Date: Thu, 09 Mar 2000 16:48:40 +0000

Hello,

> > output-character-repertoire

We may have input-character-repertoire to describe device input capabilities.

> example, space & tab, but not other EOL characters.

Okay.

> that corresponds to "every character in a charset".

Phones will understand UTF-8, but may only have glyphs from Latin-1 (plus euro
say) :-(

> Where are these defined such that they are "well known"?

Well, at the standards bodies ETSI, CEN, ISO, etc.  (For MES see www.egt.ie)

WGL4 is well known in the sense that lots of Windows machine have it already.
(For WGL4 see microsoft.com)

I had hoped unicode.org would have a page pointing to all these.  Maybe I just
haven't found it yet  -  anyone here from the Unicode Consortium?

> inclusion. For example, the name of "Latin 1 with Euro symbol"

The higher level (User Agent Profile for WAP phones) can group character
collections.  For example in Japan, typical might be:
jis208 added to mes2.

However, output-character-repertoire would indicate that *at least* these
glyphs are available.

> a Euro symbol again, so we don't have to worry about problems like

Again, output-character-repertoire would indicate that *at least* these glyphs
are available.

regards,
Aaron.
--

---

From: "Martin J. Duerst" <[email-masked]>
Date: Fri, 10 Mar 2000 11:31:40 +0900

> Glyphs available in a font.

Please be VERY careful here!

The collections you define are collections of characters.
Characters and glyphs are not the same. Not much of a difference
for Latin, but a huge difference for Arabic and for Indic scripts.

I suggest you have a look at the CSS2 spec, at the description
of the unicode-range property, and copy the language that deals
with this problem from there.

Regards,   Martin.