Subject: [core] IANA - Content-Formats

From: Achim Kraus <[email-masked]>
Date: Fri, 5 Nov 2021 16:05:44 +0100

Hi List,

according an issue in Eclipse/Californium from Jim, 2019

https://github.com/eclipse/californium/issues/1078

"There is an effort going on to get a sweep of all of the known
media-types registered"

he also referred to

https://datatracker.ietf.org/doc/draft-bormann-core-proactive-ct/

Though we currently want to update the media-types in Californium,
the question raises, if the ongoing effort is in the meantime finished?

Is

https://www.iana.org/assignments/core-parameters/core-parameters.xhtml#content-formats

the consolidated result?

best regards
Achim Kraus

---

From: Esko Dijk <[email-masked]>
Date: Fri, 5 Nov 2021 15:42:28 +0000

Hi Achim,

I did a quick check of the types mentioned in issue 1078. Not all of these are currently registered, although for most of these the number has been set to "Unassigned" in the Content-Formats IANA registry. 
So it looks like the sweep effort was not completed!

In any case for a CoAP library it makes sense to
* add support for the content formats (or a good selection of these? ) listed in the IANA Core Parameters Content-Formats registry. This is the definitive reference.
* remove support for the types that are not registered in there. (Why would we squat on unassigned Content-Formats? People may get a false impression that these are the official content-format numbers.)
  - for some types the registration may be pending e.g. due to an I-D. These types can of course stay in the library code.  However it may be hard to identify all such I-Ds ;)
* the issue 1078 has the line: "Application/x-obix-binary = 51" -> this conflicts with the current assignment in the registry: application/json-patch+json (51).  So it can better be updated to the registered type.

So best to update it now; and create a new issue to check again in some future time whether new types were added in the meantime.

Best regards
Esko

-----Original Message-----
From: core <[email-masked]> On Behalf Of Achim Kraus
Sent: Friday, November 5, 2021 16:06
To: [email-masked]
Subject: [core] IANA - Content-Formats

Hi List,

he also referred to

Is

the consolidated result?

best regards
Achim Kraus

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Achim Kraus <[email-masked]>
Date: Sat, 6 Nov 2021 08:54:37 +0100

Hi Esk,

that issue https://github.com/eclipse/californium/issues/1078 has been
considered 2019.

currently it's PR

https://github.com/eclipse/californium/pull/1814

I'm asking for.
That PR follows

so according your answer,

 > add support for the content formats (or a good selection of these? )
listed in the IANA Core Parameters Content-Formats registry. This is the
definitive reference.

I think, the PR is well. I just don't want to add media-types again, and
then remove them again, and so on.

best regards
Achim

---

From: Esko Dijk <[email-masked]>
Date: Sat, 6 Nov 2021 11:52:27 +0000

Yes, sorry, I noticed the issue 1078 was already closed.  I looked at it first because you mentioned it and then forgot to look at the PR code!

So agree to this PR; it would be good to add the content-formats from the IANA registry; since these are now IANA-allocated and unlikely to change.

Best regards
Esko

-----Original Message-----
From: Achim Kraus <[email-masked]> 
Sent: Saturday, November 6, 2021 08:55
To: Esko Dijk <[email-masked]>
Cc: [email-masked]
Subject: Re: [core] IANA - Content-Formats

Hi Esk,

currently it's PR

I'm asking for.
That PR follows

best regards
Achim