Subject: [core] CoRE applications side meetings (pubsub / dynlink)?

From: Christian Amsüss <[email-masked]>
Date: Mon, 8 Nov 2021 13:11:44 +0100

Hi,

The CoRE applications (pubsub, dynlink) get little attention on this
round's meeting -- shall we meet to see where and how we can make
progress? (This may include aligning with current CoRAL, but also
involve general discussion of what CoRE can be used for).

I'd be happy both with a larger meeting (like Wednesday or Thursday 2h
before the WG meetings), and in smaller groups ("everyone interested in
X").

BR
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Nov 2021 14:19:18 +0100

This week is full.
Can we instead have an earlier interim for this?

Grüße, Carsten

> On 8. Nov 2021, at 13:11, Christian Amsüss <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Christian Amsüss <[email-masked]>
Date: Tue, 9 Nov 2021 17:17:39 +0100

Hello,

> involve general discussion of what CoRE can be used for).

based on the feedback that arrived, a small group will meet tomorrow
(Thursday) 10:00 UTC in the hackathon area to look through some
applications (pubsub, problem-details), possibly doing examples or check
out how things align with current CoRAL.

We should probably meet in a larger group at some point too (maybe on
one of the wednesdays before CBOR/CoRE resume interims) still, but this
should get us a bit of a start already.

BR
c

PS. STP is one more of the applications I'd like to see a bit of
progress on, maybe we can push this in the same context.

-- 
A beginning is the time for taking the most delicate care that the balances are correct.
  -- Princess Irulan, Manual of Muad'Dib

---

From: Christian Amsüss <[email-masked]>
Date: Tue, 9 Nov 2021 20:47:35 +0100

> (Thursday) 10:00 UTC in the hackathon area to look through some

it's only Tuesday and I'm already in a state of mind melt.

tomorrow is Wednesday, which is when this *should* happen (at least
Marco, Jaime and me will be there).

Sorry for the mixup
c

---

From: Christian Amsüss <[email-masked]>
Date: Tue, 16 Nov 2021 15:55:19 +0100

Hello,

> out how things align with current CoRAL.

the small group was not all that small and very lively -- thanks
everyone for participating!

I've attached the minutes here in case the pad we used[1] goes away.

While we figure out how to best make more of the CoRE ecosystem publicly
visible at coap.technology, we can already start collecting material at
the wiki[2].

Best regards
Christian

[1]: https://notes.ietf.org/GaM_PWd2TnmY0DrTe6DdQA?view
[2]: https://github.com/core-wg/wiki/wiki

---

From: Göran Selander <[email-masked]>
Date: Mon, 29 Nov 2021 16:15:40 +0000

Dear T2TRG,

As reported from the CoRE applications side meeting below, there seems to be an interest in progressing topics in the area of security for constrained RESTful environments, and a proposal to host that work in T2TRG.

* What?

CoAP can be used in various settings beyond simple REST. How do we adapt existing security requirements and solutions to these new modes of operation? Some work of this kind is already in progress in the IETF but some issues go beyond the individual IETF WGs, or could benefit from additional contributions from a wider audience, reviews and information sharing.
Examples include:
- Rekeying with PFS vs. stateless operations [2]
- Firmware updates using group communication
- Efficient and secure tunnelling of CoAP in CoAP
- Notifications surviving rekeying
- Progressing pub-sub with CoAP

* Why?

To progress applications of CoAP in different security settings which "touch standardization in the IETF" [1] but are not necessarily in scope of a single working group like CoRE, ACE, SUIT, COSE, LAKE, etc.

* How?

Through a "sister" of WISHI:  A recurring meeting series under the T2TRG umbrella about topics on security for constrained RESTful environments. Working name: seccore (which apparently may mean "dryness" in some Italian context; not intended as a characterization of the content :-)  Frequency and topics open for discussion.

* Comments?

What do people think?

Should we try to have a first meeting before the upcoming holiday season?

Göran

[1] Thing-to-Thing (t2trg) - (ietf.org)<https://datatracker.ietf.org/rg/t2trg/charter/>
[2] [core] KUDOS, PFS and operations considerations (ietf.org)<https://mailarchive.ietf.org/arch/msg/core/EL0yHxQrP2DQwHxo6ojnQedvFbY/>

From: core <[email-masked]> on behalf of Christian Amsüss <[email-masked]>
Date: Tuesday, 16 November 2021 at 15:57
To: [email-masked] <[email-masked]>
Subject: Re: [core] CoRE applications side meetings (pubsub / dynlink)?
Hello,

Best regards
Christian

[1]: https://notes.ietf.org/GaM_PWd2TnmY0DrTe6DdQA?view
[2]: https://protect2.fireeye.com/v1/url?k=f4bbca08-ab20f04d-f4bb8a93-867b36d1634c-1b783ca428431080&q=1&e=a3621d21-f226-4875-acd7-faaf5c694f88&u=https%3A%2F%2Fgithub.com%2Fcore-wg%2Fwiki%2Fwiki