Subject: [core] [Editorial Errata Reported] RFC8428 (6728)

From: RFC Errata System <[email-masked]>
Date: Mon, 1 Nov 2021 07:40:28 -0700 (PDT)

The following errata report has been submitted for RFC8428,
"Sensor Measurement Lists (SenML)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6728

--------------------------------------
Type: Editorial
Reported by: Veijo Pesonen <[email-masked]>

Section: 11

Original Text
-------------
SenML-Pack = [1* record]

   record = {
     ? bn => tstr,        ; Base Name
     ? bt => numeric,     ; Base Time
     ? bu => tstr,        ; Base Units
     ? bv => numeric,     ; Base Value
     ? bs => numeric,     ; Base Sum
     ? bver => uint,      ; Base Version
     ? n => tstr,        ; Name
     ? u => tstr,        ; Units
     ? s => numeric,     ; Sum
     ? t => numeric,     ; Time
     ? ut => numeric,    ; Update Time
     ? ( v => numeric // ; Numeric Value
         vs => tstr //   ; String Value
         vb => bool //   ; Boolean Value
         vd => binary-value ) ; Data Value
     * key-value-pair
   }

Corrected Text
--------------
SenML-Pack = [1* record]

   record = {
     ? bn => tstr,        ; Base Name
     ? bt => numeric,     ; Base Time
     ? bu => tstr,        ; Base Units
     ? bv => numeric,     ; Base Value
     ? bs => numeric,     ; Base Sum
     ? bver => uint,      ; Base Version
     ? n => tstr,        ; Name
     ? u => tstr,        ; Units
     ? s => numeric,     ; Sum
     ? t => numeric,     ; Time
     ? ut => numeric,    ; Update Time
     ? ( v => numeric // ; Numeric Value
         vs => tstr //   ; String Value
         vb => bool //   ; Boolean Value
         vd => binary-value ), ; Data Value
     * key-value-pair
   }

Notes
-----
It would show good style to set the comma even though it's not required.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8428 (draft-ietf-core-senml-16)
--------------------------------------
Title               : Sensor Measurement Lists (SenML)
Publication Date    : August 2018
Author(s)           : C. Jennings, Z. Shelby, J. Arkko, A. Keranen, C. Bormann
Category            : PROPOSED STANDARD
Source              : Constrained RESTful Environments
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Nov 2021 16:09:15 +0100

This is a valid stylistic nit, but of no consequence to implementation or interoperability.
Please mark as “editorial”.

Grüße, Carsten

> On 2021-11-01, at 15:40, RFC Errata System <[email-masked]> wrote:
>