Subject: [Cose] COSE efficiency vs JOSE

From: Dick Hardt <[email-masked]>
Date: Wed, 1 Jul 2015 09:21:34 -0700

Hello

I looked over https://tools.ietf.org/html/draft-schaad-cose-00 but did not
see any indication of how much more efficient COSE will be over JOSE. Has
anyone done any tests with real token data?

-- Dick

Signup at http://HARDTWARE.com to be notified about my upcoming Kickstarter!

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 01 Jul 2015 21:09:44 +0200

> I looked over https://tools.ietf.org/html/draft-schaad-cose-00 but did
> not see any indication of how much more efficient COSE will be over
> JOSE. Has anyone done any tests with real token data?

Which kind of efficiency?

-- message size?
-- code size?
-- RAM requirements?
-- execution speed:
   -- on data center style hardware?
   -- on constrained nodes?

I'm assuming you meant the first (all five are important to the IoT).

Jim had some slides:

https://www.ietf.org/proceedings/92/slides/slides-92-jose-0.pdf

These are not numbered*), but slide 8 has some numbers:

Overheads only	– ignores contents	
		JOSE	 	Bormann	 Schaad	
1 Signer	 64 + base64	 13	 13	
1 MAC recipient	 64 + base64	 13	 14	
1 Encrypt rcpt	 94 + base64	 14	 14

There is some brownian motion in the exact numbers, but the gist should
still be true.  (The base 64 overhead is an additional 1/3 of the size
of binary data such as protected headers, authenticators, keys, etc.)

Grüße, Carsten

*) ceterum censeo: All presentation slides MUST be numbered.