Subject: [COSE] Data Types

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 31 Aug 2015 09:11:38 +0200

Hi Jim, Hi Brian,

CBOR introduces a couple of data types, such as text string and byte
string.

COSE-04 uses tstr, bstr, etc. I suspect that they are simply the
short-hand version of CBOR data types. This could be mentioned in the
terminology section or, alternatively, you could also use the CBOR
defined terms.

Ciao
Hannes

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 31 Aug 2015 09:36:35 -0700

These are hold overs from when I was planning on making CDDL normative.  Yes I need to do something about this.

Jim

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
> Sent: Monday, August 31, 2015 12:12 AM
> To: [email-masked]
> Subject: [COSE] Data Types
> 
> Hi Jim, Hi Brian,
> 
> CBOR introduces a couple of data types, such as text string and byte string.
> 
> COSE-04 uses tstr, bstr, etc. I suspect that they are simply the short-hand version
> of CBOR data types. This could be mentioned in the terminology section or,
> alternatively, you could also use the CBOR defined terms.
> 
> Ciao
> Hannes