Subject: [COSE] CDDL Grammar Descriptions

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 31 Aug 2015 09:32:31 +0200

Hi Brian, Hi Jim.

you write:

"
The CDDL grammar for a signature message is:

   COSE_Sign = [
       msg_type: msg_type_signed,
       Headers,
       payload : bstr,
       signatures : [+ COSE_signature]
   ]
"

Then, you explain the fields.

"
  msg_type  identifies this as providing the signed security service.
      The value MUST be msg_type_signed (1).

   protected  is described in Section 3.

   unprotected  is described in Section 3.
"

Unfortunately, protected and unprotected are not part of the CDDL
grammar above. So, it would be better to write:

"
   msg_type  identifies this as providing the signed security service.
      The value MUST be msg_type_signed (1).

   Header: The header parameter is described in Section 3.
"

The same occurs in other places of the document.

Ciao
Hannes

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 31 Aug 2015 11:28:24 +0200

>    Header: The header parameter is described in Section 3.

I would probably write:

Headers: The common header parameters (protected, unprotected) are
described in Section 3.

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 31 Aug 2015 11:51:32 +0200

Sounds good to me.

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 31 Aug 2015 11:04:22 -0700

If you read the text with the CDDL gone, I don't think that this makes any sense.  There is mention of headers in that case in the resulting structure or in section 3.0

Jim

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: Monday, August 31, 2015 2:28 AM
> To: Hannes Tschofenig <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [COSE] CDDL Grammar Descriptions
> 
> Hannes Tschofenig wrote:
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose