Subject: [COSE] CDDL

From: Justin Richer <[email-masked]>
Date: Mon, 7 Sep 2015 14:10:02 -0400

The chairs have discussed the issue of the use of CDDL[1]  in the current COSE draft and we agree with the assertion that dependency on an external, unfinished draft is not something we as a group should undertake lightly. Therefore, the chairs propose the following stance to the working group, and raise this for discussion.

The proposed schedule for COSE is aggressive, and we believe that our draft should not be held up by the schedule of another draft with no clear publication deadline[2]. Therefore a normative dependency on CDDL does not make sense within COSE and the normative text should always be the english text of the specification [3]. Furthermore, while some developers are comfortable writing from formal language definitions like the one that CDDL has invented, others are not, and copious, human-readable examples are more helpful to them. In both cases the normative text remains the English documentation.

If CDDL is not done by the time that COSE is done, it should be removed as a dependency in the document. Given that the timelines for the two of these do not align, it might make more sense to simply excise the CDDL sooner instead of waiting until our hand is forced later down the road.

The chairs would like the working group to discuss this point further so that we can call consensus on the matter prior to Yokohama. Please keep in mind during this discussion that whether or not you *like* the CDDL, the question is whether it is *practical* for COSE to use it.

 — Justin & Kepeng
(your COSE chairs)

[1] https://tools.ietf.org/html/draft-greevenbosch-appsawg-cbor-cddl-05 <https://tools.ietf.org/html/draft-greevenbosch-appsawg-cbor-cddl-05>
[2] https://mailarchive.ietf.org/arch/msg/cose/4hKUzEiXoglax2CFBBsezhyknDM
[3] https://mailarchive.ietf.org/arch/msg/cose/XnyFO9mX1ZyYjmF9l4GUXnMMhIs

---

From: Mike Jones <[email-masked]>
Date: Mon, 7 Sep 2015 19:01:20 +0000

I agree with this reasoning. We should not take a normative dependency on an unfinished draft.

-- Mike
________________________________
From: Justin Richer<mailto:[email-masked]>
Sent: ‎9/‎7/‎2015 11:10 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [COSE] CDDL

 — Justin & Kepeng
(your COSE chairs)

[1] https://tools.ietf.org/html/draft-greevenbosch-appsawg-cbor-cddl-05<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-greevenbosch-appsawg-cbor-cddl-05&data=01%7c01%7cMichael.Jones%40microsoft.com%7c59cea8519b2c49893a9808d2b7af95e8%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=KK6qZt3My%2f5tYpScgy%2ftV%2bcyOc3ouQckIuuVqaE02NU%3d>
[2] https://mailarchive.ietf.org/arch/msg/cose/4hKUzEiXoglax2CFBBsezhyknDM<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fmailarchive.ietf.org%2farch%2fmsg%2fcose%2f4hKUzEiXoglax2CFBBsezhyknDM&data=01%7c01%7cMichael.Jones%40microsoft.com%7c59cea8519b2c49893a9808d2b7af95e8%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=en%2bI%2f4IS5trmkyotbtBRwuPPUmEi%2fcMchoMPAEdS2dw%3d>
[3] https://mailarchive.ietf.org/arch/msg/cose/XnyFO9mX1ZyYjmF9l4GUXnMMhIs<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fmailarchive.ietf.org%2farch%2fmsg%2fcose%2fXnyFO9mX1ZyYjmF9l4GUXnMMhIs&data=01%7c01%7cMichael.Jones%40microsoft.com%7c59cea8519b2c49893a9808d2b7af95e8%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rk6fmL2EbvSe04kiDqkFXQP4vv5zZRNlygin3JgLhR8%3d>

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 7 Sep 2015 12:11:21 -0700

From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Monday, September 07, 2015 11:10 AM
To: [email-masked]
Subject: [COSE] CDDL

It is ok to publish a document which has an informational reference on a document which is currently in progress.  As long as it is not a normative dependency.

Jim

 — Justin & Kepeng

(your COSE chairs)

[1] https://tools.ietf.org/html/draft-greevenbosch-appsawg-cbor-cddl-05

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 7 Sep 2015 22:06:35 +0200

> It is ok to publish a document which has an informational reference on a
> document which is currently in progress.  As long as it is not a
> normative dependency.

Correct but the way the document is currently written CDDL is a
normative component of the spec.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 07 Sep 2015 22:10:54 +0200

Justin, Kepeng,

thank you for your careful consideration.
I'm not sure we had the question that you have been answering.
Clearly, we don't want to marry the schedule of COSE to that of CDDL, so
it has been clear for a while that there wouldn't be a normative
reference.  So that has to change, but that was clear before the WG even
was formed.
There is also little disagreement about having copious human-readable
examples.  (CDDL actually helps both with their correctness and (I hope
very soon) with their readability; see the recent RFC 7250 mishap for
another example why getting examples right is important here.)
Jim has given the reasons why excising CDDL from the draft (and, thus
robbing us from a useful way to have the discourse as well as a way to
automate some of the quality processes) would be extremely unwise.
So why can't we continue on the plan that was set out in May?

Grüße, Carsten

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 7 Sep 2015 13:50:10 -0700

And we have said that this was not going to be true in the long run.  I had
already begun to do the re-write last week on moving CDDL more out of the
mainstream.

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Monday, September 07, 2015 1:07 PM
> To: Jim Schaad <[email-masked]>; 'Justin Richer'
<[email-masked]>;
> [email-masked]
> Subject: Re: [COSE] CDDL
> 
> > It is ok to publish a document which has an informational reference on
> > a document which is currently in progress.  As long as it is not a
> > normative dependency.
> 
> Correct but the way the document is currently written CDDL is a normative
> component of the spec.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 08 Sep 2015 08:00:38 +0200

> already begun to do the re-write last week on moving CDDL more out of the

Looking at the current editor's draft I'm not even sure why we are
moving the CDDL to an appendix.

It can stay there with the main text as an illustration.

Grüße, Carsten

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 8 Sep 2015 19:10:16 -0700

If you look at the current editor's draft, I have done a couple of sections so people can see what is happening with respect to this.    If others feel that keeping the CDDL inline helps to make things clearer, now is the time to speak up.

Jim

> From: Carsten Bormann [mailto:[email-masked]]
> Sent: Monday, September 07, 2015 11:01 PM
> To: Jim Schaad <[email-masked]>
> Cc: 'Hannes Tschofenig' <[email-masked]>; 'Justin Richer'
> <[email-masked]>; [email-masked]
> Subject: Re: [COSE] CDDL
> 
> Jim Schaad wrote:
> > And we have said that this was not going to be true in the long run.
> > I had already begun to do the re-write last week on moving CDDL more
> > out of the mainstream.
> 
> Looking at the current editor's draft I'm not even sure why we are moving the
> CDDL to an appendix.
>

---

From: Olaf Bergmann <[email-masked]>
Date: Thu, 10 Sep 2015 13:24:55 +0200

Jim,

"Jim Schaad" <[email-masked]> writes:

> If you look at the current editor's draft, I have done a couple of
> sections so people can see what is happening with respect to this.  If
> others feel that keeping the CDDL inline helps to make things clearer,
> now is the time to speak up.

After reading the editor's version for the first time yesterday, I found
the inline CDDL snippets very useful. They provide a clear and
comprehensible summary of the normative text that precedes these
snippets. Therefore, I am in strong favor of keeping them inline.

Grüße
Olaf