Subject: [COSE] draft-birkholz-sacm-coswid-01

From: Jim Schaad <[email-masked]>
Date: Fri, 19 Aug 2016 20:37:42 -0700

This represents a fast read through and not a hard review.

Section 1 - bullet point 2 - I think that the reference to X.1520 is in the
wrong place

Section 2 - the change of the naming scheme seems to be gratuitous.  You
need to justify it  if you are going to keep it.

Section 3 - why are you wrapping a hash in a bstr rather than leaving it as
an array?

Section 4 - you have the protected and unprotected header restrictions
backwards

Jim

---

From: Jim Schaad <[email-masked]>
Date: Fri, 19 Aug 2016 21:13:48 -0700

Wrong mail list

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Jim Schaad
> Sent: Friday, August 19, 2016 8:38 PM
> To: [email-masked]
> Cc: 'cose' <[email-masked]>
> Subject: [COSE] draft-birkholz-sacm-coswid-01
> 
> Section 1 - bullet point 2 - I think that the reference to X.1520 is in
the wrong
> place
need
> to justify it  if you are going to keep it.
> 
> Section 3 - why are you wrapping a hash in a bstr rather than leaving it
as an
> array?
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose