Subject: Re: [COSE] Adoption of RSA and alternative algorithms

From: Samuel Erdtman <[email-masked]>
Date: Mon, 1 Aug 2016 10:21:41 +0200

see inline

On Fri, Jul 29, 2016 at 4:04 PM, Justin Richer <[email-masked]> wrote:

> Hi all, hope that everyone is recovering from Berlin. As discussed in the
> meeting last week, the working group is considering additional work on RSA
> and other algorithms in the COSE messages framework. These would be
> published in a document separate from the core draft that is now on its
> journey to RFC-land.
>
> The chairs would like to gauge the sentiment of the working group on a
> number of items related to this proposed work. Please respond with your
> answers to the list.
>
>
> 1) Do you think it’s necessary or worthwhile to define RSA and other
> additional algorithms in the COSE messages framework?
>
> A) Yes, we should do an RSA/other-algs document
> B) No, we shouldn’t do an RSA/other-algs document
> C) Yes, but not right now
> D) I need more information (please ask what you want to know)
> E) I don’t give a flying rat whether this gets done or not
>
>
A) I think RSA is interesting now and for a while, to make it easier to
integrate with legacy systems. They would need to change stuff but they
might have an RSA implementation they could reuse.

>
>
> 2) If the work is adopted, where should it be done?
>
> A) Here in COSE (we’ll keep the group open for this item)
> B) In other working group (please specify where; note that ACE is a
> possible option)
> C) I need more information (ask what you want to know)
> D) I don’t give a flying rat where this happens
>

D) Don´t care

>
> 3) If the work is adopted, which draft is a good starting point?
>
> A) Jim’s draft: https://tools.ietf.org/html/draft-schaad-cose-alg-01
> B) Mike’s draft: https://tools.ietf.org/html/draft-jones-cose-rsa-00
> C) Some other draft (please tell us which one it is or offer to write it
> yourself)
> D) I need more information (ask what you want to know)
> E) I don’t give a flying rat which document we start with
>
>
>
E) Don´t care, they look the same to me.

>
>
> We’re going to keep this thread open for two weeks at the AD’s request,
> and the chairs will try to make a consensus call at the end of that time
> period.
>
> Thank you,
>
>  — Justin & Kepeng, your COSE chairs
>
>
> *        \.  -   -  .
>        '          _ , -`.
>      '        _,'     _,'
>     '      ,-'      _/
>    '    ,-' \     _/
>   '   ,'     \  _'
>   '  '       _\'
>   ' ,    _,-'  \     _________
>   \,_,--'       \    \\_______\
>                  \    \\+=+=+=+\
>                   \    \\=+=+=+=\
>                    \    \\+=+=+=+\
>                     \    \\=+=+=+=\________
>                      \    \\+=+=+=+____----))
>                       \    \`---------.)))\\
>                        \   ||+=+=+=+=+=\\ /\\
>                         \  ||___________\\/ \\
>                          \ ||------------\\
>   ejm                     \||             \\
> *
>
>
>
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>
>

---

From: Matias Woloski <[email-masked]>
Date: Thu, 11 Aug 2016 13:27:32 -0300

inline

On Fri, Jul 29, 2016 at 11:04 AM, Justin Richer <[email-masked]> wrote:

> A) RS can be implemented in pretty much any language, easily enough.
>
> D)
> E)
ᐧ

---

From: Brian Campbell <[email-masked]>
Date: Thu, 11 Aug 2016 11:20:22 -0600

1) A. And, as I've said several times previously, I think RSASSA-PKCS1-v1_5
should be included.
2) D but A probably makes sense.
3) E

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 11 Aug 2016 22:31:58 +0000

Here are my choices

1.      A

2.      A

3.      B
From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Friday, July 29, 2016 10:04 AM
To: cose <[email-masked]<mailto:[email-masked]>>
Subject: [COSE] Adoption of RSA and alternative algorithms

Hi all, hope that everyone is recovering from Berlin. As discussed in the meeting last week, the working group is considering additional work on RSA and other algorithms in the COSE messages framework. These would be published in a document separate from the core draft that is now on its journey to RFC-land.

The chairs would like to gauge the sentiment of the working group on a number of items related to this proposed work. Please respond with your answers to the list.

1) Do you think it’s necessary or worthwhile to define RSA and other additional algorithms in the COSE messages framework?

A) Here in COSE (we’ll keep the group open for this item)
B) In other working group (please specify where; note that ACE is a possible option)
C) I need more information (ask what you want to know)
D) I don’t give a flying rat where this happens

C) Some other draft (please tell us which one it is or offer to write it yourself)

We’re going to keep this thread open for two weeks at the AD’s request, and the chairs will try to make a consensus call at the end of that time period.

Thank you,

        \.  -   -  .

       '          _ , -`.

     '        _,'     _,'

    '      ,-'      _/

   '    ,-' \     _/

  '   ,'     \  _'

  '  '       _\'

  ' ,    _,-'  \     _________

  \,_,--'       \    \\_______\<smb://_______/>

                 \    \\+=+=+=+\<smb://+=+=+=+/>

                  \    \\=+=+=+=\<smb://=+=+=+=/>

                   \    \\+=+=+=+\<smb://+=+=+=+/>

                    \    \\=+=+=+=\________

                     \    \\+=+=+=+____----))

                      \    \`---------.)))\\

                       \   ||+=+=+=+=+=\\ /\\

                        \  ||___________\\/ \\

                         \ ||------------\\

  ejm                     \||             \\

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 15 Aug 2016 09:05:19 +0200

On 2016-07-29 16:04, Justin Richer wrote:
> Hi all, hope that everyone is recovering from Berlin. As discussed in
> the meeting last week, the working group is considering additional
> work on RSA and other algorithms in the COSE messages framework.
> These would be published in a document separate from the core draft
> that is now on its journey to RFC-land.
>
> The chairs would like to gauge the sentiment of the working group on
> a number of items related to this proposed work. Please respond with
> your answers to the list.
>
>

(Not relevant for the usecases I am looking at)

> A) Here in COSE (we’ll keep the group open for this item)

If we do it, COSE seems the most fitting WG to do it. I trust this would 
not delay the other work in the group?

> E) I don’t give a flying rat which document we start with

Regards,

Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se