Subject: [COSE] exact input to the sig computation

From: "Lundblade, Laurence" <[email-masked]>
Date: Tue, 6 Dec 2016 02:39:26 +0000

Can you confirm for me the input to the signature computation (e.g. ECDSA) is the concatenation of the the bstr wrapped  protected headers and the bstr wrapped payload?  Pretty sure that’s right, but it doesn’t seem to be explicit in the cose draft. Sorry if I missed it.

Thx

LL

---

From: Jim Schaad <[email-masked]>
Date: Mon, 5 Dec 2016 19:26:16 -0800

No that is not correct.   The correct input is called out in section 4.4.

You can also look at
https://github.com/jimsch/Examples/blob/master/ecdsa-examples/ecdsa-01.json
for the ToBeSign_hex field

jim

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Lundblade, Laurence
> Sent: Monday, December 05, 2016 6:39 PM
> To: cose <[email-masked]>
> Subject: [COSE] exact input to the sig computation
> 
> Can you confirm for me the input to the signature computation (e.g. ECDSA)
is
> the concatenation of the the bstr wrapped  protected headers and the bstr
> wrapped payload?  Pretty sure that's right, but it doesn't seem to be
explicit in
> the cose draft. Sorry if I missed it.
> 
> Thx
> 
> LL
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: "Lundblade, Laurence" <[email-masked]>
Date: Tue, 6 Dec 2016 03:31:26 +0000

Well, I sure did miss it didn’t I. Thanks for the quick response. :-)

LL