Subject: [COSE] Stabilising the x509 draft [was Call for Consensus: Standalone Hash Algorithms Document]

From: DESPERRIER Jean-Marc <[email-masked]>
Date: Fri, 1 Mar 2019 16:17:01 +0000

Hi, I'm neutral with regard to the decision about a standalone hash document, however I'd like to point that as  ISO/IEC JTC 1/SC 17/WG 10 has now decided to go forward with using COSE inside the ISO 18013-5 document, we too would have a need for early assignment of values, to be able to prototype, at least for the x5chain header.

Reading the minutes, what kind of playing with the spec would be required to make it advance ? Try to do a sample implementation ?

Br, Jean-Marc Desperrier

-----Message d'origine-----
De : COSE <[email-masked]> De la part de Matthew A. Miller
Envoyé : mardi 26 février 2019 01:16
À : cose <[email-masked]>
Objet : [COSE] Call for Consensus: Standalone Hash Algorithms Document

This messages starts a call for consensus to separate the COSE hash algorithms into a separate document, ending on 2018-03-10.

In the virtual interim on 02-15, it was proposed to separate them from draft-ietf-cose-x509, to allow the hash algorithm registrations to stabilize more quickly than the rest of the X.509 draft.  If the working group agrees with separating the algorithms, then a document will be published that consists of Section 4 (Hash Algorithm Identifiers) and Section 5.3 (COSE Algorithm Registry) from draft-ietf-cose-x509.

Please respond with whether or not you support separating the hash algorithms into a separate document.  If you do not support this, please indicate why not.

- Ivaylo and Matthew
COSE Chairs

---

From: Jim Schaad <[email-masked]>
Date: Fri, 1 Mar 2019 11:20:16 -0800

>From my point of view, the major thing is to try and figure out if the set of items is complete and resolve the question of should we do the same thing that JOSE does where they allow for x.509 certificates to be carried as part of a cose key structure.  While my personal preference is no, I don't like dealing with all of the issues around making sure things match, I could be persuaded otherwise. 

Doing some prototyping of using them in various contexts would be something that can help resolve the question of completeness.  As an example, there is currently no support for things like OCSP or CRLs which I am currently just fine with.  I don't know if that is true for the work you are playing with.

Jim

> -----Original Message-----
> From: COSE <[email-masked]> On Behalf Of DESPERRIER Jean-Marc
> Sent: Friday, March 1, 2019 8:17 AM
> To: Matthew A. Miller <[email-masked]>; cose
> <[email-masked]>
> Subject: [COSE] Stabilising the x509 draft [was Call for Consensus: Standalone
> Hash Algorithms Document]
> 
> Hi, I'm neutral with regard to the decision about a standalone hash
> document, however I'd like to point that as  ISO/IEC JTC 1/SC 17/WG 10 has
> now decided to go forward with using COSE inside the ISO 18013-5
> document, we too would have a need for early assignment of values, to be
> able to prototype, at least for the x5chain header.
> 
> Reading the minutes, what kind of playing with the spec would be required
> to make it advance ? Try to do a sample implementation ?
> 
> Br, Jean-Marc Desperrier
> 
> De : COSE <[email-masked]> De la part de Matthew A. Miller Envoyé :
> mardi 26 février 2019 01:16 À : cose <[email-masked]> Objet : [COSE] Call for
> Consensus: Standalone Hash Algorithms Document
> 
> This messages starts a call for consensus to separate the COSE hash
> algorithms into a separate document, ending on 2018-03-10.
> 
> In the virtual interim on 02-15, it was proposed to separate them from draft-
> ietf-cose-x509, to allow the hash algorithm registrations to stabilize more
> quickly than the rest of the X.509 draft.  If the working group agrees with
> separating the algorithms, then a document will be published that consists of
> Section 4 (Hash Algorithm Identifiers) and Section 5.3 (COSE Algorithm
> Registry) from draft-ietf-cose-x509.
> 
> Please respond with whether or not you support separating the hash
> algorithms into a separate document.  If you do not support this, please
> indicate why not.
> 
> 
> - Ivaylo and Matthew
> COSE Chairs
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose