Subject: [COSE] Looking for COSE libraries and open source implementations

From: <[email-masked]>
Date: Mon, 26 Jul 2021 09:13:31 -0400

Hi Folks,

I'm looking at COSE versus more traditional alternatives, pros and cons, and
a huge cons would be access to open source implementations and libraries.

Anybody know of a good source of information about COSE libraries and open
source implementations?

I'm aware of https://github.com/cose-wg, which has some good pointers, but
they appear somewhat outdated. 

Thanks for any hints.

Gabriel

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 26 Jul 2021 13:23:01 -0700

Here’s the GitHub lookup  on the COSE key word: https://github.com/topics/cose

COSE-C is the original, but it is not maintained now: https://github.com/cose-wg/COSE-C

My own maintained implementation (just signing so far) is here: https://github.com/laurencelundblade/t_cose

LL

> On Jul 26, 2021, at 6:13 AM, g_e_montenegro=[email-masked] wrote:
> 
> Hi Folks,
>  
> I’m looking at COSE versus more traditional alternatives, pros and cons, and a huge cons would be access to open source implementations and libraries.
>  
> Anybody know of a good source of information about COSE libraries and open source implementations?
>  
> I’m aware of https://github.com/cose-wg <https://github.com/cose-wg>, which has some good pointers, but they appear somewhat outdated. 
>  
> Thanks for any hints.
>  
> Gabriel
> _______________________________________________
> COSE mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose>

---

From: <[email-masked]>
Date: Mon, 26 Jul 2021 16:33:20 -0400

Thanks, Laurence!

From: COSE <[email-masked]> On Behalf Of Laurence Lundblade
Sent: Monday, July 26, 2021 16:23
To: g_e_montenegro=[email-masked]
Cc: cose <[email-masked]>
Subject: Re: [COSE] Looking for COSE libraries and open source implementations

LL

On Jul 26, 2021, at 6:13 AM, g_e_montenegro=[email-masked] <mailto:g_e_montenegro=[email-masked]>  wrote:

Hi Folks,

I’m aware of  <https://github.com/cose-wg> https://github.com/cose-wg, which has some good pointers, but they appear somewhat outdated. 

Thanks for any hints.

Gabriel

_______________________________________________
COSE mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/cose> https://www.ietf.org/mailman/listinfo/cose

---

From: Michael Richardson <[email-masked]>
Date: Tue, 27 Jul 2021 12:06:32 -0400

> I’m looking at COSE versus more traditional alternatives, pros and
    > cons, and a huge cons would be access to open source implementations
    > and libraries.
    >

I implement enough COSE (Sign1 only) to do RFC8366/Constrained-Vouchers at:
   https://github.com/AnimaGUS-minerva/ChariWTs

I also use https://github.com/AnimaGUS-minerva/cbor-rust
from https://github.com/franziskuskiefer/cbor-rust (Mozilla).

I think that you'll find that COSE is rather a swiss-army-knife kit, and that
many users will implement (and test) what they need, and leave the rest
aside.
Given the constrained focus of COSE, you may never see an all-singing library.

Also, the way in which COSE integrates with CBOR libraries probably depends
heavily on exactly how the data will be used.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide