Subject: Re: [COSE] Looking for COSE libraries and open source implementations

From: Brian Sipos <[email-masked]>
Date: Wed, 28 Jul 2021 01:27:13 +0000

Gabriel,
For prototyping and higher-level use there is a Python library "cose" [1] with a same-named PyPi package [2] which has good test coverage and a quite robust and extensible API, though the API has gone through recent changes.
As Michael mentioned, the use of COSE, and the API needed to write or read COSE messages, is very application dependent (e.g., how many layers of key indirection is acceptable or required).

[1] https://github.com/TimothyClaeys/pycose
[2] https://pypi.org/project/cose/

Hi Folks,

I'm looking at COSE versus more traditional alternatives, pros and cons, and
a huge cons would be access to open source implementations and libraries.

Anybody know of a good source of information about COSE libraries and open
source implementations?

I'm aware of https://github.com/cose-wg, which has some good pointers, but
they appear somewhat outdated.

Thanks for any hints.

Gabriel

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 28 Jul 2021 01:32:19 +0000 (UTC)

Thanks, Brian and Michael!
    On Tuesday, July 27, 2021, 09:27:31 PM EDT, Brian Sipos <[email-masked]> wrote:  
 
  #yiv2503599085 P {margin-top:0;margin-bottom:0;}Gabriel,For prototyping and higher-level use there is a Python library "cose" [1] with a same-named PyPi package [2] which has good test coverage and a quite robust and extensible API, though the API has gone through recent changes.As Michael mentioned, the use of COSE, and the API needed to write or read COSE messages, is very application dependent (e.g., how many layers of key indirection is acceptable or required).
[1] https://github.com/TimothyClaeys/pycose[2] https://pypi.org/project/cose/

Hi Folks,

Thanks for any hints.

Gabriel
_______________________________________________
COSE mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cose