Subject: [Crisp] staring points

From: Rick Wesson <[email-masked]>
Date: Fri, 18 Feb 2005 10:02:14 -0800

could the IANA publish a welk-nown list of starting points as SRV 
records under the .int tld?

-rick

_______________________________________________
Crisp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/crisp

---

From: Jaap Akkerhuis <[email-masked]>
Date: Fri, 18 Feb 2005 20:19:40 +0100

Since it is infrastructure, something under .arpa is likely more
appropriate.

	jaap

PS. Hi Rick!

---

From: Rick Wesson <[email-masked]>
Date: Fri, 18 Feb 2005 12:06:22 -0800

Jaap,

thanks, yes, .arpa is more appropiate. How do you feel about publishing 
hints via SRV records? Would that be appropiate mechanism for pointing 
out the "top" of the tree?

-rick

---

From: Leslie Daigle <[email-masked]>
Date: Fri, 18 Feb 2005 15:01:27 -0500

Nice try; wrong tld... ;-)  The IETF decamped from  .int, and
we now use .arpa for such needs.

So, yes, SNAPTR could be used (like in DREG); areg-iris.arpa
could include appropriate NAPTR records to hand off to the
appropriate server (e.g., iris.nro.net).  As part of its
caretaking of the standard, the IETF/IAB would undertake
to make sure IANA kept its DNS up to date for areg-iris.arpa.
(It's not like it's going to be highly volatile!).

That speaks to the "enshrined location of the top AREG server"
issue; it solves some of the issues with it.

There still seems to be a question about whether there should
be a unique "top" to AREG, or whether that should be configurable
in the client.  That doesn't preclude the possibility of having
some conventionally known good/best starting places,  such as
iris.nro.net.

It's the latter that I recall Ted calling for during the
meeting (and seems to be captured in the minutes).  However,
the current AREG URI document doesn't seem to make the
distinction -- it suggests (practically) that there is one
top, and that it is located at iris.nro.net.

For myself, I think either the document should be clearer
that is *one* possible starting point and clients should be
configurable to allow others, or it should suggest
how to find the current "top" at any given time (other
than enshrining a host name).

BTW, both the AREG and AREG-URI document seem to be
registering the AREG1 namespace:

       urn:ietf:params:xml:ns:areg1

(i.e., duplicated iana considerations).

Leslie.

---

From: Shane Kerr <[email-masked]>
Date: Mon, 21 Feb 2005 10:56:56 +0100

> issue; it solves some of the issues with it.

While I understand that this is probably politically easier to do, we're 
really talking about moving the "enshrined location of the top AREG server" 
into the DNS. Saying, "start at areg-iris.arpa" isn't really that different 
from saying "start at iris.nro.net", except that the IAB runs it and not the 
NRO.

Which is not to say that I'm opposed to this, I just think we shouldn't kid 
ourselves about what the solution really adds.

> than enshrining a host name).

I don't think anybody thinks that clients should be prevented from having 
their initial query location configured on their side. Clients could even 
have a set of starting points depending on what AREG information they are 
looking for.

But... one of the reasons that the RIRs are so interested in IRIS is because 
clients have to configure these starting points today!

The main reason to want a unique "top" to AREG is that it is actually how 
number management works today - the same as DREG. Clients that follow the 
hierarchy from the top will get the "best" information possible, at least 
from a global view.

I can envision any number of scenerios where a top-down approach is not 
complete. For example, at a university it might make more sense to try a 
local AREG query first. Likewise at an exchange point each ISP peering there 
may provide an AREG server with detailed information to their peers. But I 
am fairly sure these are the exception, and nothing prevents clients from 
taking advantage of knowledge about the local network environment.

I hope the latest draft that Engin submitted over the weekend is clear 
enough to meet the desire for flexibility and having a well-defined default.

-- 
Shane Kerr
RIPE NCC

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 24 Feb 2005 13:24:38 -0500

Having read the revised version...

No, I don't think you're hearing what I'm saying.

I'm saying that:

	. if this *spec* defines a TOP starting point, then
	  make it a *name* not a *location*, so that it
	  can be updated over time (that's the NAPTR shim,
	  and I propose that areg-iris.arpa is a reasonable
	  place to host it).

	. if this *spec* does not define a single TOP starting
	  point, it is quite reasonable to separately define
	  the RIR's operational, authoritative AREG service
	  with a publicized well known TOP (iris.nro.net,
	  if you like).  That can be described & published as a
	  CRISP WG document (or maybe even as part of this
	  document, once you get the separation of concepts down).

I'm not really trying to advocate either way, I just think
it should be made clearer which the WG wants.

Right now, the document mixes the two:  you SHOULD start from
one defined top, although you MAY do whatever else you please.
That doesn't really leave room for developing other equivalently
weighted strategies (e.g., "local AREG -- you SHOULD start at
areg-iris.yourisp.net", or some such rot), which makes it
seem like a single TOP. OTOH, the fact that you can do anything
else means that it's not really a single TOP.  Pick!

Leslie.

Shane Kerr wrote:
> really talking about moving the "enshrined location of the top AREG 
> server" into the DNS. Saying, "start at areg-iris.arpa" isn't really 
> that different from saying "start at iris.nro.net", except that the IAB 
> runs it and not the NRO.
> 
> Which is not to say that I'm opposed to this, I just think we shouldn't 
> kid ourselves about what the solution really adds.
> 
> I don't think anybody thinks that clients should be prevented from 
> having their initial query location configured on their side. Clients 
> could even have a set of starting points depending on what AREG 
> information they are looking for.
> 
> But... one of the reasons that the RIRs are so interested in IRIS is 
> because clients have to configure these starting points today!
> 
> The main reason to want a unique "top" to AREG is that it is actually 
> how number management works today - the same as DREG. Clients that 
> follow the hierarchy from the top will get the "best" information 
> possible, at least from a global view.
> 
> local AREG query first. Likewise at an exchange point each ISP peering 
> there may provide an AREG server with detailed information to their 
> peers. But I am fairly sure these are the exception, and nothing 
> prevents clients from taking advantage of knowledge about the local 
> network environment.
>