Subject: Re: [Curdle] Proposal: Disallow Ed25519ph/Ed448ph for CA certificates

From: "Mehner, Carl" <[email-masked]>
Date: Sat, 11 Jun 2016 03:44:29 +0000

Sometimes I just need to have a certificate "including a 1 gigabit MPEG movie of me playing with my cat"[1]

[1] https://www.cs.auckland.ac.nz/~pgut001/pubs/x509guide.txt

> -----Original Message-----
> From: Curdle [mailto:[email-masked]] On Behalf Of Daniel Kahn
> Gillmor
> Sent: Friday, June 10, 2016 9:26 AM
> To: Nikos Mavrogiannopoulos <[email-masked]>; Brian Smith
> <[email-masked]>
> Cc: [email-masked]
> Subject: EXTERNAL: Re: [Curdle] Proposal: Disallow Ed25519ph/Ed448ph for
> CA certificates
> 
> On Fri 2016-06-10 05:18:40 -0400, Nikos Mavrogiannopoulos wrote:
> > Don't underestimate the value of the prehash variant. How would you hash
> > a 1GB file using an 8-bit smart card? Today you simply pass the hash and
> > get back and RSA or ECDSA signature, but with the ed25519 plain variant
> > you have to pipe the whole file through the card.
> 
> This proposal was just for CA certificates, though.  What CA needs to
> sign a 1GB file?
> 
>      --dkg
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Mon, 13 Jun 2016 10:12:55 +0000

Hi all,

Prehash or non-prehash, choosing the one which works well for all uses
(not just signing certs) is the right thing to do. I don¹t know how much
the non-prehash version is actually used right now (different from how
much it is supported in libraries).

Regards,
Quynh.