Subject: [Curdle] Agenda / draft status

From: "Salz, Rich" <[email-masked]>
Date: Thu, 17 Nov 2016 12:08:06 +0000

We'll go over the documents, hopefully move some along.  If you have any feedback, or in particular a *blocking item* to bring up, please reply here.

draft-ietf-curdle-cms-chacha20-poly1305-03 - pub requested
draft-ietf-curdle-cms-ecdh-new-curves-01 - ready for WGLC?
                Use of the Elliptic Curve Diffie-Hellamn Key Agreement Algorithm with X25519 and X448 in the Cryptographic Message Syntax (CMS)

draft-ietf-curdle-cms-eddsa-signatures-00 - ready for WGLC?
                Use of EdDSA Signatures in the Cryptographic Message Syntax (CMS)

draft-ietf-curdle-dnskey-eddsa-02
                EdDSA for DNSSEC

draft-ietf-curdle-pkix-02 - ready for WGLC?
                Algorithm Identifiers for Ed25519, Ed25519ph, Ed448, Ed448ph, X25519 and X448 for use in the Internet X.509 Public Key Infrastructure

draft-ietf-curdle-rsa-sha2-02 - ready for WGLC?
Use of RSA Keys with SHA-2 256 and 512 in Secure Shell (SSH)

Have we properly divided/rationalized the following three?

draft-ietf-curdle-ssh-ext-info-01
Extension Negotiation in Secure Shell (SSH)

draft-ietf-curdle-ssh-kex-sha2-05
Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (SSH)

draft-ietf-curdle-ssh-modp-dh-sha2-01
More Modular Exponential (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH)

Overall consistency and "style" issues to discuss

SHA256 v SHA512 - do we have an opinion/ recommendation?

No contexts in signature (empty context where the sig format has one.  Ok?

---

From: Russ Housley <[email-masked]>
Date: Thu, 17 Nov 2016 09:19:33 -0500

Each of these need one more rev to align with curdle-pkix, and then they will be ready for WGLC.

On Nov 17, 2016, at 7:08 AM, Salz, Rich <[email-masked]> wrote:

> draft-ietf-curdle-cms-ecdh-new-curves-01 – ready for WGLC?
> draft-ietf-curdle-cms-eddsa-signatures-00 – ready for WGLC?

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Tue, 22 Nov 2016 12:08:34 +0100

On Thu, 2016-11-17 at 12:08 +0000, Salz, Rich wrote:
> We’ll go over the documents, hopefully move some along.  If you have
> any feedback, or in particular a *blocking item* to bring up, please
> reply here.
 
>                 Use of EdDSA Signatures in the Cryptographic 
> Message  
> draft-ietf-curdle-pkix-02 – ready for WGLC?
>                 Algorithm Identifiers for Ed25519, Ed25519ph, Ed448,
> Ed448ph, X25519 and X448 for use in the Internet X.509 Public Key
> Infrastructure

Are there any implementations of the above drafts?

regards,
Nikos

---

From: Ilari Liusvaara <[email-masked]>
Date: Tue, 22 Nov 2016 18:47:17 +0200

> Are there any implementations of the above drafts?

I have an implemntation of the PKIX one (Ed25519 and Ed448 only, no pre-
hash variants).

-Ilari

---

From: Ondřej Surý <[email-masked]>
Date: Tue, 22 Nov 2016 18:06:00 +0100 (CET)

PowerDNS has a preliminary implementation of Ed25519 support using SUPERCOP.

And I have written crude RRSIG generator to generate examples in DNSKEY draft using python3 library from cfrg-eddsa draft:
https://gitlab.labs.nic.cz/labs/ietf/blob/master/dnskey.py

Cheers,
Ondrej

--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Original Message -----
> From: "Nikos Mavrogiannopoulos" <[email-masked]>
> To: "Salz, Rich" <[email-masked]>, "curdle" <[email-masked]>
> Sent: Tuesday, 22 November, 2016 12:08:34
> Subject: Re: [Curdle] Agenda / draft status

> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: Daniel Migault <[email-masked]>
Date: Tue, 22 Nov 2016 19:17:11 +0000

Hi Ondrej, 

Thanks for the information!

Yours, 
Daniel

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Ondrej Surý
Sent: Tuesday, November 22, 2016 12:06 PM
To: Nikos Mavrogiannopoulos <[email-masked]>
Cc: Salz, Rich <[email-masked]>; curdle <[email-masked]>
Subject: Re: [Curdle] Agenda / draft status

Cheers,
Ondrej

----- Original Message -----

>>                 Use of EdDSA Signatures in the Cryptographic Message

---

From: Jim Schaad <[email-masked]>
Date: Tue, 22 Nov 2016 13:05:18 -0800

> From: Curdle [mailto:[email-masked]] On Behalf Of Nikos
> Mavrogiannopoulos
> Sent: Tuesday, November 22, 2016 3:09 AM
> To: Salz, Rich <[email-masked]>; [email-masked]

What do you consider to be an implementation?  

The certificate at the end of draft-ietf-curdle-pkix-02 is created by a program that was generated in part from the ASN.1 module.  The rest of the examples were also generated in the same way, but this is not a CA and I did not setup so that I could use the certificate in a browser or email program.

I have done a paper fill in the fields for the cms draft, which lead to several changes in the draft over the last week as we tried to get things correct, but I have not yet done the same thing in an ASN.1 structure and then encoded it using a program.  However, again this is not going to be like it is an Email client implementing S/MIME.  

Jim

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Wed, 23 Nov 2016 09:32:20 +0100

> I have an implemntation of the PKIX one (Ed25519 and Ed448 only, no

Thanks, it is available somewhere? I am gathering references to carry
interop testing once I have something more tangible for gnutls.

regards,
Nikos